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Module overview 
Description 
Sharing data is a common requirement of daily communication. You must be able to 
consolidate the data you work with and present it in a way that makes it easier for 
viewers to understand. 

When you reach the end of this module, you'll be able to apply advanced conditional 
formatting rules; format, summarize, and validate data; and use and configure language 
options. 

Lesson Learning objective Exam objective(s) 

Understanding 
conditional 
formatting 
rules 

Apply advanced conditional formatting. • 2.3.1 
• 2.3.2 

Managing 
rules and 
customizing 
formats 

Manage advanced conditional formatting 
and apply custom number formatting.  

• 2.3.3 
• 2.2.1 

Grouping data Group and ungroup data. • 2.2.3 
• 2.2.4 

Consolidating 
data and 
configuring 
language 
options 

Summarize data and use and configure 
language options. 

• 3.4.1 
• 1.3.2 
• 1.3.1 
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Lesson Learning objective Exam objective(s) 

Cornerstone: 
Depicting 
energy 
consumption 

Apply advanced conditional formatting, 
format and validate data, and use and 
configure language options. 

• 2.3.1 
• 2.3.2 
• 2.3.3 
• 2.2.1 
• 2.2.3 
• 2.2.4 
• 3.4.1 
• 1.3.2 
• 1.3.1 

Table 1: Objectives by lesson 

Scenario 
Munson’s Pickles and Preserves farm is committed to sustainable energy production and 
water conservation. The location of the farm has an extremely favorable climate for 
natural energy production. Last year they invested in a solar array to provide electricity 
for their current needs. They are considering wind energy for future farm expansion. 

As part of an international community of farm-to-table producers, Munson's needs to 
share the data on energy consumption report with farmers across multiple 
countries/regions. A colleague has collected data and needs your help to depict the 
energy productions, consumption, and related costs and to see totals at a glance. 

Cornerstone 
This module concludes with a Cornerstone in which you’ll update the application form 
for the upcoming summer camp at Munson’s. In the cornerstone, you’ll: 

• Create custom conditional formatting rules and conditional formatting rules that use 
formulas. 

• Manage conditional formatting rules and create custom number formats. 
• Group and ungroup data and calculate data by inserting subtotals and totals. 
• Summarize data from multiple ranges by using the Consolidate feature, use 

language-specific features, and configure editing and display languages. 
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Lesson 1: Understanding 
conditional formatting rules 
Overview 
Conditional formatting makes it easier to highlight specific values or make certain cells 
stand out. This changes the appearance of a cell range based on a condition (or criteria) 
that you specify. In this lesson, you'll learn to create custom conditional formatting. 

Warm-up 
Use these questions to find out what you already know about this lesson’s topics. 

1. What's another name for the conditions used in conditional formatting? 

Select the correct option. 

a. Specifics 

b. Criteria  

c. Labels 

d. Situation 

2. You can use conditional formatting to change the ________________________ of cell(s) 
based on a conditional rule. 

Fill in the blank space. 

Topic 1: Customize conditional 
formatting rules 

 By using conditional formatting in Microsoft Excel 2019, you can quickly highlight 
data based on some prebuilt rules. In this topic, you'll learn how to apply and modify 
built-in conditional formatting rules. 
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Create custom conditional formatting rules 
To create a custom conditional formatting rule in the Excel User Interface (UI), perform 
the following steps: 

1. Open the Excel 2019 spreadsheet you want to work in. 

2. Select the cells you want to apply conditional formatting to. 

3. On the Home tab, in the Styles group, select the Conditional Formatting drop-
down box, and then select New Rule. The following screenshot depicts this process. 

 
Figure 1: New Rule option in the Conditional Formatting drop-down box 
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4. In the New Formatting Rule dialog box, in the Select a Rule Type box, select a rule 
type, as the following screenshot depicts. 

 
Figure 2: New Formatting Rule dialog box 

5. In the Edit the Rule Description section, make the changes  you need. 

6. Select OK. 

 

Additional information 

To review the tutorial on conditional formatting, go to: Highlight 
patterns and trends with conditional formatting 

 

Video 

To review the video on conditional formatting, go to: Use conditional 
formatting 

To review the video on intermediate conditional formatting, go to: 
Intermediate conditional formatting 

https://aka.ms/Highlight-patterns-and-trends-with-conditional-formatting
https://aka.ms/Highlight-patterns-and-trends-with-conditional-formatting
https://aka.ms/Conditional_formatting
https://aka.ms/Conditional_formatting
https://aka.ms/video-intermediate-conditional-formatting
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Did you know? 

You can use the prebuilt options in the Conditional Formatting 
drop-down box to quickly create rules to format your cells. In just a 
few steps, you can highlight the data by using data bars, color scales, 
or icon sets. 

Activity: Think-pair-share 
In this activity, the teacher will demonstrate how to customize conditional formatting to 
meet unique criteria. 

Resources required 
You'll need the following resources for this activity: 

• None 

Activity instructions 
Participate in the activity by following these instructions: 

1. Observe the teacher demonstrate how to customize conditional formatting. 

2. Ask the teacher clarifying questions. An example is: How can I highlight the largest 
value? 

3. Think about how you might customize the teacher's example to make it better; 
consider recording your idea(s) on a sticky note(s) or in a Word document. 

4. Trade your idea(s) with the student(s) next to you. 

Try-it: Customize conditional formatting rules 
 In this standalone try-it activity, you'll create a custom formatting rule to highlight 

the highest and lowest values in a range of cells. 
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Try-it 
Resources 
You'll need the following resources for this try-it: 

• Open L1_T1_try_energy_costs_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Add a conditional formatting rule to highlight the highest value in cells B2:H13 on 
the Energy Consumption worksheet. 

2. Format the cells as Bold with the background color as Blue, Accent 2, Lighter 80%. 

3. Add a conditional formatting rule to highlight the lowest value in cells B2:H13 on 
the Energy Consumption worksheet. 

4. Format the cell as Bold with the background color as Blue, Accent 2, Lighter 80%. 

Topic 2: Use formulas for conditional 
formatting 

 Excel provides many drop-down box options for creating custom conditional 
formatting. However, by using formulas, you can create unique conditional formatting 
rules. In this topic, you'll learn to use formulas for conditional formatting rules. 

Create custom conditional formatting rules with 
formulas 
To create a custom conditional formatting rule by using formulas, perform the following 
steps: 

1. Select the cells you want to apply conditional formatting to. 

2. On the Home tab, in the Styles group, select the Conditional Formatting drop-
down box, and then select New Rule. 
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3. In the New Formatting Rule dialog box, in the Select a Rule Type box, select Use a 
formula to determine which cells to format. 

 
Figure 3: Select a Rule Type box 

4. In the Edit the Rule Description section, in the Format values where this formula 
is true box, enter the formula. 

5. Set formatting as desired. 

6. Select OK. 

 

Additional information 

To review the tutorial on conditional formatting with formulas, go to: 
Use conditional formatting to highlight information 

 

Video 

To review the video on conditional formatting with formulas, go to: 
Use formulas to apply conditional formatting 

https://aka.ms/Use-formulas-with-conditional-formatting
https://aka.ms/Video-Use-formulas-to-apply-conditional-formatting
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Did you know? 

If you took the Excel associate 2019 course, you can use the formulas 
you learned to create custom conditional formatting. You can also 
use the advanced formulas you'll learn in Module 2 of this course to 
create custom conditional formatting. 

Activity: Show and learn 
In this activity, your teacher will demonstrate how to use a formula for the criteria for 
conditional formatting rules. 

Resources required 
You'll need the following resources for this activity: 

• None 

Activity instructions 
Participate in the activity by following these instructions: 

1. Observe the teacher demonstrate how to customize conditional formatting using a 
formula. 

2. Ask the teacher clarifying questions. An example is: How can I highlight all values 
above a certain amount? 

3. Think of formulas that you might use to highlight data in a range of cells. 

Try-it: Use formulas for conditional formatting 
 In this standalone try-it activity, you'll use a formula to highlight the above-

average values in a range of cells. 
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Try-it 
Resources 
You'll need the following resources for this try-it: 

• Open L1_T2_try_energy_costs_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Add a conditional formatting rule to highlight the above-average values in cells 
B2:H13 on the Energy Consumption worksheet. 

2. Format these cells as Bold, Blue, Accent 2, Lighter 80%. 

Wrap-up 
Use these questions to check what you learned in this lesson:  

1. What is the name of the dialog box in which you select a rule type for a new rule? 

Select the correct option. 

a. New Conditional Rule 

b. New Rule 

c. New Formatting Rule 

d. New Description 

2. Prebuilt conditional formatting rules include: 

Select all that apply. 

a. Sparklines 

b. Icon sets 

c. Data bars 

d. Color scales 

3. When you’re creating a new conditional formatting rule, you must edit the rule 
________________________ 

Fill in the blank space. 
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Lesson 2: Managing rules and 
customizing formats 
Overview 
When you get to the end of this lesson, you'll be able to manage advanced conditional 
formatting and apply custom number formatting. Conditional formatting rules allow you 
to control how you highlight and call out information on your worksheets. 

Warm-up 
Use these questions to find out what you already know about this lesson’s topics: 

1. What is the maximum number of sections a number format can have? 

Select the correct option. 

a. One 

b. Five 

c. Four 

d. Seven 

2. What must you use to separate sections of a number format? 

Select the correct option. 

a. Comma 

b. Semicolon 

c. Parenthesis 

d. Brackets 

3. Excel applies conditional formatting rules in order of ________________________ 

Fill in the blank space. 
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Topic 1: Manage conditional formatting 
rules 

 When you apply multiple conditional formatting rules to the same range of cells, 
conditional formatting will occur in order of precedence (from top to bottom). Some 
rules might cancel out other rules, even if that wasn't your intention. Copying and 
pasting cells that have conditional formatting applied might lead to unintended 
formatting consequences. In this topic, you'll learn how to find and manage conditional 
formatting rules. 

Manage conditional formatting rules 
To manage conditional formatting rules, perform the following steps: 

1. Open a worksheet that has conditional formatting applied to cells and then select 
the cells that you want to manage rules for. 

2. On the Home tab, in the Styles group, select the Conditional Formatting drop-
down box, and then select Manage Rules. 

 
Figure 4: Conditional Formatting drop down in the Styles group of the Home tab 
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3. In the Conditional Formatting Rules Manager dialog box, in the Show formatting 
rules for drop-down box, select This Worksheet, as the following screenshot 
depicts. 

 
Figure 5: Show formatting rules for drop-down box 

4. In the Rule (applied in order shown) column, select the desired rule and then select 
from the following options: 

o Move up (˄) to move the rule higher in precedence 
o Move down (˅) to move the rule lower in precedence 
o Edit Rule to make changes to the rule 
o Delete Rule to delete the rule 
o New Rule to create a new rule 
o Stop if True checkbox to stop applying rules that might conflict with the selected 

rule 
o Applies to box to change the range of cells the rule applies to 

  

Additional information 

To review the tutorial on managing conditional formatting rules, go to: 
Use conditional formatting to highlight information 

 

Video 

To review the video on managing conditional formatting rules, go to: 
Manage conditional formatting 

https://aka.ms/Manage-conditional-formatting-rule-precedence
https://aka.ms/video-manage-conditional-formatting
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Activity: Discuss and learn 
The teacher demonstrates how to manage conditional formatting rules. 

Resources required 
You'll need the following resources for this activity: 

• None 

Activity instructions 
Participate in the activity by following these instructions: 

1. Observe the teacher demonstrate how to manage conditional formatting rules. 

2. Ask the teacher clarifying questions. An example is: How can I stop rules from 
conflicting? 

Try-it: Manage conditional formatting rules 
 In this leveled try-it activity, you'll manage the conditional formatting in the 

worksheet to depict the top 10 values in a bold font and the bottom 10 values in an 
italic font. You’ll also use an icon set to depict the highest, middle, and lowest values. 

Try-it 1 
Resources 
You'll need the following resources for this try-it: 

• Open L2_T1_try1_energy_costs_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Find the cells that have conditional formatting. 

2. Delete the data bars, icon set, and color scale conditional formatting. 
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Try-it 2 
Resources 
You'll need the following resources for this try-it: 

• Open L2_T1_try2_energy_costs_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Delete the Top 10 and Bottom 10 conditional formatting rules. 

2. Change the Top 10% and Bottom 10% conditional formatting rules to Top 10 and 
Bottom 10 conditional formatting rules 

Topic 2: Customize number formats 
 You can use number formats to change the appearance of numbers, including 

dates and times, without changing the actual number. The number format does not 
affect the cell value. The actual cell value is displayed in the Formula Bar. 

Excel provides several built-in number formats. You can use these built-in formats as is, 
or you can use them as a starting point to customize your own number formats. 

A number format can have up to four sections, separated by semicolons. These sections 
define the format for positive numbers, negative numbers, zero, and text, in that order, 
as depicted in the following format: 

<POSITIVE>;<NEGATIVE>;<ZERO>;<TEXT> 

The following is an example of a number format: 

#,##0.00_);[Red](#,##0.00);0.00;"costs "@ 

You do not have to include all sections in your custom number format. When you create 
custom number formats, keep in mind the following points: 

• If you use only two sections for your custom number format, the first section is used 
for positive numbers and zeros; the second section is used for negative numbers. 

• If you use only one code section, it is used for all numbers. 
• If you want to skip a section and include a section that follows it, you must include 

the semicolon separator for the section that you skip. 
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Use prebuilt custom number features 
To use prebuilt custom number features, perform the following steps: 

1. Select the cell(s) to format. 

2. On the Home tab, in the Number group, select the Number Format drop-down 
box, which the following screenshot depicts, and then select the desired format. 

 
Figure 6: Number Format drop-down box in the Number group of the Home tab 

3. To make additional quick changes to the formatting, use the following buttons in the 
Number group of the Home tab: 

o Accounting Number Format ($) drop-down box to format as dollars, euros, or 
other currency 

o Percent Style (%) to format as a percent 
o Comma Style (,) to format with thousands separator 
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o Increase Decimal to display more decimal places 
o Decrease Decimal to display fewer decimal places 
The following screenshot depicts the Number group on the Home tab. 

 
Figure 7: Number group of the Home tab 

Customize a number format 
To customize a number format, perform the following steps: 

1. Select the cell(s) to format. 

2. On the Home tab, in the Number group, select the Number Format drop-down 
box, and then select More Number Formats. 
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Figure 8: More Number Formats option 

3. In the Format Cells dialog box, in the Type box, enter your custom number format. 
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Figure 9: Format Cells dialog box 

Hint: It's easier if you pick one of the prebuilt number formats first and then customize 
it. For example, you can select the following prebuilt number format for Accounting in 
the Number Format drop-down box in the Number group: 

 _($* #,##0.00_);_($* (#,##0.00);_($* "-"??_);_(@_)  

and change it to the following format in the Type box in the Format Cells dialog 
window: 

 _($* #,##0.00_);[Red]_($* (#,##0.00);_($* "-"??_);_(@_)  

When you make this change, negative numbers display in red with parentheses. 
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Additional information 

To review the guidelines on number formats, go to: Review guidelines 
for customizing a number format 

To review the tutorial on combining numbers and text, go to: Combine 
text and numbers 

 

Video 

To review the video on custom number formats, go to: Create a 
custom number format 

Activity: Discuss and learn 
In this activity, your teacher will demonstrate multiple methods to customize number 
formats. 

Resources required 
You'll need the following resources for this activity: 

• None 

Activity instructions 
Participate in the activity by following these instructions: 

1. Observe the teacher demonstrate how to customize number formatting. 

2. Ask the teacher clarifying questions. An example is: How can I make negative 
numbers appear red? 

Try-it: Customize number formats 
 In this standalone try-it activity, you'll create several custom number formats. 

  

https://aka.ms/review-guidelines-for-customizing-a-number-format
https://aka.ms/review-guidelines-for-customizing-a-number-format
https://aka.ms/combine-text-and-numbers
https://aka.ms/combine-text-and-numbers
https://aka.ms/Create_custom_numeric_format
https://aka.ms/Create_custom_numeric_format
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Try-it 
Resources 
You'll need the following resources for this try-it: 

• Open L2_T2_try_energy_costs_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Change date to show the short date and time. 

2. Change number formatting for cells B2:H13 on the Production worksheet to 
separate thousands with a comma, use no decimal points, and include Jars after the 
number. 

3. Change number formatting for cells B2:H13 on the Balance worksheet to currency 
with no decimal points and showing negative values in red with parenthesis. 

Wrap-up 
Use these questions to check what you learned in this lesson: 

1. If you use only one section in a number format, Excel applies it to: 

Select the correct option. 

a. Positive numbers 

b. Positive numbers and zero 

c. All numbers 

d. Negative numbers 

2. What are the main options available in the Conditional Formatting Rules Manager 
dialog box? 

Select all that apply. 

a. New Rule 

b. Delete Rule 

c. Edit Rule 

d. Reverse Rule 
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3. The easiest method to find all conditional formatting rules on a worksheet is to use 
________________________ option in the Show formatting rules for list in the 
Conditional Formatting Rules Manager dialog box. 

Fill in the blank space. 

4. Specify the correct order for the four sections available for number formatting. 

Indicate the correct sequence by adding numbers 1–4 next to the following items. 

a. Negative numbers – ________________________ 

b. Zero – ________________________ 

c. Text – ________________________ 

d. Positive numbers – ________________________ 
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Lesson 3: Grouping data 
Overview 
When you get to the end of this lesson, you'll be able to group and ungroup data and 
use subtotals and totals to make data calculations. By grouping data, you can quickly 
expand and collapse data to display details and subtotals. 

Warm-up 
Use these questions to find out what you already know about this lesson’s topics: 

1. How many levels can you have in an outline? 

Select the correct option. 

a. Five 

b. Two 

c. Eight 

d. Six 

2. Which of the following are selections you can make in the Subtotal dialog box? 

Select all that apply. 

a. Group by 

b. At each change in 

c. Use function 

d. Add subtotal to 
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Topic 1: Group and ungroup data 
 By grouping data, you can create an outline of the data. You can then expand or 

collapse this outline to quickly display summary rows or columns, or to reveal the detail 
data for each group. 

If you want to group data, you must first organize it into a format that is compatible 
with grouping. You must also make sure that: 

• Each column of the data that you want to outline has a label in the first row; for 
example, Season. 

• The data contains similar facts in each column. 
• The range you want to outline has no blank rows or columns. 
You can have up to eight levels of outline, but to have multiple groups in a level, you 
must have subtotal rows or columns. 

Group data 
To group data, perform the following steps: 

1. Select the cells you want to group. 

2. On the Data tab, in the Outline group, select the Group drop-down box. 

 
Figure 10: Group options in the Outline group 

3. Select Group or Auto Outline. 

Note: Auto Outline only works if you've added summary rows or columns 
(subtotals) to your data. 

4. If you select Group, in the Group dialog box, select Rows or Columns, and then 
select OK. 
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Figure 11: Group dialog box 

Ungroup data 
To ungroup data, perform the following steps: 

1. Select the cells you want to ungroup. 

2. On the Data tab, in the Outline group, select the Ungroup drop-down box. 

 
Figure 12: Ungroup options in the Outline group 

3. Select Ungroup to clear the grouping of the selection or select Clear Outline to 
remove the entire outline. 

4. If you select Ungroup, in the Ungroup dialog box, select Rows or Columns. 

 
Figure 13: Ungroup dialog box 

 

Additional information 

To review the tutorial on grouping, go to: Outline (group) data in a 
worksheet 

https://aka.ms/Outline-group-data-in-a-worksheet
https://aka.ms/Outline-group-data-in-a-worksheet
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Activity: Discuss and learn 
In this activity, your teacher will demonstrate how to group and ungroup rows and 
columns of data. 

Resources required 
You'll need the following resources for this activity: 

• None 

Activity instructions 
Participate in the activity by following these instructions: 

1. Observe the teacher demonstrate how to group columns and rows of data. 

2. Ask the teacher clarifying questions. An example is: How can I group data that is not 
subtotaled? 

Try-it: Group and ungroup data 
 In this standalone try-it activity, you'll group and ungroup data in a preformatted 

range of cells. 

Try-it 
Resources 
You'll need the following resources for this try-it: 

• Open L3_T1_try_energy_costs_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Group columns of the C1:G14 cells on the KWh worksheet. 

2. Auto Outline the A1:J18 cells on the Cost worksheet. 

Topic 2: Subtotal data 
 You can automatically calculate subtotals and grand totals in a list for a column by 

using the Subtotal command. This is very useful when you have long lists of numbers. 
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Insert subtotals in a list of data 
1. Select the list of data you want to subtotal. 

2. Select the Data tab. 

3. Select Subtotal in the Outline group. 

4. In the Subtotal dialog window, make the following selections: 

a. At each change in: —select the category you want to subtotal 

b. Use function: —select the calculation you want to use for the subtotal values 

c. Add subtotal to: —select the column(s) of values you want to subtotal 

d. Choose desired options in checkboxes 

 
Figure 14: Subtotal dialog box 

5. Repeat for each category you want to subtotal values for. 

Note: Grand totals are added automatically. 

 

Additional information 

To review the tutorial on creating subtotals and totals, go to: Insert 
subtotals in a list of data in a worksheet 

https://aka.ms/insert-subtotals-in-a-list-of-data-in-a-worksheet
https://aka.ms/insert-subtotals-in-a-list-of-data-in-a-worksheet
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Activity: Discuss and learn 
The teacher will demonstrate inserting subtotals and totals in a list of data. 

Resources required 
You'll need the following resources for this activity: 

• None 

Activity instructions 
Participate in the activity by following these instructions: 

1. Observe the teacher demonstrate how to insert subtotals and totals in a list of data. 

2. Ask the teacher clarifying questions. An example is: How can I insert subtotals for a 
specific group of data? 

Try-it: Subtotal data 
 In this standalone try-it activity, you'll insert subtotals and totals in a list of data. 

Try-it 
Resources 
You'll need the following resources for this try-it: 

• Open L3_T2_try_energy_costs_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

• Insert subtotals for an average of costs for the seasons and months in the list of data 
on the Cost worksheet. 
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Wrap-up 
Use these questions to check what you learned in this lesson:  

1. Select the requirements for data grouping. 

Select all that apply. 

a. A label in the first row  

b. A total in the last row 

c. Similar facts in each column 

d. No blank rows or columns in the selected range  

2. Select the functions you can apply as subtotals. 

Select all that apply. 

a. Average 

b. Sum 

c. Concatenate 

d. Count 

3. If you want to use Auto Outline, your data must have ________________________ rows 
or columns. 

Fill in the blank space. 
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Lesson 4: Consolidating data 
and configuring language 
options 
Overview 
When you get to the end of this lesson, you'll be able to summarize data and pull 
together data from many sources. You'll also be able to use and configure language 
options when you need to share files with persons who speak a different language. 

Warm-up 
Use these questions to find out what you already know about this lesson’s topics: 

1. What do you use to add new words to Office apps? 

Select the correct option. 

a. Custom Encyclopedia 

b. Custom Words 

c. Custom Dictionary 

d. Custom Spell check 

2. What can you use to change text case? 

Select the correct option. 

a. Proofing 

b. Formulas 

c. Spell check 

d. The Review tab 
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3. What options are available for different languages?

Select all that apply.

a. Display

b. Translation

c. Editing

d. Help

4. Use the Consolidate feature to consolidate data from multiple
________________________.

Fill in the blank space.

Topic 1: Consolidate data 
 When you work with Excel, you might often have to work with data from multiple 

worksheets in multiple files. To make it easier to manage this data, you’ll need to 
consolidate it into a single file. In this lesson, you'll learn how to consolidate data from 
multiple worksheets/workbooks. 

Consolidate data from multiple workbooks 
To consolidate data from multiple workbooks, perform the following steps: 

1. Open the workbooks that contain the data you want to consolidate.

2. Make sure the data in each worksheet meets the following criteria:

a. Each range of data is in list format.

b. Each column has a label (header) in the first row and contains similar data.

c. There are no blank rows or columns anywhere in the list.

d. Each range has the same layout.

e. Each range is on a separate worksheet.

3. Open a new file for the primary worksheet. Don't enter anything in the primary
worksheet where you plan to consolidate the data. Excel will do this for you.

4. Place your cursor in the first cell where you want to consolidate your data.
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5. On the Data tab, in the Data Tools group, select Consolidate, as the following 
screenshot depicts. 

 
Figure 15: Consolidate option in the Data Tools group of the Data tab 

6. In the Consolidate dialog box, select the type of Function. 

7. Select the Collapse dialog on the Reference: box, which the following screenshot 
depicts. 

 
Figure 16: Consolidate dialog box 

8. Go to the worksheet and select your first data range. 

9. In the Consolidate dialog box, select the Expand dialog on the Reference box, and 
then select Add. 

10. Repeat steps 8 and 9 for the remaining data ranges you want to consolidate. 
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11. Select from the following checkboxes: 

a. Select Top row to include all the top row labels. Leave clear if you want to 
summarize the data into one column. 

b. Select Left column to include all the left column labels. 

c. Select Create links to source data to link the data to the primary worksheet. 

12. Select OK. 

 

Additional information 

To review the video on consolidate, go to: Consolidate data in multiple 
worksheets 

Activity: Tell a story 
The values for energy consumption at Munson’s are recorded on different worksheets 
for each year, but you need to study trends for five years. To do this, you need to 
consolidate the data on one worksheet. The teacher will demonstrate how to 
consolidate the data from the different workbooks into one file by using the 
Consolidate option. 

Resources required 
You'll need the following resources for this activity: 

• None 

Activity instructions 
Participate in the activity by following these instructions: 

1. Observe the teacher demonstrate how to consolidate data from multiple worksheets. 

2. Ask the teacher clarifying questions. An example is: How can I consolidate data from 
multiple files? 

Try-it: Consolidate data 
 In this standalone try-it activity, you'll consolidate the data from five files into one 

primary workbook. 

  

https://aka.ms/consolidate-data-in-multiple-worksheets
https://aka.ms/consolidate-data-in-multiple-worksheets
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Try-it 
Resources 
You'll need the following resources for this try-it: 

• Open L4_T1_try_energy_costs_2015_starter.xlsx, 
L4_T1_try_energy_costs_2016_starter.xlsx, 
L4_T1_try_energy_costs_2017_starter.xlsx, 
L4_T1_try_energy_costs_2018_starter.xlsx, and 
L4_T1_try_energy_costs_2019_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Open a new file, which will be the primary file. 

2. Consolidate the data from the following sources into the new file: 

a. The L4_T1_try_energy_costs_2015_starter.xlsx file with cells A1:B8 on the KWh 
worksheet as the data range. 

b. The L4_T1_try_energy_costs_2016_starter.xlsx file with cells A1:B8 on the KWh 
worksheet as the data range. 

c. The L4_T1_try_energy_costs_2017_starter.xlsx file with cells A1:B8 on the KWh 
worksheet as the data range. 

d. The L4_T1_try_energy_costs_2018_starter.xlsx file with cells A1:B8 on the KWh 
worksheet as the data range. 

e. The L4_T1_try_energy_costs_2019_starter.xlsx file with cells A1:B8 on the KWh 
worksheet as the data range. 

3. Select the Top row check box in the Consolidate dialog box to include all the top 
row labels. 

4. Select the Left column check box in the Consolidate dialog box to include all the 
left column labels. 

5. Close the L4_T1_try_energy_costs_2015_starter.xlsx, 
L4_T1_try_energy_costs_2016_starter.xlsx, 
L4_T1_try_energy_costs_2017_starter.xlsx, 
L4_T1_try_energy_costs_2018_starter.xlsx, and 
L4_T1_try_energy_costs_2019_starter.xlsx files. 

6. Save the primary file with a new name. 
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Topic 2: Use language-specific features 
 Throughout the world, all languages add new words every day. In this topic, you'll 

learn how to customize the dictionary in Excel so that you can add new words to it. 
You’ll also use formulas to change the case of text. 

Add new words to the custom dictionary by using 
Backstage 
To add new words to the dictionary from the Backstage view, perform the following 
steps: 

1. Select the File tab, and then in the navigation pane, select Options. 

2. In the Excel Options dialog box, in the navigation pane, select the Proofing tab. 

 
Figure 17: Excel Options dialog box 
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3. Select Custom Dictionaries. 

4. In the Custom Dictionaries dialog box, select RoamingCustom.dic. 

 
Figure 18: Custom Dictionaries dialog box 

5. Select Edit Word List. 

6. In the RoamingCustom.dic dialog box, in the Word(s) box, enter the new word. 

 
Figure 19: RoamingCustom.dic dialog box 

7. Select Add. 

8. Select OK. 
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Add new words to the custom dictionary by using 
Spelling 
To use the Spelling option to add new words to the dictionary, perform the following 
steps: 

1. On the Review tab, in the Proofing group, select Spelling.  

 
Figure 20: Proofing group of the Review tab 

2. In the Spelling dialog box, ensure that the word you want to add is in the Not in 
Dictionary box, and then select Add to Dictionary. 

 
Figure 21: Spelling dialog box 
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Use a formula to change text case 
To change text case by using formulas, perform the following steps: 

1. Select the cell where you want the changed text to appear. 

2. Enter the following formula in the cell, substituting XX for the cell row and column 
where the text to be changed is located: 

a. =UPPER(XX) to change the text in cell XX to upper case 

b. =LOWER(XX) to change the text in cell XX to lower case 

c. =PROPER(XX) to change the text in cell XX to proper case 

For example, enter =UPPER(A1) to change the text from cell A1 to upper case in the 
cell with the formula. 

 

Additional information 

To review the tutorial on changing words in the dictionary, go to: Add 
or edit words in a spell check dictionary 

To review the tutorial on changing text case, go to: Change the case of 
text 

Activity: Show me how 
In this activity, your teacher will demonstrate how to add new words to the dictionary 
and change text case by using formulas. 

Resources required 
You'll need the following resources for this activity: 

• None 

Activity instructions 
Participate in the activity by following these instructions: 

1. Observe the teacher demonstrate how to add new words to the dictionary and use 
formulas to change the text case. 

2. Ask the teacher clarifying questions. An example is: How can I use Spell Check to add 
words to the dictionary? 

  

https://aka.ms/Add-or-edit-words-in-a-spell-check-dictionary
https://aka.ms/Add-or-edit-words-in-a-spell-check-dictionary
https://aka.ms/Change-the-case-of-text
https://aka.ms/Change-the-case-of-text


Managing and formatting data 
 

 
42 

Try-it: Use language-specific features 
 In this leveled try-it activity, you'll add words to the custom dictionary by using the 

Spelling option and Backstage. You'll also use formulas to change the text case. 

Try-it 1 
Resources 
You'll need the following resources for this try-it: 

• Open L4_T2_try1_new_word_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Select the Spelling option. 

2. When prompted, add the word Weedily to the dictionary. 

Try-it 2 
Resources 
You'll need the following resources for this try-it: 

• None 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Open Excel. 

2. Select File to go to Backstage view. 

3. Open the Excel Options dialog box. 

4. Add the new word transload to the RoamingCustom.dic dictionary. 
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Try-it 3 
Resources 
You'll need the following resources for this try-it: 

• Open L4_T2_try3_change_case_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Enter the formula to replicate the content in cells A2:A7 as upper case in each 
corresponding cell in B2:B7. 

2. Enter the formula to replicate the content in cells A2:A7 as lower case in each 
corresponding cell in C2:C7. 

3. Enter the formula to replicate the content in cells A2:A7 in the same case in each 
corresponding cell in D2:D7. 

Topic 3: Configure the editing and 
display languages 

 In an interconnected world, it's important to be able to share your files with others 
who might not speak the same language. In this topic, you'll learn how to configure the 
editing and display language options. Editing language features set up language-
specific proofing tools such as spelling, grammar checking, and sorting. Bilingual 
speakers can customize settings for what works best for them. For example, they can set 
the Help display to the language most familiar to them while setting the editing 
language to the language in which they’ll share the document. By setting display and 
editing languages, you do not translate documents from one language to another. 

Add a language 
To add a language to Excel, perform the following steps: 

1. Open Excel. 

2. Select the File tab, and then in the navigation pane, select Options. 

3. In the Excel Options dialog box, in the navigation pane, select the Language tab. 
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Figure 22: Excel Options dialog box 

4. In the Office authoring languages and proofing section, select Add a language. 

5. Choose the desired language, and then select Add. 

6. In the Excel Options dialog box, select OK. 

7. Restart Excel. 

Change Display Language 
To change your display language, perform the following steps: 

1. After adding additional editing languages, open Excel. 

2. Select the File tab, and then in the navigation pane, select Options. 

3. In the Excel Options dialog box, in the navigation pane, select the Language tab. 

4. In the Office Display Language section, select the language. 

5. Select OK. 
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Additional information 

To review the tutorial on adding an editing language, go to: Add an 
editing language or set language preferences in Office 

Activity: Tell a story 
Munson's has contacts worldwide, which makes it necessary for you to share your 
workbooks with persons in Canada and Mexico. It is therefore important that you use 
appropriate spelling and grammar when you’re using phrases or words in those 
languages. In this activity, your teacher will demonstrate how to change the editing 
language of your workbook. 

Resources required 
You'll need the following resources for this activity: 

• None 

Activity instructions 
Participate in the activity by following these instructions: 

1. Observe the teacher demonstrate how to add Canadian French as an editing 
language. 

2. Ask the teacher clarifying questions. An example is: How can I change the display 
language? 

Try-it: Configure the editing and display languages 
 In this standalone try-it activity, you’ll add the Mexican Spanish editing language. 

Try-it 
Resources 
You'll need the following resources for this try-it: 

• None 
  

https://aka.ms/add-an-editing-language-or-set-language-preferences-in-office
https://aka.ms/add-an-editing-language-or-set-language-preferences-in-office
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Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Open Excel. 

2. Add Mexican Spanish as an additional editing language. 

Wrap-up 
Use these questions to check what you learned in this lesson:  

1. What formulas can you use to change text case? 

Select all that apply. 

a. UPPER 

b. MIDDLE 

c. LOWER 

d. PROPER 

2. What two options can you use to add new words to the custom dictionary? 

Select the correct options. 

a. The spell checker 

b. References 

c. The Backstage view 

d. Dictation 

3. By adding a language to your language settings, you can enable additional 
________________________ tools for that language. 

Fill in the blank space. 

4. To summarize data, which of the following functions can you use with the 
Consolidate feature? 

Select all that apply. 

a. Sum 

b. Average 

c. Product 

d. Dividend 
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5. Selecting the ________________________ check box when consolidating data will give you
all the columns of data instead of summarizing the data.

Fill in the blank space.

Glossary 
Conditional 
Formatting 

Formatting the appearance of cells associated with specified criteria. 

Data Consolidation Pulling together data from multiple worksheets. 

Formula Excel functions and parameters that you use to perform calculations. 

Grouped data An outline of data that you can expand or collapse to quickly display 
summary rows or columns. 

Table 2: Glossary terms and definitions 
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Cornerstone 
Overview 
In this Cornerstone, you’ll work on the energy consumption data at Munson’s. You’ll 
format the data, highlight specific energy costs, group and consolidate data, and make 
language and editing customizations. 

Objectives 
The following table outlines the Cornerstone objectives and their corresponding 
Microsoft Office Specialist (MOS) exam objectives. 

Create custom 
conditional 
formatting rules 
with and without 
formulas 

• 2.3.1: Create custom conditional formatting rules 
• 2.3.2: Create conditional formatting rules that use 

formulas 

Manage 
conditional 
formatting rules 
and create custom 
number formats 

• 2.3.3: Manage conditional formatting rules 
• 2.2.1: Create custom number formats 

Group, ungroup, 
subtotal, and total 
data 

• 2.2.3: Group and ungroup data 
• 2.2.4: Calculate data by inserting subtotals and totals 

Summarize data 
using the 
Consolidate 
feature, and 
configure 
language, editing, 
and display 
language options 

• 3.4.1: Summarize data from multiple ranges by using the 
Consolidate feature 

• 1.3.2: Use language-specific features 
• 1.3.1: Configure editing and display languages 
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Create custom 
conditional 
formatting rules 
with and without 
formulas 

• 2.3.1: Create custom conditional formatting rules 
• 2.3.2: Create conditional formatting rules that use 

formulas 

Table 3: Cornerstone objectives 

Duration 
60 minutes 

Instructions 
1. Complete the tasks below for each file. 

2. When saving your file, add your name to the end of the filename, for example: 
<“Pick-Your-Own_Day_Dwayne_Espino”>. Follow your teacher’s directions for where 
to save your files.  

3. When you’re done with the Cornerstone, assess your completion and enter the 
points you think you earned within the task lists below. You can take the help of your 
teacher if required. 

Tasks 
You'll work with one file in this Cornerstone. The following are the tasks you need to do 
within this file. 

File 1: Cornerstone_solar_energy_costs_starter.xlsx 
Task: Use custom conditional formatting (30 points) 
1. Use custom conditional formatting to show the five highest energy costs for USA, 

Canada, and Mexico. (15 points) (Exam objective 2.3.1) 

2. Use custom conditional formatting with a formula to highlight energy costs that are 
below average for USA, Canada, and Mexico. (15 points) (Exam objectives 2.3.2 and 
2.3.3) 

Points scored: ________ / 30 
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Task: Customize number formats (15 points) 
• Format values for USA, Canada, and Mexico costs to appropriate currency. (15 

points) (Exam objective 2.2.1) 

Points scored: ________ / 15 

Task: Organize data (45 points) 
1. Group KWh data by product. (15 points) (Exam objective 2.2.3) 

2. Subtotal and Total KWh data by season. (15 points) (Exam objective 2.2.4) 

3. Average KWh data from several worksheets. (15 points) (Exam objective 3.4.1) 

Points scored: ________ / 45 

Task: Use language options (10 points) 
1. Change text case using a formula. (5 points) (Exam objective 1.3.2) 

2. Add a new editing language. (5 points) (Exam objective 1.3.1) 

Points scored: ________/ 10 

FILE 1 TOTAL POINTS: ________ /100 
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Module overview 
Description 
You can use Microsoft Excel 2019 to help answer questions that require some amount of 
data analysis. For example, you might want to find out: 

• What’s the average of sales of sneakers at your favorite store? 
• How many dogs or cats live on your street? 
• How many school days are there until summer vacation starts? 
• What’s the weekly food bill for families with more than two children in your area? 

If you have all the data you need in a worksheet, you could work out the answers 
manually by using a calculator, studying the data, or using various built-in Excel 
functions or a combination of functions such as Sort, Filter, and Subtotal. In this 
module, you’ll learn about other types of functions that you can use, such as logical, 
statistical, mathematical, lookup, and date and time functions to make the job easier. 
After learning about these functions, you’ll be able to choose which ones(s) to use to get 
the answer you need. You’ll be able to leave the calculator aside and use Excel to get the 
right results. You’ll also learn how to configure Excel to perform calculations in your 
workbooks and how to edit Excel Options to suit your requirements better. 

Lesson Learning objective Exam objective(s) 

Using logical, 
statistical, 
and 
mathematical 
functions 

Use functions with multiple criteria • 3.1.1 

Using lookup 
functions 

Use lookup functions • 3.2.1 

Using lookup 
functions and 
external 
references 

Use Match and Index functions to find data 
and create links to cells or ranges in other 
workbooks 

• 3.2.1 
• 1.1.2 
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Lesson Learning objective Exam objective(s) 

Using date 
and time 
functions 

Use date functions • 3.3.1 
• 3.3.2 

Customizing 
Microsoft 
Excel 

Configure formula calculation options • 1.2.4 

Cornerstone: 
Analyzing soil 
tests 

Use various functions to analyze data, 
including Lookup and Date functions, and 
reference cells from another workbook 

• 3.1.1 
• 3.2.1 
• 1.1.2 
• 3.3.1 
• 3.3.2 

Table 1: Objectives by lesson 

Scenario 
You’re analyzing the most recent soil testing report and comparing it to previous test 
results. There are specific questions that you need to answer to help the farm’s 
agronomist evaluate whether the soil conditioning measures taken over the past year, 
which include aeration, drainage, and decreased use of pesticides and fertilizers, have 
improved the soil quality. You also need to find out how many working days passed 
from when the soil test was taken to the date the results were received and how many 
days until the next results should be received. 

Cornerstone 
This module concludes with a Cornerstone project in which you’ll use logical, statistical, 
and mathematical functions to analyze soil test results. During the Cornerstone, you’ll: 

1. Use the LOOKUP function to retrieve specific values. 
2. Create COUNTIF and IFS functions. 
3. Use MATCH and INDEX functions. 
4. Use date and time functions to calculate future dates. 
5. Create a formula by combining the IF and WORKDAY functions. 
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Lesson 1: Using logical, 
statistical, and mathematical 
functions 
Overview 
You learned about the IF function in the Microsoft Excel associate 2019 course (if you 
took that course). In this lesson, you’ll learn about logical and statistical functions such 
as COUNTIF and AVERAGEIF to add to your knowledge of functions. You’ll then expand 
on this knowledge by learning how to create similar functions but for multiple criteria. 

Warm-up 
Ask your neighbor what they enjoyed the most about the previous module. Is there 
anything they are looking forward to learning in future modules of this course? Use the 
following questions to find out what you already know about this lesson’s topics. 

1. Which of the following categories does the AVERAGEIF function belong to? 

Select the correct option. 

a. Math & Trig 

b. Logical 

c. Lookup & Reference 

d. Statistical 

2. Which of the following categories does the SUMIFS function belong to? 

Select the correct option. 

a. Math & Trig 

b. Logical 

c. Lookup & Reference 

d. Statistical 
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3. Which of the following categories does the IFS function belong to? 

Select the correct option. 

a. Math & Trig 

b. Logical 

c. Lookup & Reference 

d. Statistical 

4. To work out how many entries in a list are equal to three specific conditions, you can 
use the ________________________ function. 

Fill in the blank space. 

Topic 1: Use functions with single 
criteria 
Excel 2019 includes several logical, mathematical, and statistical functions. Using some 
of these functions in this module will help you get a general idea of how they work. 

If you took the earlier associate course, you would have explored the IF, AVERAGE, 
MAX, MIN, and COUNT functions for basic logical, statistical, or mathematical 
calculations. But what if you need to perform a more complex analysis of your data? For 
example, consider a worksheet that has three columns of data: the first column contains 
states, the second contains cities, and the third has population statistics. You can use the 
AVERAGE function to calculate the average population for all states, but if you only 
want the average for a specific state, you need to use AVERAGEIF instead. 

AVERAGEIF 
The AVERAGEIF function finds the arithmetic mean for the cells specified by a given 
criteria or condition. The syntax for this function is =AVERAGEIF(range, criteria, 
[average_range]). The part contained within square brackets is optional. 
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As with all functions in Excel, you can manually enter the function, you can start the 
function from the Formulas tab, or you can use the Insert Function. When you begin 
entering the formula, such as =AVE, Excel will display possible functions for you to 
choose from. You can continue entering the formula or you can select the formula from 
the displayed list by either double-clicking it or by selecting the Tab key. Your formula 
will be updated as follows and you can continue entering the formula: 

 
Figure 1: AVERAGEIF function 

1. Enter the range of cells to evaluate. This can be a range, a whole column or row, or a 
named range if you have created one, followed by a comma (,). 

2. Enter the criteria enclosed in quote marks. The criteria can be a number, cell 
reference, expression, or text, followed by a comma (,). For example, to find out the 
average of all cells that have a value greater than 100, enter “>100”. 

3. Enter the actual cells to average. If you do not provide any cell references, the cells in 
the first range will be averaged. If the range in step 1 is numerical, you might not 
need to perform step 3. 

4. Enter a parenthesis ) to complete the formula, and then select Enter. 
Alternatively, use one of the following methods to enter the formula and the function 
arguments: 

• Select the Formulas tab, and then select the More Functions category. 
• Select Statistical, select AVERAGEIF, and then select OK. 
Another way to do this: 

1. On the Formulas tab, select Insert Function or select Shift +F3 on your keyboard. 
Alternatively, select the Insert Function button next to the Formula Bar. 
o Enter AVERAGE into the search box and then select Go (or select Enter). 

Alternatively, in the Or select a category drop-down menu, change the category 
from Most Recently Used to Statistical. 

2. Select AVERAGEIF from the list of functions, and then select OK (or select Enter). The 
Function Arguments dialog box opens. 

3. In the Range box, enter the range of cells you want Excel to evaluate. This can be a 
range, whole column or row, or a named range if you have created one. 

4. In the Criteria box, enter what you want to find. This can be a number, cell reference, 
expression such as >100, or text). 
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5. In the Average_range box, enter the range to be averaged, if required. This box is 
optional. 

 
Figure 2: AVERAGEIF Function Arguments dialog box 

6. Select OK or select Enter. 
Note: The Range and Average_range (if you are using it) must be the same length. For 
example, if you select a whole column for the range, you must use a whole column for 
the average range; otherwise, you’ll get an error. In Figure 2, the range C2:C197 matches 
E2:E197. This rule applies to all similar types of functions. 

SUMIF 
The SUMIF function is similar to the AVERAGEIF function, except that it adds the values 
in cells specified by a given criteria or condition. This function is included in the Math & 
Trig category and uses the following syntax: 

=SUMIF(range, criteria, [sum_range]) 

The part contained within square brackets is optional. 

 
Figure 3: SUMIF function 
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1. Enter the range of cells to evaluate. This can be a range, a whole column or row, or a 
named range if you have created one, followed by a comma (,). 

2. Enter the criteria enclosed in quote marks. The criteria can be a number, cell 
reference, expression, or text, followed by a comma (,). For example, to find out the 
sum of all cells that have a value greater than 100, enter “>100”. 

3. Enter the actual references of cells to sum. If left blank, the cells in range will be 
used. 

4. Enter a parenthesis ) to complete the formula, and then select enter. 
Alternatively, on the Formulas tab, select the Math & Trig category, and then select 
SUMIF. 

The following steps are another way to do this: 

1. On the Formulas tab, select Insert Function or select the Insert Function button 
next to the Formula Bar. 

2. Enter SUMIF into the search box, and then select either Go or Enter. Alternatively, in 
the Or select a category drop-down menu, change the category from Most 
Recently Used to Math & Trig. 

3. Select SUMIF from the list of functions, and then select either OK or Enter. The 
Function Arguments dialog box opens. 

4. In the Range box, enter the range of cells you want Excel to evaluate. This can be a 
range, a whole column or row, or a named range if you have created one. 

5. In the Criteria box, enter the condition that you want Excel to validate the cells 
against. This can be a number, a cell reference, an expression such as >100, or text. 

6. The Sum_range box is optional. If required, you can enter the range to be averaged 
in this box. 

7. Select either OK or Enter to complete the formula. 
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Figure 4: SUMIF Function Arguments dialog box 

 

Video 

To review the video on the SUMIF function, go to: SUMIF function 

COUNTIF 
The COUNTIF function counts the cells that meet a specified criteria or condition. It 
belongs to the Statistical category of functions and has the following syntax: 

 =COUNTIF(range, criteria) 

1. Enter the range of cells to evaluate. This can be a range, a whole column or a row, or 
a named range if you have created one, followed by a comma (,). 

2. Enter the criteria enclosed in quotes. The criteria can be a number, cell reference, 
expression such as >100, or text, followed by a parenthesis ) to complete the 
formula. 

Note that all criteria must be entered within quote marks, for example “>100”. 

  

https://aka.ms/SUMIF-function
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Alternatively: 

1. On the Formulas tab, select Insert Function or select the Insert Function button 
next to the Formula Bar. 

2. Enter COUNTIF into the search box, and then select either Go or Enter. Alternatively, 
in the Or select a category drop-down menu, change the category from Most 
Recently Used to Statistical. 

3. Select COUNTIF from the list of functions and then select OK or select Enter. 
Alternatively, on the Formulas tab, select More Functions, select Statistical, and 
then select COUNTIF. The Function Arguments dialog box opens. 

4. In the Range box, enter the range of cells you want Excel to evaluate against a 
criterion. This can be a range, a whole column or a row, or a named range if you 
have created one. 

5. In the Criteria box, enter the criteria that you want Excel to evaluate. The criteria can 
be numbers, cell references, expressions such as >100, or text. 

 
Figure 5: COUNTIF Function Arguments dialog box 

3. Select either OK or Enter. 
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Other Functions 
The following screenshot depicts some sample data. 

 
Figure 6: Example data 

The following table provides a brief overview of additional functions included in Excel. 
The examples provided in this table use the sample data displayed in Figure 6. 

Function Description 

IF Syntax: 
=IF(Logical_test, value_if_true, value_if_false) 
Evaluates whether a condition is met. Returns one value if true and 
another if false. 
Example: 
=IF(C2>A2,"Increasing","Investigate") 
Result = Increasing 

NOT Syntax: 
=NOT(Logical) 
Evaluates whether any of the arguments are true. Returns FALSE if all 
arguments are false. 
Examples: 
=NOT(A2>1000) 
Result = TRUE 
=IF(AND(NOT(A2<B2),NOT(B2<C2)),"Investigate","Increasing") 
Result = Increasing 
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Function Description 

AND Syntax: 
=AND(Logical1, Logical2,….) 
Evaluates whether all arguments are true. If all arguments are true, the 
result will be TRUE. If any of the arguments are not true, the result will 
be FALSE. 
Example: 
=AND(A2>1000,B2>1000,C2>1000)  
Result = FALSE 
=IF(AND(A2>1000,B2>1000,C2>1000),”Good”,”Poor”) 
Result = Poor 

OR Syntax: =OR(Logical1, Logical2,….) 
Evaluates whether any arguments are true. If any arguments are true, 
the result will be TRUE. If all of the arguments are not true, the result will 
be FALSE. 
Examples: 
=OR(A1>1000,B1>1000,C1>1000)  
Result = FALSE 
= IF(OR(A2>1000,B2>1000,C2>1000),”Good”,”Poor”) 
Result = Good 

Table 2: Summary of other functions 

 

Additional information 

For more information on Logical functions, go to: Formulas and 
functions 

For more information on Math & Trig functions, go to: Math and 
trigonometry functions (reference) 

For more information on Statistical functions, go to: Statistical 
functions (reference) 

Activity: Demonstrate and learn 
In this activity, your teacher will demonstrate how to create a SUMIF function and 
change the criteria values. You’ll then change the function to an AVERAGEIF to note the 
difference in the result. 

https://aka.ms/Formulas-and-functions
https://aka.ms/Formulas-and-functions
https://aka.ms/Math-and-trigonometry-functions-reference
https://aka.ms/Math-and-trigonometry-functions-reference
https://aka.ms/Statistical-functions-reference
https://aka.ms/Statistical-functions-reference
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Resources required 
You’ll need the following resources for this activity: 

• Open L1_T1_act_sales_starter.xlsx in this lesson’s Learning Activity Resources. 

Activity instructions 
Participate in the activity by following these instructions: 

1. Follow along as the teacher demonstrates how to create a SUMIF function to total 
all the vegetable sales. 

2. Change the contents of G2 to Fruit, then Nuts, and then Honey Based. 

3. Edit the function from SUMIF to AVERAGEIF. 

Try-it: Use functions with single criteria 
 In this leveled try-it, you’ll edit an existing function and you’ll create another new 

function. 

Try-it 1 
Edit an existing formula to use the SUMIF function instead of AVERAGEIF. 

Resources 
You’ll need the following resources for this try-it: 

• Open L1_T1_try1_sales_starter.xlsx in this lesson’s Learning Activity Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Examine the function in cell H2. 

2. Edit the function to change it to a SUMIF function to find the total vegetable sales 
for winter. 

3. Save the file as the same name plus your initials. 

Try-it 2 
Create a function to calculate the number of vegetable entries in a specified range. 

  



Using advanced formulas 
 

 
17 

Resources 
You’ll need the following resources for this try-it: 

• Open L1_T1_try2_sales_starter.xlsx in this lesson’s Learning Activity Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. In cell H2, create a function that will count the number of vegetables in the 
Category column. 

2. Save the file as the same name plus your initials. 

Try-it 3 
Create a function that will average the total vegetable sale values for summer. 

Resources 
You’ll need the following resources for this try-it: 

• Open L1_T1_try3_sales_starter.xlsx in this lesson’s Learning Activity Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. In cell H2, create a function that will average the values for total vegetable sales in 
summer. 

2. Save the file as the same name plus your initials. 

Topic 2: Use functions with multiple 
criteria 

As you know, there are many logical and statistical functions available in Excel 2019. 
In the previous topic, you had the opportunity to practice some of these functions. Most 
work in a similar manner; using one of them will give you a general idea of how the 
others work. However, using nested functions, which means using multiple functions 
within the same formula, can be tricky. 
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Continuing from Topic 1, imagine a worksheet with three columns of data: the first 
column contains states, the second contains cities, and the third contains population 
statistics. You can count how many entries are listed, but what if you only want to count 
the entries above a specific figure? That’s when you need to use COUNTIF instead of 
COUNT. 

 

Did you know? 

There are several new functions in Excel 2019 such as SWITCH, IFS, 
MAXIFS, MINIFS, and more. You’ll get to try these out in this lesson. 
To learn more about the new functions included in Excel 2019, go to: 
What's new in Excel 2019 for Windows 

 

IFS 
IFS is a great new function available in Excel 2019. Evaluating your data against certain 
criteria often results in multiple possible outcomes, and not just a true or false value. 
The IFS function evaluates whether your data satisfies one or more conditions and 
returns a value corresponding to the first true condition. In previous versions of Excel, 
you would need to create a nested IF function, but in Excel 2019, you can use the IFS 
function. It belongs to the Logical category of functions and uses the following syntax: 

=IFS(logical_test1, value_if_true1, logical_test2, value_if_true2,…) 

To use the IFS function: 

1. In the Formula Bar, enter =IFS( and then enter your question, followed by a comma. 
2. Enter the result you want if the answer to your question is yes, followed by a comma. 
3. Enter your next question, followed by a comma. 
4. Enter the result you want if the answer to your second question is yes. 
5. Continue entering your questions and the results you want until you have added all 

your questions. 
6. Close the formula with a closed parenthesis ) and then select Enter. Similar to how 

you used the other functions, you can use one of the following methods to enter a 
formula: 
o Select the Formulas tab, select the Logical category, and then select IFS. 
o On the Formulas tab, select Insert Function, or select the Insert Function 

button next to the Formula Bar. 

https://aka.ms/What-s-new-in-Excel-2019-for-Windows
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o Enter IFS into the search box and then select Go or select Enter. Alternatively, 
change the category from Most Recently Used to Logical. 

o Select IFS from the list of functions, and then select OK. The Function 
Arguments dialog box opens. 

 
Figure 7: IFS Function Argument dialog box 

7. As you enter your logical tests and the values you want if the result is true, Excel 
provides you more boxes to enter additional questions. 

8. Select OK or select Enter to complete the function. 

 

Did you know? 

You can set up to 127 logical tests within an IFS function! 

 

Additional information 

For more information on the IFS function, go to: IFS Function 

https://aka.ms/IFS-function
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SWITCH 
The SWITCH function compares one value against a list of values and returns the first 
matching value as the result. If no match is found, the function can return an optional 
default value. The syntax for SWITCH is =SWITCH(expression, value1, result1, 
[default_or_value2, result2],…..). The part within square brackets is optional. 

You can use this function to switch specific results to a different result. You could 
consider this to be similar to using the Find and Replace commands, except that you 
can replace more than one thing at the same time. 

For example, imagine you have a worksheet that lists vegetables that are known by 
different names in different countries/regions, and you need to change the words to use 
the American names. You could find each word and replace it one by one or you could 
create a formula using the SWITCH function as shown in the following example: 

=SWITCH(F4,"Aubergine","Eggplant","Chicory","Endive","Swede","Rutabaga","Co
urgette","Zucchini",F4) 

This formula evaluates the value in cell F4, and if it contains Aubergine, switches it to 
Eggplant; if it contains Chicory, switches it to Endive; and so on. If F4 doesn’t contain any 
of those words, the function will return the original value of F4. Then, to tidy up the 
worksheet, you could copy the result and paste it on top of the original data as values to 
remove the formula. Excellent! 

You can combine the SWITCH function with other functions; in lesson 4 of this module, 
you’ll combine SWITCH and WEEKDAY. 

AVERAGEIFS 
The AVERAGEIFS function is a statistical function that finds the average (also known as 
the arithmetic mean) for the cells specified by a given set of criteria or conditions. The 
syntax for AVERAGEIFS is =AVERAGEIFS(average_range, criteria_range1, criteria1, 
criteria_range2, criteria2,…). 

To create an AVERAGEIFS function: 

1. Enter =AVERAGESIFS( in the cell you want to create the formula.

2. Enter the range to be averaged if all the criteria are met. This can be a range, a whole
column or a row, or a named range if you have created one, followed by a comma (,).

3. Enter the range where the first criteria will be evaluated, followed by a comma.

4. Enter the criteria, which can be a number, cell reference, expression such as >100, or
text, followed by a comma (,).
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5. Enter the next range where the next criteria will be evaluated, followed by a comma 
(,). 

6. Enter the next criteria, followed by a comma (,) until you have completed adding all 
your criteria to evaluate, and then enter a closed parenthesis ) to finish the formula. 

7. Select Enter to complete the formula. 

Alternatively, use the following steps: 

1. Select the Insert Function button next to the Formula Bar or select Insert Function 
on the Formulas tab. 

2. Enter AVERAGE into the search box, and then select either Go or Enter. Alternatively, 
in the Or select a category drop-down menu, change the category from Most 
Recently Used to Statistical. 

3. Select AVERAGEIFS from the list of functions, and then select either OK or Enter. 
Alternatively, select the Formulas tab, select More Functions, select Statistical, and 
then select AVERAGEIFS. The Function Arguments dialog box opens as depicted in 
the following screenshot. 

 
Figure 8: AVERAGEIFS Function Arguments dialog box 

4. Enter values in the Average_range, Criteria_range1, and Criteria1 boxes. 

5. Excel will provide additional boxes in the Function Arguments dialog box to allow 
you to enter Criteria_range2 value and Criteria2 value. 
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6. Continue to add the additional criteria ranges and criteria values you need until you 
have completed adding all of your criteria. 

7. Select either OK or Enter to complete the formula. 

MAXIFS, MINIFS, COUNTIFS, and SUMIFS 
• Excel includes several similar functions that you can use to perform specific 

evaluations of your data. The MAXIFS and MINIFS functions are included in the 
Statistical category, COUNTIFS in the Logical category, and SUMIFS in the Math & 
Trig category. 

• These functions are very similar to the AVERAGEIFS function, and they perform the 
following calculations: 
o MAXIFS finds the highest value among cells specified by a given set of criteria or 

conditions. 
o MINIFS finds the lowest value among cells specified by a given set of criteria or 

conditions. 
o COUNTIFS counts the number of cells specified by a given set of criteria or 

conditions. 
o SUMIFS totals the values in the cells specified by a given set of criteria or 

conditions. 
The syntax for these functions is the same as AVERAGEIFS. Simply replace AVERAGEIFS 
with MAXIFS, MINIFS, COUNTIFS, or SUMIFS as appropriate. 

Editing functions 
There are many methods you can use to edit a function. First, select the cell containing 
the function to edit, and then use one of the following options: 

• Select the Formula Bar, make your alteration, and then select Enter to complete the 
edit. 

• Select the Insert Function and then make your alteration in the Function 
Arguments dialog box. If there are nested functions within the same formula, select 
any of the function names within the Formula Bar; the Function Arguments dialog 
box will then switch to that part of the formula. Select either OK or Enter to complete 
the edit. 

• Select the formula and then select F2, make your alteration, and then select Enter to 
complete the edit. 



Using advanced formulas 
 

 
23 

 

Additional information 

For more information on the SWITCH function, go to: SWITCH 
function 

Activity: Discuss and learn 
In this activity you’ll work in pairs, teams, or individually to match a function with its 
correct description. 

Resources required 
You’ll need the following resources for this activity: 

• Open L1_T2_act_functions_starter.docx in this lesson’s Learning Activity Resources. 

Activity instructions 
Participate in the activity by following these instructions: 

1. Study the description in the first column of the table in the Word document. 

2. Work in pairs, teams, or individually (as instructed by your teacher) to indicate the 
correct function against each description. 

3. There are 12 functions to identify. 

Try-it: Use functions with multiple criteria 
 In this leveled try-it, you’ll create a MAXIFS function and describe what an IFS 

function is evaluating. 

Try-it 1 
Create a new formula that uses the MAXIFS function. 

Resources 
You’ll need the following resources for this try-it: 

• Open L1_T2_try1_sample_starter.xlsx in this lesson’s Learning Activity Resources. 
  

https://aka.ms/SWITCH-function
https://aka.ms/SWITCH-function
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Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. In cell F2, create a function that will find the maximum sample value if the rate is 
greater than or equal to 3 and if it belongs to the periodic table group 2. 

2. Save the file as the same name plus your initials. 

Try-it 2 
Describe what the IFS function is calculating in column D. 

Resources 
You’ll need the following resources for this try-it: 

• Open L1_T2_try2_sample_starter.xlsx in this lesson’s Learning Activity Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Examine the comment in cell D2. 

2. Edit the comment to complete the description of what the function in cell D2 is 
calculating. 

3. Save the file as the same name plus your initials. 

Wrap-up 
Do you or your classmates have any concerns about today’s topics? Maybe you can 
help. Make a note for the “mud puddle” or “parking lot” or send a short email to your 
teacher if your concerns are not answered. Then, use these questions to check what you 
learned in this lesson. 

1. Which of the following functions does not exist in Excel 2019? 

Select the correct option. 

a. AVERAGEIF 

b. MAXIF 

c. SUMIF 

d. MINIFS 
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2. If the content of A2 is 100 and the contents of B2 is 200, what result would you get 
using the formula =IF(AND(A2>50,B2>200),"Excellent","Needs improvement") 

Select all that apply. 

a. Excellent 

b. You would get an error 

c. Needs improvement 

d. A2>50 

3. You can use an IFS function instead of which of the following functions? 

Select all that apply. 

a. Nested IF 

b. IF 

c. COUNTIF 

d. AND 

4. Identify the category to which the following functions belong. 

o SUMIFS 
o COUNTIF 
o AVERAGEIFS 
o SWITCH 
Categorize the following items by adding the function name next to each item. 

o Math & Trig - ________________________ 
o Statistical - ________________________ 
o Statistical - ________________________ 
o Logical - ________________________ 
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Lesson 2: Using lookup 
functions 
Overview 
Several Lookup & Reference functions are available in Excel 2019. LOOKUP is used 
when the key row or column is not adjacent to the data row or column. VLOOKUP and 
HLOOKUP are probably the most frequently used lookup functions. These functions are 
the same except for the direction of the lookup table. In this lesson, you’ll learn how to 
use the VLOOKUP function and the HLOOKUP function. Imagine a worksheet 
containing the details of every student attending your school this year. The worksheet 
contains details such as name, date of birth, contact details, and grade results. You need 
to find some information about a specific group of students in another workbook. You 
could search for each student’s details manually and enter the details you need yourself, 
or you could use a lookup function to find the information automatically. 

Warm-up 
Use these questions to find out what you already know about this lesson’s topics. 

1. What does the V in VLOOKUP mean? 

Select the correct option. 

a. Value 

b. Value_if_true 

c. Vertical 

d. View 

2. The HLOOKUP function belongs to which category of functions? 

Select the correct option. 

a. Math & Trig 

b. Lookup & Reference 

c. Logical 

d. Statistical 
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3. There are many Lookup & Reference functions in Excel 2019, not all of which are
mentioned in this lesson. Which of the following functions do not belong to the
Lookup & Reference function category?

Select all that apply.

a. REPLACE

b. HLOOKUP

c. LOOKUP

d. SWITCH

4. VLOOKUP will return a value from a column index number, and HLOOKUP will
return a ________________________ index number.

Fill in the blank space.

Topic 1: Use VLOOKUP 
 Have you ever found yourself manually searching for values within one table of 

data and then entering the values you need into another table? If you need to add more 
values, you have to repeat the process again and again. It’s a task that can be time-
consuming and boring. Luckily, you can use VLOOKUP or HLOOKUP for such repetitive 
tasks. 

The VLOOKUP function belongs to the Lookup & Reference category; you can use it to 
find data in a table where the data is laid out vertically. There are four parts in a 
VLOOKUP function, and it has the following syntax: =VLOOKUP(lookup_value, 
table_array, col_index_num, [range_lookup]) 

Create a VLOOKUP function 
To create a VLOOKUP by manually entering it: 

1. Enter =VLOOKUP(.

2. In Lookup_value, enter the value you wish to find, followed by a comma. This can be
a cell reference, text, or number.

3. In Table_array, enter the range of cells or table that contains the value you want to
find, followed by a comma. The table array can be a defined range or table or a
range of cells that may need to be absolute.

4. In Col_index_num, enter the column number within the table array that you want to
return when the value you want to find has been found, followed by a comma.
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5. Enter False or 0 for an exact match, or enter True or 1 for an approximate match. 

6. Complete the formula with a closed parenthesis ) and then select enter. 

Alternatively, to create a VLOOKUP using the Function Arguments dialog box: 

1. Select the Insert Function button next to the Formula Bar or on the Formulas tab. 

2. Enter VLOOKUP into the search box and then select either Go, or change the 
category from Most Recently Used to Lookup & Reference. 

3. Select VLOOKUP from the list of functions and then select OK. Alternatively, select 
the Formulas tab, select Lookup & Reference, and then select VLOOKUP. The 
Function Arguments dialog box opens as the following screenshot depicts. 

 
Figure 9: VLOOKUP Function Arguments dialog box 

4. In Lookup_value, enter the value you want to find. This can be a cell reference, text, 
or a number. 

5. In Table_array, enter the range or table of cells in which you want to find the value. 
The table array can be a defined range, a table, or a range of cells that may need to 
be absolute. 

6. In Col_index_num, enter the column number you want to return the value from. 
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7. In Range_lookup, enter False or 0 for an exact match. For an approximate match, 
enter True or 1 or leave it blank. 

8. Select either OK or Enter to complete the formula. 

Note: 

• Use the following guidelines when creating a VLOOKUP function: 
o When you use TRUE or 1 in Range_lookup or do not enter anything, Excel will 

return the closest match that is less than the number you are looking up. If there 
is no lower value to return, #N/A will be returned. 

o A VLOOKUP function will check in the first column of the table array and will 
return the first match it can find. 

o When looking up numerical values, you should sort the table array by the first 
column, smallest to largest first. 

o If the Range_lookup is FALSE or 0 and the Lookup_value is text, you can use a 
wildcard character within the Lookup_value. Use a question mark (?) to match 
any single character or an asterisk (*) to match any sequence of characters in the 
Lookup_value. To find an actual question mark or asterisk, type a tilde (~) before 
the character. 

 

Video 

To review the video on the VLOOKUP function, go to: VLOOKUP 
function 

Activity: Discuss and learn 
In this activity, you’ll discuss the four parts of the VLOOKUP function that has been 
created in a worksheet. Your teacher will then create the formula again by entering the 
formula manually. 

Resources required 
You’ll need the following resources for this activity: 

• Open L2_T1_act_elements_starter.xlsx in this lesson’s Learning Activity Resources. 

  

https://aka.ms/VLOOKUP-function
https://aka.ms/VLOOKUP-function


Using advanced formulas 
 

 
30 

Activity instructions 
Participate in the activity by following these instructions. 

1. Follow your teacher and participate in the discussion. 

2. Create another formula with the VLOOKUP function along with your teacher for 
practice before filling out the rest of the elements. 

Try-it: Use VLOOKUP 
 In this leveled try-it, you’ll edit an existing VLOOKUP function and then create a 

new formula using this function. 

Try-it 1 
Edit the function on the Samples worksheet so that the levels in column D are correct. 

Resources 
You’ll need the following resources for this try-it: 

• Open L2_T1_try1_elements_starter.xlsx in this lesson’s Learning Activity Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Examine the values in column D. You’ll notice that some of the values are correct and 
others are incorrect. 

2. Edit the formula in D2 to fix the errors. 

3. Fix the rest of the formulas in column D. 

4. Save the file as the same name plus your initials. 

Try-it 2 
Find the correct periodic table group for each element listed. 

Resources 
You’ll need the following resources for this try-it: 

• Open L2_T1_try2_elements_starter.xlsx in this lesson’s Learning Activity Resources. 
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Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. In cell B2, on the Samples worksheet, create a formula that will find the element’s 
periodic table group number from the Elements_Info defined range on the 
Elements worksheet. 

2. Add the formula for the rest of the elements on the Samples worksheet. 

3. Save the file as the same name plus your initials. 

 

Additional information 

For more information on using range names in functions, go to: Define 
and use names in formulas 

Topic 2: Use HLOOKUP 
You can use the HLOOKUP function to find data in a table where the data you need 

to retrieve is laid out horizontally. There are four components in the HLOOKUP function, 
which belongs to the Lookup & Reference category. The HLOOKUP function is the 
same as VLOOKUP except that it checks for a row value rather than a column value. The 
syntax for HLOOKUP is =HLOOKUP(lookup_value, table_array, row_index_num, 
[range_lookup]). 

Create a HLOOKUP function 
To create a HLOOKUP by manually entering it: 

1. In the cell you want to use the formula, enter =HLOOKUP( and then complete the 
four parts of the function in the same way that you did for VLOOKUP. 

2. Make sure that you are referring to the row number rather than the column number. 

Alternatively, to create a HLOOKUP by using the Function Arguments dialog box: 

1. Select the Insert Function button next to the Formula Bar or select Insert Function 
on the Formulas tab. 

2. In the search box, enter HLOOKUP and then select either Go. Alternatively, in the Or 
change the category drop-down menu, change the category from Most Recently 
Used to Lookup & Reference. 

3. Select HLOOKUP from the list of functions, and then select OK. Alternatively, select 
the Formulas tab, select Logical, and then select HLOOKUP. 

https://aka.ms/Define-and-use-names-in-formulas
https://aka.ms/Define-and-use-names-in-formulas
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4. In the Lookup_value box, enter the value you want to find. This can be a cell 
reference, text, or a number. 

5. In Table_array, enter the range or table of cells you want to find the value in. The 
table array can be a defined range or table or a range of cells that may need to be 
absolute. 

6. In Row_index_num, enter the row number you want to check. 

7. In Range_lookup, enter False or 0 for an exact match. For an approximate match, 
enter True or 1, or leave it blank. 

8. Select OK or select Enter to complete the formula. 

Note: 

Use the following guidelines when creating a HLOOKUP function: 

• When you use TRUE in Range_lookup or do not enter anything, Excel will return the 
closest match lower than the number you are looking up. If there is no lower value to 
return, #N/A will be returned. 

• The HLOOKUP function checks the first row of the table array and returns the first 
match it can find. 

• When looking up numerical values, you should sort the table array by the first row, 
smallest to largest first. To do that: 
o Select the Data tab and then select Sort. 
o Select the Options button and then select Sort left to right under Orientation. 
o Continue to set the sort option you want. 

• If the Range_lookup is FALSE or 0 and the Lookup_value is text, you can use a 
wildcard character within the Lookup_value. Use a question mark (?) to match any 
single character or an asterisk (*) to match any sequence of characters in the 
Lookup_value. To find an actual question mark or asterisk, type a tilde (~) before the 
character. 

 

Did you know? 

There’s a new lookup function currently available in Office 365 that 
will be soon included in Excel 2019: the XLOOKUP function! Here’s a 
link to the XLOOKUP function for you to review when you have a 
moment. 

https://aka.ms/xlookup-function
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Additional information 

For more information on the HLOOKUP function, go to: HLOOKUP 
function 

Activity: Pose a question 
Your teacher will ask you a question about the difference between the VLOOKUP and 
HLOOKUP function. You’ll then create an HLOOKUP formula based on a VLOOKUP 
formula that has already been created. 

Resources required 
You’ll need the following resources for this activity: 

• Open L2_T2_act_trace_elements_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Activity instructions 
Participate in the activity by following these instructions: 

1. Consider the difference between an HLOOKUP and VLOOKUP. Ask yourself: 

o What does the V stand for? 
o What does the H stand for? 
o What difference does it make to the formula? 

2. Be prepared to share with the class. 

3. Examine the VLOOKUP function in column C of the Soil Sample 2019 worksheet. 

4. Work with your neighbor to create a similar formula on the Soil Sample 2020 
worksheet, but use HLOOKUP instead. A range named Level has been created for 
your use as the table array on the Soil Sample 2020 worksheet. 

Try-it: Use HLOOKUP 
 In this standalone try-it, you’ll work in pairs to write a description of the 

HLOOKUP and VLOOKUP functions. 

  

https://aka.ms/HLOOKUP-function
https://aka.ms/HLOOKUP-function


Using advanced formulas 

34 

Try-it 
Imagine one of your peers has asked you to explain how to use lookup functions and 
the various elements in these functions. In this try-it, you’ll try to describe the 
HLOOKUP and VLOOKUP functions to make it as easy as possible for your peers to 
understand how these functions work. 

Resources 
You’ll need the following resources for this try-it: 

• Open L2_T2_try_trace_elements.xlsx in this lesson’s Learning Activity Resources as
reference or create your own data in a blank workbook.

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Use any method and/or help available to you and your partner to write a brief user
guide that will help your friends understand these two functions.

2. Consider:

o Are all the four parts of the function required?
o What’s the correct sequence for the functions?
o How would you make the formula easier to understand?
o What’s the difference between an HLOOKUP and VLOOKUP?

3. Be prepared to share your work with the class.

4. Your teacher may ask you to hand in your work at the end of the lesson.

Wrap-up 
For what kind of data would it be useful to apply the VLOOKUP or HLOOKUP 
functions? Discuss with your neighbor. Use the following questions to review what you 
learned in this lesson. 

1. In a VLOOKUP or a HLOOKUP function, what should you enter in the fourth
segment of the formula to specify that you want an approximate match return?

Select all that apply.

a. True

b. Leave it blank

c. False

d. 1
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2. A VLOOKUP function checks the ________________________ column in a table array to 
match it with the lookup value. 

Fill in the blank space. 

3. When using a VLOOKUP function for a numerical value, it’s best practice to sort the 
first column from ________________________ to ________________________ 

Fill in the blank spaces. 

4. What is the correct order of entering the four parts of an HLOOKUP function? 

Indicate the correct sequence by adding numbers 1-4 next to the following items. 

a. Row_index_num - ________________________ 

b. Range_lookup - ________________________ 

c. Table_array - ________________________ 

d. Lookup_Value - ________________________ 
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Lesson 3: Using lookup 
functions and external 
references 
Overview 
In this lesson, you’ll learn how to use the MATCH and INDEX functions to find data. In 
the previous lesson, you learned that the VLOOKUP function checks the first column in 
the table array and the HLOOKUP function checks the first row in the table array for the 
value you want to find. But what if the value you want to find is not in the first column 
or row of the table array? That’s when the MATCH and INDEX functions can help. 

The second topic in this lesson will cover referencing data on other workbooks, which 
basically means linking cells from one worksheet to another so that they are 
automatically updated. 

Warm-up 
Use the following questions to find out what you already know about this lesson’s 
topics. 

1. To which category of functions does MATCH belong? 

Select the correct option. 

a. Logical 

b. Financial 

c. Lookup & Reference 

d. Statistical 
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2. When you reference another workbook in a formula, what type of brackets enclose
the source workbook within the formula?

Select the correct option.

a. ( )

b. < >

c. [ ]

d. { }

3. When you reference another workbook in a formula, what symbol is after the source
worksheet name within the formula?

Select the correct option.

a. !

b. ?

c. $

d. \

4. When the value you are searching for is not in the first column of a table array, you
can use the ________________________ and/or ________________________ functions.

Fill in the blank spaces.

Topic 1: Use MATCH and INDEX 
The MATCH function on its own returns the relative position of a value in a 

specified list or range. The INDEX function returns a specific value or reference at the 
intersection of a column and row. You can use the INDEX function with a reference or 
an array. The MATCH and INDEX functions work well in combination with other 
functions, such as VLOOKUP. 



Using advanced formulas 
 

 
38 

MATCH function 
The MATCH function belongs to the Lookup & Reference function category and uses 
the following syntax: 

=MATCH(lookup_value, lookup_array, [match_type]) 

The Lookup_value and Lookup_array components are similar to the VLOOKUP and 
HLOOKUP function. The part in square brackets is optional but has three possible 
values that you can enter: 

• Enter 0 to find an exact match you need to retrieve. 
• Enter 1 to find the largest number, greater than or equal to the lookup value. 

However, the lookup array must be sorted smallest to largest. 
• Enter -1 for the smallest number, less than or equal to the lookup value. However, 

the lookup array must be sorted in largest to smallest order. 
Here are some examples of the MATCH function: 

• =MATCH("Iron",A1:A24,0) will return the position of Iron within the range A1:24. 
Based on the data in Figure 10, the result is 12. 

• =MATCH(200,B1:B24,-1) will return the position of the smallest number, less than 
or equal to the lookup value. Based on the data in Figure 10, the result is 5, meaning 
anything below the fifth position (B5) is below 200. 

• If the data in column B in Figure 11 is reversed, that is, sorted smallest to largest, 
=MATCH(200,B1:B24,1) will return the position of the highest number, greater than 
or equal to the lookup value. The result is 20. 
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Figure 10: Sample data for MATCH function 
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Figure 11: Sample data for MATCH function 

INDEX function 
The INDEX function also belongs to the Lookup & Reference function category. 
However, the INDEX function has two forms: the array form and the reference form. The 
array form returns an entire row or column. The reference form returns the value in the 
intersecting cell where the row and column meet: 

• =INDEX(array, row_num, column_num) 
• =INDEX(reference, row_num, [column_num], [area_num]) 
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Did you know? 

Curly brackets (braces) around a formula {….} means that the formula 
is a superpower formula because it performs multiple calculations in 
the same formula. It’s also known as an array formula; to make it work 
correctly, you must complete the formula by selecting Ctrl + Shift + 
Enter. 

Here are some examples of the INDEX function based on the data in Figure 12. 

 
Figure 12: Sample data for INDEX function 

• To find the rate for Zinc that was recorded in 2016, the formula is: 
=INDEX(A5:C10,6,3). 

• This will return the contents of the cell in the sixth row and third column within the 
range A5 to C10. The result will be 5. 

• To find the rate for Zinc in 2016, 2018, or 2020, the formula is: 
=INDEX((A5:C10,E5:G10,I5:K10),6,3,2). The reference part of the function has been 
edited to include three ranges to which the function should refer. The 2 at the end of 
the formula refers to which of the three tables to search. In this case, it is the second 
table (E5 to G10). The result will be 4. 

=INDEX((A5:C10,E5:G10,I5:K10),6,3,3). The 3 at the end of the formula indicates 
that the function should refer to the third table (I5 to K10). The result will be 3. 
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• When using the array form of the INDEX function, you must indicate the cells in 
which you want the results to be displayed. For example, if there are three values to 
return from a row, you need to select three cells while creating the formula. When 
you have created the formula, you must select Ctrl+Shift+Enter to complete it; 
otherwise, you won’t get the correct answer. This creates an array formula with curly 
brackets (braces) at either end of the formula: 
{=INDEX((A5:C10,E5:G10,I5:K10),6,0,3)} 

This formula will return the entire sixth row in the third table; the result will be Zinc, 
1.48, and 3. 

Combine MATCH and INDEX 
Instead of using a VLOOKUP or HLOOKUP function to find a value, you can combine 
MATCH and INDEX in the same formula. This could be helpful when you need to find a 
value that is not in the first column or row of the table array. 

In the following example, =INDEX(A1:E119,MATCH("Fe",B1:B119,0),4), the formula 
returns a value that’s in the fourth column of a data table A1 to E119. The value to find 
is in the second column (B1 to B119), and the value to return is in the fourth column; 
therefore, using VLOOKUP will not help. You could rearrange the table so that the 
column containing Fe is in the first column, but sometimes you won’t want to change 
the data at all. 

The outer component of the formula =INDEX(A1:E119,…,4) specifies where to find the 
value and which column to return when the value is found. 

The inner component MATCH("Fe",B1:B119,0) specifies what needs to be found, 
where to find it within the table, and to return an exact match. 

 

Video 

To review the video on the MATCH function, go to: MATCH function 

To review the video on the INDEX function, go to: INDEX function 

Activity: Pose a challenge 
In this activity, your teacher will ask questions about the MATCH and INDEX functions. 
Consider the possibility of using VLOOKUP or HLOOKUP to find specific data. 

  

https://aka.ms/MATCH-function
https://aka.ms/index-function
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Resources required 
You’ll need the following resources for this activity: 

• Open L3_T1_act_elements_starter.xlsx in this lesson’s Learning Activity Resources. 

Activity instructions 
Participate in the activity by following these instructions: 

1. Examine the data on the Elements worksheet. Consider the following: 

o If you wanted to find the symbol for any of the elements, could you use 
VLOOKUP or HLOOKUP? If not, why not? 

o Is it possible to extract a full row using MATCH or INDEX? 
2. Switch to the Searching Elements worksheet and examine the function in cell J2 

and in the cells I7 to L7. 

3. Check your understanding of how the function works. 

4. Change the contents of cell I2 to any other symbol listed in column B. Does the 
result in J2 update? 

5. Change the row number in any of the formulas in the range I7 to L7. Does the result 
update? If not, why not? 

6. Follow along as your teacher recreates one of the functions. 

Try-it: Use MATCH and INDEX 
 In this leveled try-it, you’ll edit an existing MATCH or INDEX function, or you’ll 

create a new formula using the MATCH and INDEX functions. 

Try-it 1 
A MATCH function has been created, but it needs to be combined with INDEX to 
retrieve the name of the element and not just the position in the column. 

Resources 
You’ll need the following resources for this try-it: 

• Open L3_T1_try1_elements_starter.xlsx in this lesson’s Learning Activity Resources. 
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Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Examine the function in cell J2. Notice it’s not retrieving the correct value. It contains 
the formula =MATCH(I2,B1:B119,0) and is therefore only returning the position of 
the contents of cell I2 within the Elements column. 

2. Edit the formula to include the INDEX function so that it picks up the Element name 
for the symbol in I2 (you can use the formula in K6 as reference). 

3. Change the contents of cell I2 to Cr to check that your formula works. 

4. Save the file as the same name plus your initials. 

Try-it 2 
An INDEX function has already been created, but it needs to be combined with MATCH 
to return the required results. 

Resources 
You’ll need the following resources for this try-it: 

• Open L3_T1_try2_elements_starter.xlsx in this lesson’s Learning Activity Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Examine the function in cell J2. It contains an error because it’s unclear which row 
and column need to be matched. 

2. Edit the formula to include the MATCH function so that it retrieves the Element for 
the symbol in I2 (you can use the formula in K6 as reference). 

3. Change the contents of cell I2 to Rb to check that your formula works. 

4. Save the file as the same name plus your initials. 

Try-it 3 
Create a new formula using both the INDEX and MATCH functions. 

Resources 
You’ll need the following resources for this try-it: 

• Open L3_T1_try3_elements_starter.xlsx in this lesson’s Learning Activity Resources. 
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Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. In cell J2, create an INDEX function with a nested MATCH function so that you can 
find the Element that matches the contents of I2 in the range A1 to E119. 

2. Copy the formula from J2 to K2, and then edit it to find the Group number. 

3. Save the file as the same name plus your initials. 

Topic 2: Reference data from other 
workbooks 

 What if you have to regularly refer to cells in various workbooks? For example, you 
could have a workbook that summarizes data from several workbooks. The other 
workbooks are updated on a regular basis, which means that you need to constantly 
update the summary workbook. How time consuming would that be? If the data from 
the other workbooks were linked to the summary workbook, the values would always be 
updated automatically. 

Reference another workbook 
When you reference an external workbook in your workbook, you are creating a link. 
The following procedure is one of the simplest methods to link to another workbook: 

1. Open both workbooks (the destination and source workbooks). 

2. In the destination workbook, select the cell in which you want to add the reference. 

3. Enter an equal sign (=). 

4. Select the source workbook, and then select the cell(s) you want to refer to. 

5. Select Enter. 

6. You’ll be automatically returned to the destination workbook. If the data in the 
source workbook is updated, it will be automatically updated in the destination 
workbook, too. We recommend that you keep both the source and destination 
workbooks open when you are updating data in the source workbook. Sometimes, 
the destination workbook might not get updated correctly if it’s closed. 
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Reference a defined range in another workbook 
If the source workbook contains a defined range name, you can link to the whole range. 

1. Open both the destination and source workbooks. 

2. In the destination workbook, select the cell in which you want to add the reference. 

3. Enter an equal sign (=). 

4. Select the source workbook, but don’t select a specific cell. To select the source 
workbook, on the View tab, in the Window group, select Switch Windows, or select 
Alt+Tab on your keyboard. (You many need to select Tab more than once to select 
the correct workbook.) 

5. Select F3, and the Paste Name dialog box will open as depicted in Figure 13. 

 
Figure 13: Paste Name dialog box 

6. In the Paste_name list, select the range to link to, and then select OK. You’ll be 
automatically returned to the destination workbook, and the whole range will be 
linked. 

Security warnings 
When you open a workbook that contains links to other workbooks, Excel might display 
a security warning message under the ribbon as depicted in Figure 14. 

 
Figure 14: Security Warning message 

Select Enable Content to continue working in the workbook. 
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If a source workbook has been updated at any time without the destination workbook 
being open, you’ll receive a message as depicted in Figure 15. 

 
Figure 15: Security Warning dialog box 

If you do receive a warning like this, don’t panic. Select Update if you are happy to go 
ahead and update the current workbook, or select Don’t Update if you would prefer 
not to. However, be extra careful when making the decision to update or not. If columns 
or rows have been inserted into the source workbook since you first created the link, the 
cells in the destination workbook might be referring to the wrong cells! If this happens, 
close the workbook without saving, and then open again and select Don’t Update 
instead. Alternatively, you may need to create the link again. 

Break a link 
At any time, you can remove the link to an external workbook. To do this: 

1. On the Data tab, in the Queries & Connections group, select Edit Links. 

2. In the Edit Links dialog box, select the link you want to remove, and then select 
Break Link. You could also copy and paste the cell containing the link on top of the 
same cell as a value. To do so, copy the cell, and then either access the context menu 
(right-click) or select the drop-down menu on the Paste button on the Home tab, 
and then select Values. 
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Figure 16: Edit Links dialog box 

From this dialog box, you can also: 

• Update the linked values. 
• Change the source to a different workbook. 
• Open the source workbook and check the status of the links. 

 

Additional information 

For more information on referencing data from other workbooks, go 
to: Create an external reference (link) to a cell range in another 
workbook 

Activity: Show and tell 
In this activity, you’ll learn how to reference data from other workbooks and find out the 
challenges that this might cause. 

Resources required 
You’ll need the following resources for this activity: 

• Open L3_T2_act_summary_starter.xlsx, L3_T2_act_finances.xlsx, and 
L3_T2_act_sales.xlsx in this lesson’s Learning Activity Resources. 

  

https://aka.ms/create-an-external-reference-link-to-a-cell-range-in-another-workbook
https://aka.ms/create-an-external-reference-link-to-a-cell-range-in-another-workbook
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Activity instructions 
Participate in the activity by following these instructions: 

1. Follow along as your teacher links data from the finance workbook into the summary 
workbook. 

2. Discuss what challenges this may create. 

Try-it: Reference data from other workbooks 
 In this leveled try-it, you’ll create links to other workbooks. 

Try-it 1 
Create three links from one workbook to another. 

Resources 
You’ll need the following resources for this try-it: 

• Open L3_T2_try1_summary_starter.xlsx and L3_T2_sales.xlsx in this lesson’s 
Learning Activity Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. In L3_T2_try1_summary_starter.xlsx, on the Summary worksheet, in cell B18, 
create a link to the cell E174 on the Forecast Sales worksheet in L3_T2_sales.xlsx. 

2. Repeat to link B19 to F174 and B20 to G174. 

3. Save the file as the same name plus your initials. 

Try-it 2 
Create a link to another workbook by using the SUM function. 

Resources 
You’ll need the following resources for this try-it: 

• Open L3_T2_try2_summary_starter.xlsx and L3_T2_sales.xlsx in this lesson’s 
Learning Activity Resources. 
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Instructions 
The following are the general tasks that you need to perform during this try-it. 

1. In cell B18 on the Summary worksheet in L3_T2_try2_summary_starter.xlsx, create 
a formula that totals the cells E174 to G174 in the L3_T2_sales.xlsx workbook. 

2. Save the file as the same name plus your initials. 

Try-it 3 
Create a link to another workbook that averages a defined named range. 

Resources 
You’ll need the following resources for this try-it: 

• Open L3_T2_try3_summary_starter.xlsx and L3_T2_finances.xlsx in this lesson’s 
Learning Activity Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it. 

1. In cell B4 on the Summary sheet in L3_T2_try2_summary_starter.xlsx, create a 
formula that averages the named range Category_Totals in the L3_T2_finances.xlsx 
workbook. 

2. Save the file as the same name plus your initials. 

Wrap-up 
Use these questions to check what you learned in this lesson. 

1. To return an exact match by using the MATCH function, what value would you use 
for the match_type? 

Select the correct option. 

a. -1 

b. 1 

c. 0 

d. Leave it blank 
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2. When referencing a named range in another workbook, what keyboard shortcut can 
you use to open the Paste Name dialog box? 

Select all that apply. 

a. F1 

b. F2 

c. F3 

d. F4 

3.  To break a link from one workbook to another, select the Data tab and then select 
Edit Links. Select the link to break and then select ________________________. 

Fill in the blank space. 

4. Order the following components for the INDEX function syntax in the reference form 
in the correct sequence. 

Indicate the correct sequence by adding numbers 1-4 next to the following items. 

a. Column_num - ________________________ 

b. Reference - ________________________ 

c. Area_num - ________________________ 

d. Row_num - ________________________ 
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Lesson 4: Using date and time 
functions 
Overview 
Wouldn’t it be great to be sure that when you are working with dates in a workbook 
that your data is always up to date? Well, Excel 2019 has a selection of date and time 
functions that can help you. In this lesson, you’ll learn how to use the NOW, TODAY, 
WEEKDAY, and WORKDAY functions. One of the key things to remember when 
working with date and time functions is that you should check the formatting that has 
been applied to all cells involved in the formula, including the cell where the result is 
displayed. 

Warm-up 
Use these questions to find out what you already know about this lesson’s topics. 

1. What is the keyboard shortcut to enter the current time into a cell? 

Select the correct option. 

a. Ctrl + semicolon 

b. Ctrl + Shift + semicolon 

c. Ctrl + tilde 

d. Ctrl + D 

2. If you want to calculate the next three working days from a specific date, which of 
the following functions would you use? 

Select the correct option. 

a. WEEKDAY 

b. NETWORKDAYS 

c. WORKDAY 

d. DAY 
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3. Which of the following functions will help keep current a formula that refers to 
dates? 

Select all that apply. 

a. HOUR 

b. NOW 

c. MINUTE 

d. TODAY 

4. To identify a day of the week as a number rather than a text value, you can use the 
________________________ function. 

Fill in the blank space. 

Topic 1: Use NOW and TODAY 
Using the NOW or TODAY function is an excellent way of ensuring that formulas or 

cells referring to dates are always current. You can use these functions on their own, and 
they both work in the same way. The NOW function returns the date and current time, 
and the TODAY function returns the date only. However, when you combine either 
function with other functions, you can perform highly complex calculations. 

 

Did you know? 

Excel stores dates as sequential serial numbers, which means they can 
be used in calculations. Number 1 is January 1, 1900. Number 2 is 
January 2, 1900 and so forth. That’s why, if a cell containing a date 
has been formatted as a number, you get a value such as 43831. 

NOW function 
The NOW function syntax is =NOW(). It’s particularly helpful when you need to display 
the current date and time in a worksheet, and you need it to update automatically every 
time you open the workbook. Similarly, when you use NOW within a formula, the 
formula result will also be up to date to the very minute and second according to the 
clock in your device. This is great for recording the time you started a task against the 
time you finished it because you can subtract one from the other to calculate the exact 
amount of it took to complete the task. What a great tool for time management! 
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TODAY function 
The TODAY function syntax is =TODAY(). The TODAY function is similar to the NOW 
function. It’s useful when you want to display the current date on a worksheet whenever 
you open the workbook. It’s also useful for calculating intervals between dates, in days. 
For example, you could have a cell with the start date and another with the finish date, 
and then subtract one from the other to work out how many days are between them. 
You may need to change the formatting to General if the result is returned in a date 
format. 

Date and Time keyboard shortcuts 
There are a couple of keyboard shortcuts that you can use to enter the date and/or time 
into a cell. The important thing to remember is that the shortcuts keep the date or time 
static from the moment you use them according to the date and time settings on your 
device. This means they are perfect for recording the actual date or time without having 
to enter it yourself. 

The keyboard shortcuts for inserting the date and time into a cell are: 

• Time: Ctrl+ : or Ctrl + Shift + ; (depending upon the type of keyboard you are using) 
• Date: Ctrl + ; 
The following table provides a few examples of formulas using NOW or TODAY. For all 
of the TODAY examples listed, you would get the same result using NOW. 

Formula Result 

=NOW()-2.5 The date and time 2.5 days ago 

=TODAY()-30 The date 30 days ago 

=TODAY()+14 The date two weeks from now 

=MONTH(TODAY()) The current month 

=INT((TODAY()-A1)/365) The number of years between the dates in 
cell A1. The INT function at the start 
removes any decimal points and leaves 
the integer only. 

=IF(A1>TODAY(),"Future","Past") If the date in A1 is greater than the 
current date, the result will be Future; 
otherwise, the result will be Past.  

Table 3: Examples of formulas 
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Note: When using date and time functions, take care to check the formatting that has 
been applied to the cells. You may think you have the wrong result, when it’s really just 
a matter of fixing the formatting. For example, you might need to change from a Date 
format to General or General to Short Date or Long Date. 

 

Additional information 

For more information on the TODAY function, go to: TODAY function. 

For more information on the NOW function, go to: NOW function 

Activity: Each one, teach one 
In this activity, you’ll take a few minutes to research the TODAY and NOW functions. 
You’ll then teach your partner what you learned. 

Resources required 
You’ll need the following resources for this activity: 

• Create a blank workbook to practice your formulas. 

Activity instructions 
Participate in the activity by following these instructions: 

1. Use any option available to you to research the NOW and TODAY functions. 

2. Enter some random dates in any cell in the workbook to practice with. 

3. Teach your partner something about each formula. 

Try-it: Use NOW and TODAY 
 In this standalone try-it, you’ll answer a series of date-related questions by using 

either NOW or TODAY. 

Resources 
You’ll need the following resources for this try-it: 

• Open L4_T1_try_question_time.xlsx in this lesson’s Learning Activity Resources. 
  

https://aka.ms/TODAY-function
https://aka.ms/NOW-function
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Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Answer the questions in column A using either the NOW function or the TODAY 
function, or refer to a cell within the worksheet that contains the NOW or TODAY 
function. 

2. Add a couple of your own questions to the list. 

3. Compare your results with your classmates. 

4. Did anyone add the same questions as you? 

5. Save the workbook as the same name plus your initials. 

Topic 2: Use WEEKDAY and WORKDAY 
 The WEEKDAY and WORKDAY functions belong to the Date & Time function 

category. If you ever find yourself counting days between dates using a calendar, you’ll 
find both of these functions useful. 

WEEKDAY function 
The WEEKDAY function evaluates a date and returns the day of the week as an integer. 
The syntax is =WEEKDAY(serial_number, [return_type]). 

Serial_number refers to the date, and return_type is optional. If you omit it, Sunday will 
be returned as a 1, Monday will be returned as a 2, and so on. Figure 17 lists the return 
types that are available in Excel 2019. The value that will be returned in the example 
depicted in the following screenshot will be 5 for Friday. 
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Figure 17: WEEKDAY function return types 

WORKDAY function 
The WORKDAY function is great for adding days onto a date, excluding weekends. It 
can even exclude bank holidays if you include them in the function! The syntax is 
=WORKDAY(start_date, days, [holidays]). Holidays is optional but enables you to 
achieve a more accurate result if included. When including holidays, you can refer to 
another workbook that contains a list of bank holidays or you can add the list into your 
current worksheet if you want to. Don’t forget to check the formatting that has been 
applied to the result! 

Imagine you had a task to complete within seven working days (in your case, that might 
be school days), and you were given the task on a Monday. The due date is not next 
Monday, it’s next Wednesday. If that week included one bank holiday, then the due date 
would be Thursday. If you wanted to calculate how many days it actually took you to 
complete the task, you could use the NETWORKDAYS function. 

 

Did you know? 

Not every nation or region has Monday as the first day of the working 
week. For some, Friday and Saturday constitute the weekend. Luckily, 
there is a function available that can deal with that: WORKDAY.INTL 
function. How cool is that? 

https://aka.ms/workday-intl-function
https://aka.ms/workday-intl-function
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WEEKDAY combined with SWITCH 
When working with the WEEKDAY function, you might find that having the day 
returned as an integer is a little hard to understand or not very useful. If you combine 
the WEEKDAY with the SWITCH function, you can display the integer as a text value. 

The following examples are based on the cell C2 containing 2/29/2020, which is a 
Saturday. The formula in the first example uses WEEKDAY only, and the second 
example uses the same function in combination with SWITCH. 

=WEEKDAY(C2,2) returns a result of 6 

=SWITCH(WEEKDAY(C2,1),6,"Saturday",7,"Sunday","Weekday") returns a result of 
Saturday 

The formula in the second example translates as: if the day equals 6, switch it to 
Saturday; if it equals 7, switch it to Sunday; otherwise, switch it to Weekday. 

 

Additional information 

For more information on the WEEKDAY function, go to: WEEKDAY 
function 

For more information on the WEEKDAY function, go to: WORKDAY 
function 

For more information on date and time functions, go to: Date and 
time functions (reference) 

Activity: Discuss and learn 
In this activity, your teacher will ask a volunteer to guess what the WEEKDAY and 
WORKDAY functions can do. The volunteer will then demonstrate each function using 
random dates or dates suggested by you or your classmates. 

Resources required 
You’ll need the following resources for this activity: 

• Open L4_T2_holidays.xlsx in this lesson’s Learning Activity Resources for reference 
and create a blank workbook or use any other open workbook to practice on. 

  

https://aka.ms/WEEKDAY-function
https://aka.ms/WEEKDAY-function
https://aka.ms/WORKDAY-function
https://aka.ms/WORKDAY-function
https://aka.ms/Date-and-time-functions-reference
https://aka.ms/Date-and-time-functions-reference
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Activity instructions 
Participate in the activity by following these instructions. 

1. In a blank worksheet, enter a few random dates into a few cells. 

2. You can use a keyboard shortcut or use a function to enter the current date if you 
want. 

3. Consider the kind of questions you could answer using the WORKDAY or WEEKDAY 
functions. 

4. Use L4_T2_holidays.xlsx as reference with the WORKDAY function. 

5. Prepare to share your thoughts with the class. 

Try-it: Use WEEKDAY and WORKDAY 
 In this leveled try-it, you’ll create a formula that uses the WEEKDAY function or a 

formula that uses the WORKDAY function. 

Try-it 1 
Create a function that helps you discover what day of the week you were born on. 

Resources 
You’ll need the following resources for this try-it: 

• Create a new blank workbook or use the same one from the previous activity. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Enter a random date at least 16 years ago in cell A1. 

2. Create a function in the adjacent cell that returns the day of week of the date you 
entered using the return type that would display a Monday as 1. 

3. Save the workbook as Weekday_plus your initials. 

Try-it 2 
Create a function that will calculate the date in 30 working days, including bank holidays 
for the current year. 
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Resources 
You’ll need the following resources for this try-it: 

• Open L4_T2_holidays.xlsx and L4_T2_try2_sample_dates_starter.xlsx in this 
lesson’s Learning Activity Resources for reference and create a new blank workbook 
or use the same one from the previous activity. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. In cell B2, use a keyboard shortcut to enter today’s date so that it doesn’t update in 
L4_T2_try2_sample_dates_starter.xlsx. 

2. In cell B3, create a function that will calculate 30 working days in the future using B2 
as the start and will take into account the bank holidays listed in 
L4_T2_holidays.xlsx. 

3. In cell B4, calculate how many days there are between the cells B2 and B3. 

4. Save the workbook as the same name_plus your initials. 

Wrap-up 
If time permits, you can try creating an IF function that includes TODAY. For example, if 
a cell is greater than today, it’s in the future; if it’s less than today, it’s in the past. Then 
use the following questions to check what you learned in this lesson: 

1. The result of a formula should be 12/31/2020 and it displays as 44196. Which of the 
following formats will fix it? 

Select all that apply. 

a. Number 

b. General 

c. Short Date 

d. Long Date 
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2. The WEEKDAY function has several return types that you can use to represent the
day of the week as a number. If you enter 2 as the return type, the result you get is 1.
What day of the week does 1 refer to?

Select the correct option.

a. Friday

b. Saturday

c. Sunday

d. Monday

3. To represent Sunday as 1 in the WEEKDAY function, which return type can you use
from the following?

Select all that apply.

a. Omit it

b. 1

c. 11

d. 17

4. Which of the following is the correct syntax for the WORKDAY function?

Select the correct option.

a. =WORKDAY(start_date, days)

b. =WORKDAY(start_date, days, [holidays])

c. =WORKDAY(serial_number, [return_type])

d. =WORKDAY(serial_number, days, [holidays]).
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Lesson 5: Excel customization 
options 
Overview 
In this lesson, you’ll learn how to configure when Excel updates formulas on your 
workbook and how to change Excel Options to suit your needs, potentially improving 
your productivity. 

Warm-up 
Use these questions to find out what you already know about this lesson’s topics. 

1. By default, how are formulas set to update? 

Select the correct option. 

a. By selecting F9 

b. Automatically 

c. Automatically except for data tables 

d. Manually 

2. Which of the following options can you use to set calculation options? 

Select all that apply. 

a. Select the Format tab, and then select the Formula Auditing group. 

b. Select the Format tab, and then select the Calculation group. 

c. Select File, select Options, and then select General. 

d. Select File, select Options, and then select Formulas. 

3. Which of the following tabs are available in Excel Options? 

Select all that apply. 

a. Advanced 

b. Data 

c. Ease of Access 

d. Review 
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4. Which of the following Excel Options tabs can you use to change the default font 
type and font size? 

Select the correct option. 

a. Add-ins 

b. Formulas 

c. General 

d. Proofing 

Topic 1: Set formula calculation options 
Imagine a workbook that links to several other workbooks, thus linking thousands 

of cells. Every time you open the linked workbook, it accesses all the linked data in the 
other workbooks, whether they are open or not. It can take several minutes to 
completely open the workbook and to save it. That’s okay if you are super patient, but 
that can be very time-consuming. In Excel 2019, you can choose to update calculations 
when you want to, rather than every time you make a change to a cell. 

Set calculation options by using the ribbon 
There are two main methods you can use to set calculation options to suit your needs. 
The simplest method is by using the ribbon. 

1. Select the Formulas tab, and in the Calculation group, select Calculation Options. 

 
Figure 18: Calculation group 

2. Select one of the three available options: Automatic, Automatic Except for Data 
Tables, or Manual. 

3. If you select Automatic Except for Data Tables or Manual, when you are ready to 
update the formulas, you can select Calculate Now from the Calculation group (or 
select F9) or select Calculate Sheet to update the current sheet only (or select 
Shift+F9). 

4. Select Calculation Options and then select Automatic to return to the default 
settings. 
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Set calculation options by using Excel Options 
You can also set the calculation options by using Excel Options. To do this: 

1. Select File and then select Options. 

2. In the Excel Options dialog box, select the Formulas tab, and then select the option 
you want under Calculation Options. 

3. Select OK to save your modifications. 

 
Figure 19: Formulas Options tab 

Note: 

• When you change the calculation settings in a workbook, you are setting them at the 
application level, which means that these settings will apply for every workbook that 
you use in the future and not just the current workbook or worksheet. 
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• From the Formula tab in Excel Options, you can choose to set an additional option 
to Recalculate workbook before saving. Disabling this option may help reduce the 
time it takes to close a huge workbook. 

• You can also edit the iteration calculation settings. 

 

Additional information 

For more information on setting calculation options, go to: Change 
formula recalculation, iteration, or precision in Excel 

Activity: Discuss and learn 
In this activity, you’ll open a workbook and change the calculation options. You’ll then 
use the methods available to update the functions. 

Resources required 
You’ll need the following resources for this activity: 

• Open L5_T1_act_samples.xlsx in this lesson’s Learning Activity Resources. 

Activity instructions 
Participate in the activity by following these instructions: 

1. Follow the teacher’s instructions to change the default calculation options. 

2. Consider why you might want to do this in the future. 

3. Be prepared to share your thoughts with the class. 

Try-it: Set formula calculation options 
 In this standalone try-it, you’ll set the calculation options in a workbook. 

Try-it 
Set the calculation options back to default settings. 

Resources 
You’ll need the following resources for this try-it: 

• Open L5_T1_try_samples_starter.xlsx in this lesson’s Learning Activity Resources. 

https://aka.ms/Change-formula-recalculation-iteration-or-precision-in-Excel
https://aka.ms/Change-formula-recalculation-iteration-or-precision-in-Excel
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Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Examine the formula in cell A18 on the Trace Elements worksheet. Is it current? 

2. Select the keyboard shortcut to update the entire workbook. 

3. Alter the sample value for Nickel on the 2010, 2014, and 2018 worksheets to any 
other value. Has the data on the Trace Elements worksheet updated? What about 
the chart? 

4. Set the calculations back to default settings. 

5. Save the workbook as the same name_plus your initials. 

Topic 2: Set Excel options 
When you become more experienced with using Excel, you’ll likely want to change some 
of the options to help make Excel work better for you. It’s very likely that you’ll want to 
customize the ribbon or the Quick Access Toolbar. But you might know all about that 
already if you took the Excel associate course! 

To access Excel Options, select File, and then select Options. The Excel Options dialog 
box displays several tabs for each category of options as depicted in the following 
screenshot. 
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Figure 20: Excel Options dialog box, General tab 

Make a note of whatever changes you make within Excel Options as you might change 
an option that does not produce the results you desire, and you might want to revert 
the change. You would then need to remember how to set the option back to its 
original setting. 

Select OK to apply any changes you make, but note that some changes won’t take effect 
until you restart the application. 

There are several options you can set using Excel Options; however, covering them all in 
this guide would be impossible. Instead, the following sections illustrate some of the 
most common changes users make. 
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General Options 
On the General tab, you can change: 

• The default font size 
• The number of worksheets to include in every new workbook 
• The user name 
• The Office Theme setting to Colorful, Dark Gray, Black or White 
• Displaying or hiding the mini toolbar when selecting text 
• Enabling or disabling live preview 

Formulas Options 
On the Formulas tab, you can set: 

• How Excel calculates formulas 
• Whether to enable or disable the use of table names in formulas 
• What color to use to indicate errors if you don’t want the default green 
• Error checking rules 

Proofing Options 
Use the Proofing tab to set what is checked when you run Spell Check. You can choose 
to: 

• Ignore words in UPPERCASE 
• Ignore words that contain numbers 
• Ignore internet and file addresses 
• You can also set the AutoCorrect Options and set the dictionary language. 

Save Options 
On the Save tab, you can: 

• Set the AutoRecover options 
• Set the default file location to save for local files, templates, and drafts 

Language Options 
On the Language tab, you can add languages and the order in which languages are 
used. 
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Ease of Access Options 
Use this tab to make Excel more accessible. You can choose to display ScreenTips, 
modify the display font size, and keep the accessibility checker on while you work. 

Advanced Options 
The Advanced tab has the most options that you can use for customizing Excel. On this 
tab, you can: 

• Set editing options such as enabling or disabling the fill handle, drag and drop, 
AutoComplete, and Flash Fill. 

• Enable or disable cut, copy, and paste options. 
• Set the quality of images and printing. 
• Set chart options. 
• Set display options, such as the number of recent workbooks listed in Backstage or 

whether to display the Formula Bar. 
• For a specific workbook, you can display the scroll bars, worksheet tabs, worksheet 

row and column headers, and gridlines. 
• And many more options. 

 

Did you know? 

Not every nation or region writes numbers the same way you do. For 
example, in the USA, ten thousand dollars is usually formatted as 
$10,000.00. In Germany, it’s typically formatted as $10.000,00; and in 
Switzerland, it would be $10’000.00. Changing the system separators 
in Advanced Options might be very useful if you have to keep 
changing the formatting. 

 

Add-Ins 
Use the Add-Ins tab to manage the add-ins that are available on your device. Select Go 
to activate built-in add-ins such as the Analysis ToolPak or Solver for further analysis 
of your data. 

Trust Center Options 
On the Trust Center tab, you can access the Trust Center Settings, which opens 
another dialog box as depicted in the following screenshot. You’ll learn more about the 
Trust Center options in Module 5, when creating macros. 
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Figure 21: Trust Center options 

 

Additional information 

For more information on Excel Options, go to: Advanced Options 

Activity: Discuss and learn 
In this activity, your teacher will lead a discussion on some of the key Excel options that 
you may want to change in the future. 

  

https://aka.ms/Advanced-options
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Resources required 
You’ll need the following resources for this activity: 

• Open any workbook that you have available or create a blank workbook for 
reference. 

Activity instructions 
Participate in the activity by following these instructions: 

1. Follow the discussion and ask/answer questions when prompted. 

2. You’ll perform a scavenger hunt to locate specific options in the try-it that follows. 

Try-it: Set Excel options 
 In this standalone try-it, you will locate various options within Excel Options. 

Try-it 
Work in pairs or teams to locate where the options listed can be edited in Excel 
Options. 

Resources 
You’ll need the following resources for this try-it: 

• Open L5_T2_Excel_options_starter.docx in this lesson’s Learning Activity Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Access the Excel Options. 

2. Locate the option listed in the first column in the Word document. 

3. Enter the tab where the options can be found in the second column (there may be 
more than one answer). 

4. Enter the section under which the option can be found in the third column. 

5. Compare your answers with another pair or team before checking against the 
solution file. 

Accessible alternative: 

The teacher will split the class into two teams and call out an option on the list. The 
team that finds the option first wins a point. If one team keeps winning, take turns from 
team to team. 
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Wrap-up 
For the final wrap up before the Cornerstone, there will be a function challenge if time 
permits. Open L5_T2_wrap_up.xlsx in the lesson’s Learning Activity Resources. This 
workbook contains an assortment of worksheets that should inspire you to think up 
some excellent questions. Take a moment to examine the data on any of the 
worksheets. (You can also create your own data if you prefer.) Create at least two 
questions for your neighbor to answer using any function. Swap places and answer the 
questions your neighbor has set for you. (If swapping places is not possible, just ask 
your neighbor the question.) Save the workbook as the same name plus your name.  

Use the following questions to check what you learned in this lesson: 

1. To update formulas on a workbook that is set to manual update, you can use the
keyboard shortcut ________________________ to update all formulas at any time.

Fill in the blank.

2. To update formulas on a workbook that is set to manual update, you can use the
keyboard shortcut ________________________ + ________________________ to update all
formulas in the current worksheet only.

Fill in the blanks.

3. To set the dictionary language to Spanish (Mexico), which tab would you use within
Excel Options?

Select the correct option.

a. Advanced

b. General

c. Proofing

d. Save

4. Which of the following statements is true?

Select all that apply.

a. You can hide the Formula Bar in the current workbook only.

b. You can hide the Formula Bar for all workbooks only.

c. You can hide ScreenTips from everywhere in Excel, except when entering
functions manually.

d. You can hide ScreenTips from everywhere in Excel.
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Glossary 
Array function A formula that calculates more than one variable at the same time. 

You must use Ctrl+Shift+Enter to complete an array function; the 
completed formula will be contained with braces {…}. 

Column index 
number 

The position of the column within the table array. The row index 
number refers to the position of the row within the table array. 

Expression A mathematical term; for example, >=200 (greater than or equal to 
200) or <100 (less than 100).

Function 
Arguments 

The dialog box that helps you build a formula. 

Iteration The repeated recalculation of a worksheet until a specific value is 
reached. This is used in functions such as the Solver add-in tool. 
When a formula refers to one of its own cells, it’s known as a circular 
reference, and these can iterate indefinitely. In the Excel Options > 
Formula Options, you can control the maximum number of 
iterations and the amount of acceptable change.  

Lookup value Refers to the value you want to find. 

Table array The table, range, or list of cells that contains the value you want to 
find. 

Table 4: Glossary terms and definitions 
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Cornerstone 
Overview 
In this Cornerstone, you’ll use various functions to analyze data, including Lookup and 
Date & Time functions. You’ll also reference cells from another workbook. 

Objectives 
The following table outlines the Cornerstone objectives and their corresponding MOS 
exam objectives. 

Use functions with 
multiple criteria 

• 3.1.1: Perform logical operations by using nested
functions, including IF(), IFS(), SWITCH(), SUMIF(),
AVERAGEIF(), COUNTIF(), SUMIFS(), AVERAGEIFS(),
COUNTIFS(), MAXIFS(), MINIFS(), AND(), OR(), and NOT()

Use VLOOKUP • 3.2.1: Look up data by using the VLOOKUP(), HLOOKUP(),
MATCH(), and INDEX() functions

Reference data 
from other 
workbooks 

• 1.1.2: Reference data in other workbooks

Use NOW and 
TODAY functions 

• 3.3.1: Reference date and time by using the NOW() and
TODAY() functions

Use WEEKDAY and 
WORKDAY 

• 3.3.2: Calculate dates by using the WEEKDAY() and
WORKDAY() functions

Table 5: Cornerstone objectives 

Duration 
50 minutes 
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Instructions 
1. Complete the tasks below for each file. 

2. When saving your file, add your name to the end of the filename; for example, 
Sample_Dwayne_Espino.xlsx. Follow your teacher’s directions for where to save your 
files. 

3. When you’re done with the Cornerstone, assess your completion and enter the 
points you think you earned within the task lists below. You can use the help of your 
teacher if you need it. 

Tasks 
You’ll work with three files in this Cornerstone. The following are the tasks you need to 
do within each file. 

File 1: Cornerstone_samples_starter.xlsx 
Task: Lookup values (4 points) 
1. Open Cornerstone_samples_starter.xlsx. 

2. In cell B2 in the Sample Summary worksheet, create a function that will find the 
element symbol for the element in cell A2 using the table (A1:E119) on the 
Elements worksheet. (3 points) (Exam objective 3.2.1) 

3. Fill the formula for all cells up to B27 for all the elements. (1 point) 

Points scored: ________ / 4 

Task: Use COUNTIF(S) (4 points) 
1. In cell M10 on the Sample Summary worksheet in 

Cornerstone_samples_starter.xlsx, create a function that will count how many rates 
in column H are 4 or more. (2 points) 

2. In cell M11, create a function that will count how many samples for the rates are at 
least 3 and the sample result is greater than 200. (2 points) (Exam objective 3.1.1) 

Points scored: ________ / 4 
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Task: Use IFS (4 points) 
1. In cell I2 on the Sample Summary worksheet in Cornerstone_samples_starter.xlsx, 

create an IFS function that will return the level for the rate in H2. (3 points) (Exam 
objective 3.1.1) 

2. Fill the formula in the cells for all elements. (1 point) 

Points scored: ________ / 4 

Task: Use MATCH and INDEX (6 points) 
1. Examine the contents of cell B31 on the Sample Summary worksheet in 

Cornerstone_samples_starter.xlsx. 

2. In cell C31, create an INDEX and MATCH function to return the symbol for the 
contents of cell A31 (use the formula in B31 as guidance). (3 points) (Exam objective 
3.1.1) 

3. Repeat steps 1 and 2 for Group and Periodic table row. (You can use copy and 
paste and edit the formula if you want to.) (3 points). 

Points scored: ________ / 6 

FILE 1 TOTAL POINTS: ________ / 18 

File 2: Cornerstone_test_date_starter.xlsx 
Task: Calculate future dates (5 points) 
1. Open Cornerstone_test_date_starter.xlsx and Cornerstone_holidays.xlsx. 

2. In cell B2 on the Cornerstone_test_date_starter.xlsx workbook, create a function 
that calculates the date in 10 days. (1 point) (Exam objective 3.3.1) 

3. In cell B3, check what day of the week it is by using a function that returns Monday 
as 1. (2 points) (Exam objective 3.3.2) 

4. In cell B4, create a function that will calculate 21 working days from the date in cell 
B2, ensuring that you take into account any possible holidays in 
Cornerstone_holidays.xlsx. (2 points) (Exam objective 3.3.2 and 1.1.2) 

Points scored: ________ / 5 
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Task: Combine IF with WORKDAY (3 points) 
1. In column H, there is an existing formula =(WORKDAY(F8,7) that adds 7 working 

days to the date when the last results were received. Edit the existing formula so that 
it is nested within an IF function where the result is “On Time” if the received date is 
less than 7 working days; otherwise, it’s “Late”. (2 points) (Exam objective 3.3.2) 

2. Fill the formula for all test results. (1 point) 

Points scored: ________ / 3 

FILE 2 TOTAL POINTS: ________ / 8 
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Module overview 
Description 
Entering and maintaining complex data in Microsoft Excel 2019 workbooks can be a 
challenge under the best of circumstances. When you add in factors such as varying skill 
levels, distractions, fatigue, or stress, the opportunity for error multiplies. Verifying data 
and checking formula results manually can be a tedious and time-consuming process, 
even if you have someone to help you. 

This module includes learning activities that will help you use Excel to confirm and 
expedite data entry and formula checks. You'll also learn to quickly check for and resolve 
errors. 

At the end of this module, you’ll work on the Cornerstone project to facilitate worksheet 
entries, evaluate data and formulas, and resolve errors to provide reliable data. 

Lesson Learning objective Exam objective(s) 

Validating 
data 

Apply data validation settings and remove 
duplicates from a list. 

• 2.2.2 
• 2.2.5 

Filling cells Use the Flash Fill feature and set advanced 
options for fill series. 

• 2.1.1 
• 2.1.2 

Auditing 
formulas 

Trace precedents and dependents and 
monitor cells and formulas with the Watch 
Window. 

• 3.5.1 
• 3.5.2 

Checking and 
evaluating 
data 

Create error checking rules and evaluate 
formulas. 

• 3.5.3 
• 3.5.4 

Cornerstone: 
Auditing CSA 
data 

• Use the Flash Fill feature. 
• Configure data validation. 
• Remove duplicate records. 
• Monitor cells and formulas by using the 

Watch Window. 
• Evaluate formulas. 

• 2.1.1 
• 2.2.2 
• 2.2.5 
• 3.5.2 
• 3.5.4 

Table 1: Objectives by lesson 
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Scenario 
Munson’s Pickles and Preserves Farm supports a local community supported agriculture 
(CSA) project for community members to become “farm members” and purchase shares 
of the produce to feed their families. 

Each week they receive a box of fresh produce. They can take part in farm events such as 
workdays, potlucks, and you-pick gardens to experience the joy of harvesting their own 
food. You’ve received a workbook that details produce distribution to members by 
member ID, states or provinces, and location. The data has several errors; you need to 
fix those errors and validate the data. 

Cornerstone 
After you’ve completed the lessons and try-its and navigated through several scenarios, 
the Cornerstone project will test your ability to apply what you’ve learned. In the 
Cornerstone, you’ll: 

• Use the Flash Fill feature. 
• Configure data validation. 
• Remove duplicate records. 
• Monitor cells and formulas by using the Watch Window. 
• Evaluate formulas. 
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Lesson 1: Validating data 
Overview 
At the end of this lesson, you’ll be able to apply data validation settings and remove 
duplicates from a list. 

Warm-up 
Use these questions to find out what you already know about this lesson’s topics: 

1. By using the Data Validation command, you can provide worksheet users with 
________________________. 

Select all that apply. 

a. A warning message about their cell entry. 

b. A list of values to choose from for the cell. 

c. A message about the input they need to enter in the cell. 

d. A choice of formulas. 

2. To help ensure that a list does not have any repeated rows, you can use the 
________________________ tool. 

Fill in the blank space. 

3. What are the styles of error messages available for data validation? 

Select all that apply. 

a. Stop 

b. Warning 

c. Caution 

d. Information 
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Topic 1: Perform basic data validation 
 When multiple people are entering data in a worksheet, you’ll often get different 

results for what should be the same data. It’s also likely that people make typing errors 
when performing data entry. For example, if you have multiple people entering 
employee data into a list in the Marketing Department, there might be a few different 
entries in the Department column, such as: 

• Marketing 
• Mktg. 
• Marketing Dept. 
• Mtkg. 
• Mkt. Dept. 

Inconsistent and incorrect entries will make it impossible to accurately sort, filter, and 
summarize your data. In this example, if you needed to calculate the total count of 
employees in each department, you would have five different totals. 

The Data Validation command in Excel provides a variety of ways for you to not only 
restrict the entries in a cell but also to guide and inform the users on requirements. This 
command also helps you find data that violates the restrictions you set. 

Set up data validation for cell(s) 
On the Data tab of the ribbon, in the Data Tools group, when you select the Data 
Validation command (not the drop-down list), a dialog box with three tabs displays. 
The following screenshot highlights the Data Validation command on the Data tab:  

 
Figure 1: Data Validation command on the Data ribbon tab 
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The following screenshot depicts the Data Validation dialog box with three tabs—
Settings, Input Message, and Error Alert: 

 
Figure 2: Data Validation dialog box with tabs for Settings, Input Message, and Error 
Alert 

Settings tab 
On the Settings tab, you set the criteria, or conditions and restrictions rules, for the data 
that you want to allow in the selected cell or cells. Notice that the default settings allow 
Any value in cells. In the Allow drop-down list, you can select from: 

• Whole Number, to restrict the cell to accept only whole numbers. 
• Decimal, to restrict the cell to accept only decimal numbers. 
• List, to pick data from a drop-down list. 
• Date, to restrict the cell to accept only date entries. 
• Time, to restrict the cell to accept only time entries. 
• Text Length, to restrict the length of the text entered. 
• Custom, for a custom formula. 

The remaining options on the Settings tab change according to your choice in the 
Allow drop-down list. Most options in the Allow drop-down list supply options for 
Data, which is a list of comparison operators. For each of the data options, Excel has 
appropriate cell-picker windows for Value, Minimum, Maximum, Start date, End date, 
Start time, End time, and so on. 
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If you select List in the Allow drop-down list, Excel provides a cell-picker window for the 
reference to the range of cells containing the list values. If you select Custom in the 
Allow drop-down list, Excel has a cell-picker window for the formula. The following 
screenshot depicts examples of cell-picker windows. 

 
Figure 3: Examples of cell-picker windows 

Input Message tab 
The next tab in the Data Validation dialog box is the Input Message tab. This is where 
you configure the input message that displays when the user selects a cell. Note that 
this is an optional setting. If you don’t want an input message, clear the Show input 
message when cell is selected check box. The following screenshot depicts the Input 
Message tab in the Data Validation dialog box: 

 
Figure 4: Input Message tab 

Error Alert tab 
The next tab in the Data Validation dialog box is the Error Alert tab. On this tab, you 
can configure the options for the response from Excel when a user enters data that does 
not meet the Settings criteria for valid data. This is also an optional setting. If you do 
not want an error alert, clear the Show error alert after invalid data is entered check 
box. 
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On the Error Alert tab, you can select from the following error styles: 

• Stop prevents users from entering invalid data. 
• Warning warns users that they are entering invalid data, without preventing it. 
• Information informs users that they are entering invalid data, without preventing it. 

Validation circles 
You might not want to completely prevent users from entering data in the cells with 
data validation, because that could interrupt the workflow around the data entry and 
impact productivity. By allowing users to enter data in a cell, you have information for 
which you must follow up. Going back to the example of multiple people entering 
employee data into a list in the Marketing Department, it's still helpful if the entry is 
"Mtkg" and not blank. You can identify cells in which users have entered invalid data by 
using validation circles. To use validation circles: 

1. On the Data tab, in the Data Tools group, select the Data Validation drop-down 
list, and then select Circle Invalid Data to apply circles over the cells that contain 
data that is against the validation rules you’ve set for those cells. 

2. In the Data Validation drop-down list, select Clear Validation Circles to remove the 
validation circles from any cells on the worksheet. 

You'll find that you can't anticipate all the possible errors that users make during data 
entry. When you review the data, you might discover multiple errors and then need to 
find and correct them all. For example, in a column that lists employee hiring dates, 
some entries might be for the future! You can apply data validation settings to all the 
cells in this column, including those that already have data. In this example, the data 
validation settings you need would be: 

• Allow: Date 
• Data: less than or equal to 
• End date: =TODAY() 
After you apply the data validation settings, use the Circle Invalid Data command to 
find any cells that don't meet those criteria. As you fix the invalid entries, Excel removes 
the validation circles when the entries meet the validation criteria. 

 

Additional information 

For more information on using the Data Validation tool, go to: Apply 
data validation to cells 

For more information on data validation, go to: More on data 
validation 

https://aka.ms/Validate_cell_data
https://aka.ms/Validate_cell_data
https://aka.ms/More-on-data-validation
https://aka.ms/More-on-data-validation
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Video 

To review the video on creating and managing drop-down lists, go 
to: Create and manage drop-down lists 

 

 

Did you know? 

If you're creating a worksheet for others to use, you can provide 
helpful guidance for the users on any cell or cells by using only the 
Input Message of the Data Validation dialog box. Simply leave 
Settings at Allow: Any value, and for the Error Alert, deselect the 
checkbox for Show error alert after invalid data is entered. 

Activity: Show me how 
In this activity, your teacher will demonstrate and guide you through configuring data 
validation for specific cells on a worksheet. 

Resources required 
You’ll need the following resources for this activity: 

• None 

Activity instructions 
Participate in the activity by following these instructions: 

1. Observe the teacher demonstrate how to set up data validation options. 

2. Ask the teacher clarifying questions. An example is: How can I provide input 
messages? 

Try-it: Perform basic data validation 
 In this leveled try-it activity, you'll use the methods and commands you learned in 

this topic to configure data validation. 

  

https://aka.ms/Video-Create-and-manage-drop-down-lists
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Try-it 1 
Resources 
You’ll need the following resources for this try-it: 

• Open L1_T1_try1_members_starter.xlsx in this lesson’s Learning Activity 
Resources folder. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Set the following data validation on the column of zip codes, I5:I30: 

o Validation Criteria: Text length equal to five characters 
o Input Message Title: Zip Code 
o Input Message: Enter 5-digit postal zip code. 
o Error Alert Style: Warning 
o Error Title: Zip Code Error 
o Error message: Postal zip codes require 5 digits. 

Note: You can customize the title and the input message to match postal codes in 
your country/region. 

2. Enter 3430 in cell I5, and then select Enter. 

3. Observe the warning error message. 

Try-it 2 
Resources 
You’ll need the following resources for this try-it: 

• Open L1_T1_try2_members_starter.xlsx in this lesson’s Learning Activity 
Resources folder. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Set the following data validation on the column of state abbreviations, H5:H30: 

o Validation Criteria: List with a source of =Input!$B$2:$B$9 
o Input Message Title: State 
o Input Message: Select a state from the drop-down list. 
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o Error Alert Style: Stop 
o Error Title: State Error 
o Error message: That state is not on the list. 

2. Enter WA in cell H5, and then select Enter. 

3. Observe the stop error message. 

Try-it 3 
Resources 
You’ll need the following resources for this try-it: 

• Open L1_T1_try3_members_starter.xlsx in this lesson’s Learning Activity 
Resources folder. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Set the following data validation on the column of cities, G5:G30: 

o Validation Criteria: List with a source of =Input!$A$2:$A$14 
o Input Message Title: City 
o Input Message: Select a city from the drop-down list. 
o Error Alert Style: Information 
o Error Title: City Error 
o Error message: That city is not on the list. 

2. Enter Hotlanta in cell G8, and then select Enter. 

3. Observe the information error message. 

4. Set the following data validation on the column of Num: A5:A30: 

o Validation Criteria: Whole numbers between 1 and 26 
o Input Message Title: Number 
o Input Message: Enter a number between 1 and 26. 
o Error Alert Style: Warning 
o Error Title: Number Error 
o Error message: The number must be between 1 and 26. 

5. Enter 30 in cell A5 and then select Enter. 

6. Observe the warning error message. 
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Topic 2: Remove duplicates 
 Sometimes users are in a hurry or simply don't realize that data already exists in a 

cell. At other times, while trying to quickly enter similar entries, they might copy and 
paste existing data that they then plan to replace with different values. During the 
process, they might forget or miss entries. Excel supplies tools to identify and remove 
duplicate values or records. 

You should first identify and review duplicate values or records before you remove them 
from your data. You can do this with filtering or conditional formatting. These are skills 
you might have already learned in the Microsoft Excel associate 2019 course. 

Remove duplicates from a range of cells 
When you're ready to remove duplicates, select the cells that contain those duplicates. 
On the Data tab, in the Data Tools group, select the Remove Duplicates command, 
which the following screenshot depicts: 

 
Figure 5: Remove Duplicates command on the Data tab 

In the Remove Duplicates dialog box, verify the correct selection status by selecting or 
clearing the My data has headers check box. The list of column names from your data 
is in a list box; by default, all are selected. To change the selection status more quickly, 
you can choose from the Select All or Unselect All options. When you select column 
names in the Columns list, you're telling Excel what to evaluate as a duplicate record. 
Typically, Excel considers records duplicates only if every column has the same value. 

For example, you may have a list of members in which some people have the same first 
and last names, but if any of the other columns are different, they are not duplicates. In 
the following table, none of the records are complete duplicates. However, if you 
wanted Excel to ignore the Join Date column when considering if a record is a 
duplicate, you would not select the Join Date column. Then, the first and second 
records would be considered duplicates; Remove Duplicates would keep the first 
record with the Join Date in 2010 and delete the second record with the Join Date in 
2001. 
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First Name Last Name City State Phone Join Date 

Linda Schmid Abilene KS 555-1123 1/1/2010 

Linda Schmid Abilene KS 555-1123 1/1/2001 

Linda Schmid Topeka KS 555-1134 1/1/2010 

Table 2: Examples of non-duplicate complete records 

The Remove Duplicates command always considers each row in a data set as a record. 
If it finds duplicates, it’ll keep the first record and remove any following records. Even if 
you don’t select all columns as you’re searching for duplicates, Excel will remove the 
entire record of a duplicate. 

 

Additional information 

For more information on identifying and removing duplicates, go to: 
Find and remove duplicates 

For more information on filtering for unique values or removing 
duplicate values, go to: Filter for unique values or remove duplicate 
values 

 

Did you know? 

You can use Remove Duplicates to quickly reduce a copy of a 
column of repetitive data values to a list that you can then use as the 
source for your Data Validation drop-down list! 

Activity: Tell a story 
Multiple users have been copying and pasting records into a main list from other lists, 
and over time, this has resulted in duplication. A team member has found multiple 
instances of the same records in the list and has reviewed those duplicate records to 
verify that they are not needed. They’ve asked you to remove the duplicate records. In 
this activity, your teacher will demonstrate and guide you through the steps for 
removing duplicates. 

https://aka.ms/Find-and-remove-duplicates
https://aka.ms/Filter-for-unique-values-or-remove-duplicate-values
https://aka.ms/Filter-for-unique-values-or-remove-duplicate-values
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Resources required 
You’ll need the following resources for this activity: 

• Open L1_T2_act_produce_starter.xlsx in this lesson’s Learning Activity Resources 
folder. 

Activity instructions 
Participate in the activity by following these instructions: 

1. Open the L1_T1_act_produce_starter.xlsx workbook and go to the Summer 
worksheet. 

2. Observe the teacher’s demonstrations and your own Excel window, and follow any 
instructions given. 

3. Be sure to save any changes to the file before moving on to the try-it. 

Try-it: Remove duplicates 
 In this standalone try-it activity, you'll practice using the Remove Duplicates 

command with one or more columns not selected and with all columns selected. 

Try-it 
Resources 
You’ll need the following resources for this try-it: 

• L1_T2_try_members_starter.xlsx in this lesson’s Learning Activity Resources 
folder. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Open L1_T2_try_members_starter.xlsx and go to the Members worksheet. 

2. Use the Remove Duplicates command to remove any duplicated records in the list, 
instructing it to disregard the columns Num and State. Note the information in the 
message box from Remove Duplicates. Enter the number of removed records in cell 
N3. 

3. Undo the Remove Duplicates operation to restore the removed records. 
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4. Use the Remove Duplicates command to remove any duplicate records in the list,
instructing it to disregard the column Num in evaluating duplicates. Note the
information in the message box from Remove Duplicates. Enter the number of
removed records in cell N4.

5. Undo the Remove Duplicates operation to restore the removed records.

6. Use the Remove Duplicates command to remove any duplicate records in the list.
Note the information in the message box from Remove Duplicates. Enter the
number of removed records in cell N5.

Wrap-up 
Use these questions to check what you learned in this lesson: 

1. The available tabs for Data Validation settings are:

Select all that apply.

a. Error Alert

b. Settings

c. Format

d. Input Message

2. The Remove Duplicates tool considers each row in a data set as a
________________________.

Fill in the blank space.
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Lesson 2: Filling cells 
Overview 
Why enter data yourself when you can fill cells automatically instead? In this lesson 
you’ll learn how to use the Flash Fill feature, including setting advanced options for a 
linear or growth fill series. 

Warm-up 
Use these questions to find out what you already know about this lesson’s topics: 

1. You can use the Fill command in the Editing group on the Home tab to: 

Select the correct option. 

a. Fill cells with underline formatting. 

b. Fill a workbook with worksheets. 

c. Fill cells with a series of values.  

d. Fill a worksheet with a picture. 

2. Which of the following features is Flash Fill a part of? 

Select the correct option. 

a. AutoFill  

b. AutoFit 

c. Filter 

d. Advanced Filter 

3. On which group on the Home tab can you find Flash Fill? 

Select the correct option. 

a. Number 

b. Styles 

c. Cells 

d. Editing 
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4. To fill data using a series from the ribbon commands, start by selecting the 
________________________ button. 

Fill in the blank space. 

Topic 1: Use the Flash Fill feature 
 Using Flash Fill is a great way to save time and effort. If you completed the 

Microsoft Excel associate 2019 course, you might remember using AutoFill. You might 
already be using AutoFill regularly, because it’s such a useful tool. Flash Fill is a feature 
of AutoFill. 

You can use Flash Fill to extract data from existing data and combine additional data 
with the extracted data. Be careful, as the results might not always be what you were 
expecting! You could consider using Flash Fill instead of features such as Text to 
Columns or functions such as CONCAT, UPPER, LOWER, PROPER, LEFT, and RIGHT. 

Use the Fill command 
To use Flash Fill by starting with the Fill command: 

1. Enter an example of the data you’d like to extract into a cell in the same row as the 
data to be extracted. Make sure to include any added data you want to combine with 
the extracted data. 

2. Select the cells that you want to fill, including the cell(s) to use as a basis for the rest 
of the cells. 

3. On the Home tab, select the Fill drop-down list from the Editing group, and then 
select Flash Fill, as the following screenshot depicts: 

 
Figure 6: Fill drop-down list on the Home tab 
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Use the cursor 
You also can use Flash Fill with a cursor. To do this: 

1. Enter an example of the data you’d like to extract into a cell in the same row as the 
data to be extracted. Make sure to include any added data you want to combine with 
the extracted data. 

2. Select the cell(s) to use as a basis for the rest of the cells. 

3. Position the cursor at the cell on the last row and column of the cells you selected. 
The cursor will change to a small black cross. 

4. Use your cursor to select the cells required. 

5. Release the cursor to complete the action. 

6. An AutoFill Options button displays in the corner of the filled data. 

7. Select the button and then select Flash Fill. 

Note: If the Flash Fill feature does not work, you might need to enable it.  

 

Additional information 

For more information on enabling Flash Fill, go to: Enable Flash Fill in 
Excel 

Use automatic Flash Fill 
Depending upon what you are entering into a workbook, if Excel detects a pattern, it will 
automatically offer suggestions to complete the rest of the column, which you can use 
or ignore. Imagine a column that contains a list of your classmates’ full names from cell 
A2 through to A30. Cell A2 contains Pablo Tirado and A3 contains Victor Ivanov. If 
you were to enter Tirado into cell B2 and then enter Ivanov into cell B3, Excel will 
recognize the pattern and prepopulate the rest of the cells through to B30. Select Enter 
to fill the data automatically. A Flash Fill options button will display next to the filled 
data, as the following screenshot displays, which you can select for further options if you 
want. 

 
Figure 7: Flash Fill options button 

https://aka.ms/Enable-Flash-Fill-in-Excel
https://aka.ms/Enable-Flash-Fill-in-Excel
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Note: If you were to enter Tirado and Ivanov in uppercase, the Flash Fill feature would 
fill the remaining cells in uppercase, too This means that you don’t need to use the 
UPPER function to change the case of the text. The same applies for the PROPER and 
LOWER commands. 

Activity: Show and tell 
In this activity, your teacher will demonstrate how to use Flash Fill by using a list of 
names. 

Resources required 
You’ll need the following resources for this activity: 

• L2_T1_act_students.xlsx in this lesson’s Learning Activity Resources folder. 

Activity instructions 
Participate in the activity by following these instructions: 

1. Observe the teacher’s demonstrations and your own Excel window, and follow any 
instructions given. 

2. Be sure to save any changes to the file before moving on to the try-it. 

Try-it: Use the Flash Fill feature 
 In this leveled try-it activity, you’ll extract values from existing data. Alternatively, 

you’ll extract data from existing data with added text and characters specifications. 

Try-it 1 
Use Flash Fill to extract part of the values in a column of cells. 

Resources 
You’ll need the following resources for this try-it: 

• L2_T1_try1_students_starter.xlsx in this lesson’s Learning Activity Resources 
folder. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. In cells B2 to B26, use Flash Fill to extract the first initial of each student's first name 
and then their full surname. 

2. Save the workbook as the same name plus your initials. 
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Try-it 2 
Use Flash Fill to extract data and add text. 

Resources 
You’ll need the following resources for this try-it: 

• L2_T1_try2_students_starter.xlsx in this lesson’s Learning Activity Resources 
folder. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. In cells D2 to D26, use Flash Fill to extract each student's last name, followed by a 
comma and a space. Then add the initial of their first name; for example, Pepin, A. 

2. Sort the list into alphabetical order A to Z using the new data in column D. 

3. Save the workbook as the same name plus your initials. 

Try-it 3 
Resources 
You’ll need the following resources for this try-it: 

• L2_T1_try3_students_starter.xlsx in this lesson’s Learning Activity Resources 
folder. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. In cell D2 to D26, use Flash Fill to create a user name for each student that is made 
up of their # number, first name, and first letter of the last name, followed by an 
exclamation mark; for example, 1AlainP!, 2AzeemB! 

2. Sort the list into alphabetical order Z to A by using the new data in column D. 

3. Save the workbook as the same name plus your initials. 
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Topic 2: Set advanced options for fill 
series 

 You now know how useful the AutoFill feature is. Advanced fill options enable you 
to have even more control over how Excel automatically fills data in your worksheet. 

Create a linear series using AutoFill 
A linear series is data with a continual increase or decrease. For example, 1, 3, 5, 7, 9, 11 
has a continuous increase of 2 between each number. The series 20, 15, 5, 0, -5 has a 
continuous decrease of 5 between each number. To create a linear series using AutoFill: 

1. Enter at least the first two numbers in the sequence in adjacent cells, so that Excel 
can detect the linear pattern to fill. For example, enter 5 in A1 and 9 in B1. 

2. Select the cells to be sequentially increased or decreased; for example, A1 and B1. 

3. Position the cursor at the cell that is on the last row and column of the selected cells. 
The cursor will change to a small black cross. 

4. Use your cursor to select the cells required. 

5. Release the cursor to complete the action. 

You could also: 

1. Position the cursor at the cell that is on the last row and column of the selected cells. 
The cursor will change to a small black cross. 

2. Right-click or access the context menu and then select the cells required. 

3. Release the cursor and select Linear trend. 

Create a linear series using the Fill command 
Use the Fill command on the Home tab if you want more control over how Excel fills 
data in your worksheet. To do this: 

1. Enter at least the first two numbers in the sequence in adjacent cells so that Excel 
can detect the pattern to fill. You could also just enter the starting number in one 
cell, if there is a steady increase or decrease. 

2. Select the cell(s) to be sequentially increased or decreased, including the cells you 
want Excel to fill. 

3. On the Home tab, select Fill from the Editing group. 
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4. Select Series. The Series dialog box will open. 

5. Select Linear as the Type, if not already set. 

6. Enter the Step value number that you wish to increase or decrease by, as the 
following screenshot depicts. If you already entered the pattern in the first couple of 
cells, select Trend instead. 

 
Figure 8: Fill Series dialog box 

7. Select either OK or Enter to complete the action, and then Excel will fill the selected 
cells by using the step value you entered. 

Create a growth series using AutoFill 
A growth series is data that the AutoFill feature multiplies by a consistent value that you 
configure. For example, the series 3, 9, 27, 81, 243, 729 has been multiplied by 3 (the 
step value) based on the result of each multiplication (the product). That is, 3 x 3 = 9,  
9 x 3 = 27, and 27 x 3 = 81. A growth series is also known as an exponential value. To 
create a growth series using AutoFill: 

1. Enter at least the first two numbers in the sequence in adjacent cells so that Excel 
can detect the growth pattern to fill. For example, enter 2 in A1 and 4 in B1. 

2. Select the cells to be sequentially increased; for example, A1 and B1. 

3. Position the cursor at the cell that is on the last row and column of the selected cells. 
The cursor will change to a small black cross. 

4. Select the cells required. 

5. Release the cursor to complete the action. 
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You could also: 

1. Position the cursor at the cell that is on the last row and column of the selected cells. 
The cursor will change to a small black cross. 

2. Right-click or access the context menu and select the cells required. 

3. Release the cursor and select Growth trend. 

Create a growth series using the Fill command 
You can use the Fill command to control what data Excel fills in your worksheet. To do 
this: 

1. Enter the starting value in the first cell. (You can enter the first two cells if you want 
to.) 

2. Select the cells to be sequentially filled, including the starting cell(s). 

3. From the Home tab, select Fill from the Editing group. 

4. Select Series. The Series dialog box will open. 

5. Select Growth as the Type. 

6. Enter the Step value number that you wish to multiply by. If you have already 
entered the pattern in the first couple of cells, you can select Trend instead. 

7. Select either OK or Enter to complete the action. The selected cells will be filled 
using the step value you entered. 

Create a date series 
Instead of having to manually enter dates in a sequence in a worksheet, you can use the 
Fill command to do it for you. You can also use AutoFill, but using the Fill command 
enables you to control the dates that are entered. For example, you can create a list for 
an entire year for every 14 days from the start to the end of the year. To create a date 
series by using the Fill command: 

1. Enter the starting date in the first cell. 

2. From the Home tab, select Fill from the Editing group. 
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3. Select Series. The Series dialog box displays, as the following screenshot depicts: 

 
Figure 9: Series dialog box 

4. Select Rows or Columns from the Series in selections. 

5. Select Date as the Type. 

6. Enter the Step value number that you want to increase the date by; for example, 14. 

7. Enter the last date in the series in Stop value. 

8. Select either OK or Enter to complete the action. The selected cells will be filled 
using the step value you entered. 

 

Additional information 

For more information on advanced options for fill series, go to: Project 
values in a series 

Activity: Tell a story 
In this activity, your teacher will tell a story to help explain growth trends and linear 
trends. They will then demonstrate how to create a linear series and growth series. 

Resources required 
You’ll need the following resources for this activity: 

• Open a blank workbook or use any open workbook with a new worksheet. 
  

https://aka.ms/project-values-in-a-series
https://aka.ms/project-values-in-a-series
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Activity instructions 
Participate in the activity by following these instructions: 

1. Follow the story and ask questions if you need further clarification. 

2. Follow any instructions your teacher gives you. 

3. Imagine a scenario in which you shared details of your favorite TV series with two 
people. Those two people shared this information with two people each, and all 
those people shared it with two people each. How many people will know about 
your favorite TV series after five levels in the chain? Create a Growth Fill series to 
find out. 

4. What if you told five people at the start? How many would know after 10 levels in 
the chain? 

Try-it: Set advanced options for fill series 
 In this standalone try-it activity, you’ll create a date series for a full year. 

Resources 
You’ll need the following resources for this try-it: 

• L2_T2_try_shipments_starter.xlsx in this lesson’s Learning Activity Resources 
folder. 

The following are the general tasks that you need to perform during this try-it: 

1. In cell A4, enter the first Thursday of the current year using the mm/dd/yyyy 
format. Note: You may instead enter the standard short date format that is used in 
your country/region. 

2. Use the Fill command to fill column A with every Thursday until the end of the 
current year. 

3. Save the workbook as the same name plus your initials. 
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Wrap-up 
Use these questions to check what you learned in this lesson: 

1. On a worksheet in cells A2:A50, you have the full names of people in "Last Name,
First Name" format. To put each person's first name into the next column, you need
to do the following:

Indicate the correct sequence by adding numbers 1-4 next to the following items.

a. In cell B4, begin entering the first name of the name that is in cell A4. -
________________________

b. Select the Enter key. - ________________________

c. In cell B3, enter the first name of the name that is in cell A3. -
________________________

d. When Excel displays a preview of the list of first names, select Enter. -
________________________

2. In a Linear fill series, what does the Step value refer to?

Select the correct option.

a. The value by which to multiply each value in the series.

b. The value by which to divide each value in the series.

c. The difference between each number in the series.

d. The difference between the first number and the last number in the series.

3. In a Growth fill series, what does the Step value refer to?

Select the correct option.

a. The value by which to multiply each value in the series.

b. The value by which to divide each value in the series.

c. The difference between each number in the series.

d. The difference between the first number and the last number in the series.
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4. Which of the following functions can you replace with Flash Fill? 

Select all that apply. 

a. UPPER 

b. LEFT 

c. VLOOKUP 

d. CONCAT 
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Lesson 3: Auditing formulas 
Overview 
Have you ever wondered where you would be without help from the people you interact 
with every day? Excel uses precedents and dependents to track how cells affect each 
other. In this lesson, you’ll learn how to trace precedents and dependents of cells and 
how to use the Watch Window to keep track of cells in the same worksheet or other 
worksheets. 

Warm-up 
Use these questions to find out what you already know about this lesson’s topics: 

1. You can use formula auditing tools to: 

Select the correct option. 

a. Determine if a formula result is legal. 

b. Identify why a formula is not working as expected. 

c. Find specified text within a formula. 

d. Insert functions into a formula. 

2. What is a cell that affects the value of other cells known as? 

Select the correct option. 

a. A dependent 

b. A precedent 

c. A source 

d. A circular reference 

3. On which tab will you find Watch Window? 

Select the correct option. 

a. Page Layout 

b. Formulas 

c. Review 

d. View 
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4. Which of the following statements is correct?

Select all that apply.

a. You can add watches from other workbooks while you are working in another
workbook, but only if the other workbooks are open.

b. You can add watches from other workbooks while you are working in another
workbook, even if the other workbooks are closed.

c. You can track a watch from another workbook if you have added the watch from
the workbook you are currently working in.

d. You can track a watch from another workbook if you have added the watch from
the workbook you are currently working in, but only if the other workbook is
open.

Topic 1: Trace precedents and 
dependents 

 Have you ever found yourself struggling to work out what’s going on with your 
data? Have there been errors that you haven’t been able to detect? Well, you can use 
the Trace Precedents and Trace Dependents commands in the Formula Auditing 
group to help. Using these commands is especially helpful, because they display arrows 
on the screen to help you trace which cells depend on other cells. An error in one cell 
can affect other cells exponentially! (Remember that word from the earlier lesson?) 

Trace precedent cells 
When you trace precedent cells, Excel displays arrows to indicate which cells affect the 
current value of the selected cell. To trace precedent cells: 

1. Select the cell to you want to check.

2. Select the Formulas tab and then select Trace Precedents from the Formula
Auditing group, as the following screenshot depicts:

Figure 10: Formula Auditing group 
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3. Excel displays arrows on screen, pointing to the precedent cells. The color of the
arrow varies, depending on whether there is a problem with the connection, as the
following screenshot depicts:

Figure 11: Dependent and Precedent arrows 

4. Select Precedent again to display the precedent of the precedent; do this as many
times as necessary. If you would prefer not to have arrows displayed, you can select
the Ctrl+[ keys to go to the precedent cell. Repeat the process of selecting the Ctrl+[
keys to go to that cell’s precedent.

If a precedent or dependent cell is in another worksheet or workbook, the arrow will 
have a grid attached, as depicted in the following screenshot. Double-click the dotted 
black line to open the Go To dialog box, then select Special…,and then select the 
precedent cell. As an alternative, you can use the keyboard shortcut Ctrl+[. 

Figure 12: Precedent in another worksheet 

Trace dependent cells 
When you trace dependent cells, Excel displays arrows to indicate which cells are 
affected by the current cell. To trace dependent cells: 

1. Select the cell to you want to check.

2. Select the Formulas tab and then select Trace Dependents from the Formula
Auditing group.

3. Arrows display on the screen, pointing to the dependent cells. The color of the arrow
varies, depending on whether there is a problem with the connection.

4. Select Trace Dependents again to display the dependent for that cell; do this as
many times as necessary. If you would prefer not to have arrows displayed, you can
select the Ctrl+] keys to go to the dependent cell. Repeat the process of selecting
the Ctrl+] keys to go to that cell’s dependent cell; do this as many times as
necessary.



Validating and auditing data 

33 

Remove arrows 
You can remove all the arrows in a worksheet if you want to or only the precedent or 
dependent arrows. To remove arrows: 

1. Select the Formulas tab, and then select Remove Arrows in the Formula Auditing
group, or

2. Select the Remove Arrows drop-down list, and then select Remove Precedent
Arrows or Remove Dependent Arrows.

Additional information 

For more information on tracing formulas, go to: Display the 
relationships between formulas and cells 

Activity: Discuss and learn 
In this activity, your teacher will initiate a discussion on the ways in which you’ll 
troubleshoot formulas for the precedents and dependents tools. The workbook you’ll be 
working with does not contain errors, but you’ll have the opportunity to experiment with 
the precedents and the dependents. Imagine you’re a detective tracing the paths from 
cell to cell! 

Resources required 
You’ll need the following resources for this activity: 

• L3_T1_act_shipments.xlsx and L3_T1_members.xlsx in this lesson’s Learning
Activity Resources folder.

Activity instructions 
Participate in the activity by following these instructions: 

1. Follow the discussion.

2. Observe the teacher’s demonstrations and your own Excel window, and follow any
instructions given.

3. Experiment with any cell that contains a formula.

https://aka.ms/Display-relationships-between-formulas-and-cells
https://aka.ms/Display-relationships-between-formulas-and-cells
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Try-it: Trace precedents and dependents 
 In this standalone try-it activity, you’ll trace precedents and dependents. Consider 

why there are red arrows on screen, indicating an error. Can you fix the error that is 
causing the problem? 

Resources 
You’ll need the following resources for this try-it: 

• L3_T1_try_CSA_starter.xlsx in this lesson’s Learning Activity Resources folder.

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Trace the precedents and dependents of cell G5.

2. Trace the precedents of cell L4.

3. Remove all arrows.

4. Edit the error in cell G5.

5. Trace the precedents and dependents of cell G5 and the precedents of L4. The
arrows should now be blue.

6. Leave the arrows on screen and compare your file with your neighbor. Are they both
the same?

7. Close and save the workbook as the same name plus your initials.

Topic 2: Use the Watch Window 
 The Watch Window keeps track of cell values that don’t easily display on screen. 

Using the Watch Window, you can work on your data and track the effect of your work 
on important cells in your workbook. That will save you from having to scroll through 
your worksheets when you only want to find out what's happening to specific cells. You 
could compare the Watch Window to a neighborhood watch, except that you are 
watching data. 
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Add cells to the Watch Window 
To add cell(s) to the Watch Window: 

1. On the Formulas tab, select Watch Window in the Formula Auditing group. The
Watch Window dialog box displays, as the following screenshot depicts:

Figure 13: Watch Window dialog box 

2. Select Add Watch. The Add Watch dialog box displays, with the current cell already
entered, including the worksheet name. The following screenshot displays the Add
Watch dialog box:

Figure 14: Add Watch dialog box 

3. Select the cell(s) you want to add directly in the worksheet or any other open
workbook. You can select the collapse button if you want to shrink the dialog box,
but it is not necessary.

4. Select Add.

5. Repeat steps 2 through 4 until you have added all the cells you want.

6. Close the dialog box when you no longer need it.

You can select Watch Window at any time to track the cells you have added. However, 
when you want to track them, you must make sure that all the workbooks that have cells 
in the Watch Window are open. 
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Remove cells from the Watch Window 
To remove cells from the Watch Window: 

1. Open the workbook that contains the watch that you want to delete.

2. On the Formulas tab, select Watch Window in the Formula Auditing group.

3. Select the cell to remove from the list of watches.

4. Select Delete Watch.

5. Close the dialog box.

Additional information 

For more information on using the Watch Window, go to: Watch a 
formula and its result by using the Watch Window 

Activity: Discuss and learn 
In this activity, your teacher will lead a discussion on how to use the Watch Window. 
You’ll then add and remove watches. 

Resources required 
You’ll need the following resources for this activity: 

• L3_T2_act_CSA_starter.xlsx in this lesson’s Learning Activity Resources folder.

Activity instructions 
Participate in the activity by following these instructions: 

1. Follow along with the discussion.

2. Observe the teacher’s demonstrations and your own Excel window, and follow any
instructions your teacher gives.

Try-it: Use the Watch Window 
 In this leveled try-it activity, you’ll display the Watch Window. You’ll then either 

edit a precedent cell to note the effect on the watch or add and edit a watch. 

Try-it 1 
Display the Watch Window and note the existing watch, edit a precedent cell, and note 
the change in value. 

https://aka.ms/watch-a-formula-and-its-result-using-watch-window
https://aka.ms/watch-a-formula-and-its-result-using-watch-window
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Resources 
You’ll need the following resources for this try-it: 

• L3_T2_try1_CSA_starter.xlsx in this lesson’s Learning Activity Resources folder.

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Open the Watch Window.

2. Edit the cost of lettuce for June and July to 0.35.

3. Enter the watch value for G38 in cell J5 and change the cost for lettuce back to 0.30.

4. Edit the retail cost for cherries in August to 1.97.

5. Enter the watch value for H38 in cell J8 and change the cost of cherries back to 1.99.

6. Save the workbook as the same name plus your initials.

Try-it 2 
Display the Watch Window and add a watch from the same worksheet, edit a 
precedent cell, and note the change in value. 

Resources 
You’ll need the following resources for this try-it: 

• L3_T2_try2_CSA_starter.xlsx in this lesson’s Learning Activity Resources folder.

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Open the Watch Window.

2. Add a watch for the cell G38.

3. Edit the retail cost for cherries in August to 1.97.

4. Enter the watch value for H38 in cell J5 and undo the change you made to cherries.

5. Edit the cost of cucumbers for July to 0.15.

6. Enter the watch value for G38 in cell J8 and change the cost of cucumbers back to
0.10.

7. Save the workbook as the same name plus your initials.
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Try-it 3 
Display the Watch Window. Add a watch from the same worksheet and a watch from 
another worksheet, edit a precedent cell, and note the change in value. 

Resources 
You’ll need the following resources for this try-it: 

• L3_T2_try3_CSA_starter.xlsx in this lesson’s Learning Activity Resources folder. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Open the Watch Window. 

2. Select the August worksheet. 

3. Add a watch for the cells E50 and F50 on the Summary worksheet. 

4. Edit the retail cost for cherries on the August worksheet to 1.97. 

5. Enter the watch value for Summary F50 in cell J5 on the August worksheet and 
undo the change you made to cherries. 

6. Edit the cost of cucumbers for July to 0.15. 

7. Enter the watch value for Summary E50 in cell J5 on the July worksheet and undo 
the changes you made to cucumbers. 

8. Save the workbook as the same name plus your initials. 

Wrap-up 
Use these questions to check what you learned in this lesson:  

1. Which of the following keyboard shortcuts can you use to navigate to a precedent or 
dependent cell? 

Select all that apply. 

a. Ctrl+[ 

b. Ctrl+( 

c. Ctrl+] 

d. Ctrl+) 
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2. When a cell has a precedent in another workbook, what is attached to the arrow? 

Select the correct option. 

a. A blue arrowhead 

b. A red arrowhead 

c. A black grid 

d. A black arrowhead 

3. To keep track of important cells that don’t easily display while you’re editing a 
worksheet, you can add a watch to the ________________________. 

Fill in the blank space. 

4. To remove a watch from a worksheet, you need to follow these steps. 

Indicate the correct sequence by adding numbers 1-4 next to the following items and 
add an X next to the step that is not required. 

a. Open the workbook. - ________________________ 

b. Select the cell that has been added as a watch. - ________________________ 

c. Select the watch to remove. - ________________________ 

d. Select Delete watch. - ________________________ 

e. Select Watch Window from the Formula Auditing group. - 
________________________ 
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Lesson 4: Checking and 
evaluating data 
Overview 
In this lesson, you’ll continue to learn more about the Auditing Formulas group on the 
Formulas tab. You’ll learn about error checking rules, types of errors, and evaluating 
formulas. 

Warm-up 
Use these questions to find out what you already know about this lesson’s topics: 

1. When Excel detects a possible error in a cell, which of the following indicators will
the cell display?

Select the correct option.

a. A blue square in the corner

b. A red border

c. A blue border

d. A green triangle in the corner

2. If a cell has a ##### error code, what does it indicate?

Select the correct option.

a. The function uses an incorrect operator.

b. The cell has the wrong type of formatting applied.

c. The column is not wide enough to display the cell contents.

d. The cell contains a circular reference.
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3. Which of the following commands does not belong to the Formula Auditing group? 

Select the correct option. 

a. Calculation Options 

b. Remove Arrows 

c. Error Checking 

d. Show Formulas 

4. Which of the following commands can help fix errors in a worksheet? 

Select all that apply. 

a. Watch Window 

b. Remove Arrows 

c. Error Checking 

d. Evaluate Formula 

Topic 1: Work with error checking rules 
 In this topic, you’ll learn about checking for errors in a workbook. Sometimes, 

errors on a worksheet can be obvious and you can easily find them. However, when 
you’re working with huge amounts of data, errors might be a little more difficult to 
notice. Depending upon your Excel options, errors might not even be marked! 

 

Additional information 

For more information on error checking, go to: Detect errors in 
formulas 

Find Errors 
There are many methods you can use to detect errors. If a cell contains an error, it will 
usually be marked with a green triangle in the corner, unless your Excel settings have 
changed. The green triangle is not always an error. It might indicate an inconsistency 
that Excel has detected, even though the formula is correct, and the value is exactly what 
you wanted. 

https://aka.ms/Detect-errors-in-formulas
https://aka.ms/Detect-errors-in-formulas
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Did you know? 

You can choose to disable error checking and also change the color 
that Excel uses to indicate errors! These options are on the Formulas 
tab of Excel Options. 

To investigate an error, one of the first things you might do is select any cell in the 
worksheet you want to check, and then: 

1. Select Error Checking on the Formulas tab in the Auditing Formulas group. The 
Error Checking dialog box, which the following screenshot displays, provides help 
on the first error Excel detects. 

 
Figure 15: Error Checking dialog box 

2. Select Help on this Error to open Microsoft Office Support if you want to find out 
more about that specific type of error. 

3. Select Show Calculation Steps to open the Evaluate Formula dialog box. 

4. Select Ignore Error if you want to ignore the error or, to edit the formula yourself, 
select Edit in Formula Bar. 

5. Select Previous or Next to go from one error to the next. 

6. Select Options to open the Excel Options dialog box. You can also select the File 
tab, select Options, and then select Formulas to open the Excel Options dialog box, 
where you can check the settings for error checking. The following screenshot 
depicts the Excel Options dialog box. 
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Figure 16: Formulas tab in the Excel Options dialog box 

7. In the Error Checking section, you can choose to disable error checking entirely by 
selecting the Enable background error checking check box. From here, you can 
also change the default color to use to indicate errors. This could be very helpful if 
you have color blindness or you just don’t like green! 

8. Select or clear any option for checking in the Error Checking Rules section. 
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Another way to investigate errors is to: 

1. Select Find & Select from the Editing group on the Home tab, and then select Go 
To Special. You might also select Ctrl+G, and then select Special. The Go To Special 
dialog box displays, as the following screenshot depicts: 

 
Figure 17: Go To Special dialog box 

2. Select Formulas and then clear the Numbers, Text, and Logicals check boxes. 

3. Select either OK or Enter to close the dialog box. Any cells that contain an error will 
have a different shading applied. This shading disappears when you select any cell. 

Another way to investigate errors is to select a specific cell to check and perform one of 
the following steps: 

• Select Trace Precedents or Trace Dependents to help trace cells that are causing 
errors. 

• Select the Error Checking drop-down list, and then select Trace Error. 
• Select Evaluate Formula in the Formula Auditing group. 
• Select the cell that has a green triangle in the corner, move your cursor over the 

warning symbol that displays, select the drop-down list, and then select any option 
on the submenu. The example in the following screenshot depicts a #DIV/0! error, 
which means the formula is attempting to divide by zero. 
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Figure 18: #DIV/0! error warning submenu 

 

Did you know? 

You can hide errors on a worksheet so that your data displays better. 
To do so, in your workbook, use functions such as IFERROR, ISNA, or 
IFNA. You can also use conditional formatting. Only an expert in Excel 
would know how to discover the truth!  

 

Additional information 

For further information on hiding errors, go to: Hide error values and 
error indicators in cells 

Error Types 
There are many types of errors that can occur in Excel. However, it is important to note 
that sometimes an error result is okay and might be what you’re expecting. For example, 
when you use an exact match for the range lookup in a VLOOKUP function, and the 
result is #N/A, it is indicating that the value you are searching for is not there, which 
might be what you want. The following table provides a brief outline of error types. 

https://aka.ms/hide-error-values-and-error-indicators-in-cells
https://aka.ms/hide-error-values-and-error-indicators-in-cells
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Activity: Pose a challenge 

In this activity, your teacher will pose some questions regarding errors in a workbook. 
You don’t need to correct the errors, but you need to identify the different types of 
errors within the workbook. 

Error Code Possible reason(s) for error 

###### • The data is too wide for the cell width. 
• One date has been subtracted from another date, and the result is 

a negative number. 

#DIV/0! • The number or cell reference has been divided by zero or a blank 
cell or text. 

#N/A • A required argument in a function has been omitted. 
• The cell that contains the argument is blank or contains the wrong 

type of entry. 

#NAME? • A named range or function has been referenced that does not 
exist. 

• Text has been used in a formula without quotes around it. 
• A named range or function has been misspelled. 
• A colon has been omitted from a formula. 
Note: Any text written in a formula that is not recognized by Excel will 
result in the #NAME? error. 

#NULL! • An intersection has been referred to that does not exist; for 
example, a space has been used instead of a comma (,). 

#NUM! • Text or a blank cell has been used in a formula where a number is 
required. 

• The formula is too small or too large for Excel to handle. 

#REF! • Cells required by a formula have been deleted. 

#VALUE! • Text has been entered in a cell that requires a number. 
• The wrong type of argument or operator has been used. 
• A value is not available to the formula or function. 
• AutoCorrect cannot correct the formula. 
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Resources required 
You’ll need the following resources for this activity: 

• L4_T1_act_members.xlsx in this lesson’s Learning Activity Resources folder. 

Activity instructions 
Participate in the activity by following these instructions: 

1. Observe the teacher’s demonstrations and your own Excel window, and follow any 
instructions given. There are two worksheets that have errors. 

2. Consider these questions: 

o Why are there green triangles in the corners of some cells? 
o What if you would rather not have errors display in green? 
o How can you find out what is causing errors? 
o Can you turn off the error checking feature? 

Try-it: Work with error checking rules 
 In this standalone try-it activity, you’ll match the error description with the correct 

error code. You can work with your neighbor or a partner if you want to. 

Resources 
You’ll need the following resources for this try-it: 

• L4_T1_try_error_types_starter.docx in this lesson’s Learning Activity Resources 
folder. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. In the first column of the table, read the description of the error. 

2. In the second column of the table, enter the matching error code. A list of codes has 
been provided. 
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Topic 2: Evaluate formulas 
 You can use the Evaluate Formula command to break down a function by 

component. It's especially helpful if you’re trying to evaluate a nested function or 
complex function. The Evaluate Formula command is not always for checking for errors, 
though. Sometimes, you might just want to understand what the function is doing. You 
could consider it a bit like getting into Microsoft Excel's brain. 

Evaluate a formula 
The Evaluate Formula command won’t fix an error or edit a formula. It’ll just help you 
understand what's going on with a formula. To evaluate a formula, select the cell 
containing the formula to evaluate, and then: 

1. Select Evaluate Formula from the Auditing Formulas group on the Formulas tab. 

 
Figure 19: Evaluate Formula dialog box 

2. Select Evaluate to break down, or debug, the formula in the Evaluation box. You 
can continue to select Evaluate from component to component until Evaluate 
changes to Restart, at which point you can start the evaluation again. The preceding 
screenshot depicts the underlining of the component within the formula that is 
currently being evaluated. In this case, the value in L29 does not exist in the table 
array in the VLOOKUP function. 
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3. Select Step In to break down the result of underlined part of the formula in the 
Evaluation box, which the following screenshot depicts: 

 
Figure 20: Evaluate Formula dialog box Step In 

4. Select Step Out to go back to the previous component or formula. 

5. Select Close to return to your worksheet. 

 

Additional information 

For more information on evaluating formulas, go to: Evaluate a nested 
formula one step at a time 

Activity: Think-pair-share 
In this activity, you’ll try to explain to your neighbor the problem with a formula in a 
worksheet. You can then use the Evaluate Formula command to check if you were 
correct. 

Resources required 
You’ll need the following resources for this activity: 

• L4_T2_act_members_starter.xlsx in this lesson’s Learning Activity Resources 
folder. 

Activity instructions 
Participate in the activity by following these instructions: 

1. Examine the data in the worksheet and try to understand the problem with any error 
that you find. 

2. Describe the error to your neighbor. 

https://aka.ms/Evaluate-nested-formula-one-step-at-a-time
https://aka.ms/Evaluate-nested-formula-one-step-at-a-time
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3. Use the Evaluate Formula command to evaluate the function. 

4. Correct the errors if possible. (Hint: For the event ID error, the member's choice was 
'Pick your own produce'.) 

Try-it: Evaluate formulas 
 In this standalone try-it activity, you’ll use the Evaluate Formula command on a 

complex formula in the sheet. 

Resources 
You’ll need the following resources for this try-it: 

• L4_T2_try_members_starter.xlsx in this lesson’s Learning Activity Resources 
folder. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Examine the data in the table. 

2. Select any cell that contains an error and evaluate it. 

3. Fix the error if possible. 

Wrap-up 
Use these questions to check what you learned in this lesson:  

1. To step into a formula, what command would you use? 

Select the correct option. 

a. Trace precedents 

b. Trace dependents 

c. Evaluate Formula 

d. Error checking 
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2. Which of the following keyboard shortcuts can you use to help locate errors in a 
worksheet? 

Select all that apply. 

a. F3 

b. F5 

c. Ctrl+G 

d. Ctrl+F 

3. To change the color of the error indicator in a cell, which tab would you select in the 
Excel Options dialog box? 

Select the correct option. 

a. Advanced 

b. Data 

c. Formulas 

d. General 

4. To help debug a formula, you can use the ________________________ Formula 
command. 

Fill in the blank 
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Glossary 
Audit Assess or inspect data. 

Cell-picker window A field window inside a dialog box with a collapse button that allows 
the user to collapse the dialog box, thereby displaying more of the 
worksheet cells. These windows indicate that users can directly select 
cells to insert the cell references. 

Criteria Set conditions to be checked in a function. 

Dependent A cell or cells affected by the current cell. 

Duplicate A repeated entry of data. 

Evaluate Assess a formula. 

Precedent A cell that affects the value of the current cell. 

Validate A general reference used to help ensure that the correct data is 
entered into cells in a worksheet. 

Watch Window A window that can display values in cells that don’t easily display 
while you are working in a workbook. 

Table 3: Glossary terms and definitions 
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Cornerstone 
Overview 
In this Cornerstone, you’ll validate data by using Data Validation, Remove Duplicates, 
and Flash Fill. 

Objectives 
The following table outlines the Cornerstone objectives and their corresponding 
Microsoft Office Specialist (MOS) exam objectives: 

Validate data • 2.2.2: Configure data validation 

Remove duplicates • 2.2.5: Remove duplicate records 

Use Flash Fill • 2.1.1: Fill cells by using Flash Fill 

Add a watch • 3.5.2: Monitor cells and formulas using the Watch 
Window 

Evaluate formulas • 3.5.4: Evaluate formulas 

Table 4: Cornerstone objectives 

Duration 
50 minutes 

Instructions 
1. Complete the following tasks for each file. 

2. When saving your file, add your name to the end of the filename; for example, 
Members_Dwayne_Espino.xlsx. Follow your teacher’s directions for where to save 
your files. 

3. When you’re done with the Cornerstone, assess your completion and enter the 
points you think you earned within the following task lists. You can use the help of 
your teacher if required. 
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Tasks 
You’ll work with two files in this Cornerstone. The following are the tasks you need to do 
within each file: 

File 1: Cornerstone_members_starter.xlsx 
Task: Remove duplicates (2 points) 
1. Open Cornerstone_members_starter.xlsx. 

2. Remove any duplicates in the States listed in the Lists worksheet. (2 points) (Exam 
objective 2.2.5) 

Points scored: ________ / 2 

Task: Apply data validation (6 points) 
1. Apply a validation rule for all of column H on the Members worksheet that uses the 

Abbr. column on the Lists worksheet to ensure that only states that have been 
validated can be entered in future. (2 points) (Exam objective 2.2.2) 

2. Clear the Data Validation from the cells H1 to H4. (2 points) (Exam objective 2.2.2) 

3. Circle invalid data on the Members worksheet. (1 point) (Exam objective 2.2.2) 

4. Enter the comment Check the Ref ID for this member (or note if you’re using 
Office 365) into the cell in column L containing the error on the Members 
worksheet. (1 point) 

Points scored: ________ / 6 

Task: Edit validation error message (2 points) 
1. Edit the existing validation rule on column L of the Members worksheet so that the 

style is Stop instead of Warning. (1 point) (Exam objective 2.2.2) 

2. Enter the error message Please enter a number from 0 to 6 only. (1 point) (Exam 
objective 2.2.2) 

Points scored: ________ / 2 
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Task: Use Flash Fill (2 points) 
1. Use Flash Fill to enter the Member Num, State, and ZIP code as one string of text 

in column M of the Members worksheet for all members listed. (2 points) (Exam 
objective 2.1.1) 

2. Close and save the file as Members_plus your name. 

Points scored: ________ / 2 

FILE 1 TOTAL POINTS: ________ / 12 

File 2: Cornerstone_shipments_starter.xlsx 
Task: Find errors (3 points) 
1. Open Cornerstone_shipments_starter.xlsx. 

2. Use any method to locate any errors on both worksheets within the workbook. (1 
point) 

3. Edit the comment or note in cell A1 of the July Summary worksheet to note how 
many errors you have found in the entire workbook. (2 points) 

Points scored: ________ / 3 

Task: Add a watch (2 points) 
• Add a watch for cell H108 on the Shipments July worksheet and close the Watch 

Window. (2 points) (Exam objective 3.5.2) 

Points scored: ________ / 2 

Task: Fix errors (3 points) 
1. Use any formula auditing tool to help fix the errors you have found. (3 points) (Exam 

objective 3.5.4) 

2. Close and save the file as Shipments_plus your name. 

Points scored: ________ / 3 

FILE 2 TOTAL POINTS: ________ / 8 
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Module overview 
Description 
In Module 3, you learned about validating and auditing data. In this module, you’ll learn 
various techniques to analyze and predict data, including nested functions, Forecast 
Sheet, Goal Seek, and the Scenario Manager. The skills that you learn in this module 
will help you in the future, should you decide to take out a bank loan or make an 
investment. You can use Goal Seek to find the correct value you need to use to get the 
correct output, taking away the guesswork you would otherwise need to make. 

The Scenario Manager can store several versions of values for your formulas, which you 
can display at any time for quick reference. You can even use the Scenario Manager to 
create a summary report to easily compare different values in one worksheet. In the final 
lesson, you’ll create and modify charts. It’s always advisable to be able to present your 
data in a graphic form, if possible. As usual, the module will conclude with a 
Cornerstone project to consolidate your skills. 

At any time during this module, take a few minutes to review the video on making 
predictions with data. This video will help orient you toward using basic data analysis by 
stating goals, gathering data, ensuring that the data is usable, and then using software 
tools to develop predictive models. 

 

Video 

To review the video on making predictions with data, go to: Making 
predictions with data 

Lesson Learning objective Exam objective(s) 

Forecasting 
data 

Use the IF and AND functions and create a 
forecast sheet to predict data. 

• 3.4.3 

Analyzing 
financial data 

Analyze data by using the PMT and NPER 
functions. 

• 3.4.3 
• 3.4.4 

Performing a 
what-if 
analysis 

Use Goal Seek and Scenario Manager to 
reach various results from existing data. 

• 3.4.2 

https://aka.ms/video-making-predictions
https://aka.ms/video-making-predictions
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Lesson Learning objective Exam objective(s) 

Creating 
advanced 
charts 

Add a secondary axis to a chart and create 
and modify various types of charts. 

• 4.1.1 
• 4.1.2 

Cornerstone: 
Deciding 
whether to 
produce 
more sweet 
corn 

Forecast and analyze data. • 3.4.2 
• 3.4.3 
• 3.4.4 
• 4.1.2 

Table 1: Objectives by lesson 

Scenario 
Every year, Munson’s Pickles and Preserves Farm sells out of sweet corn, disappointing 
many potential customers, including a local food-processing chain. They are considering 
increasing the number of acres devoted to sweet corn. 

There are a few givens: they can purchase land at $4,500 per acre, or they can rent it at 
$80 per acre per month. If they buy land at $4,500 per acre, the interest will be 5.4 
percent on a five-year loan. Before Munson’s management team decides to spend 
money to plant more sweet corn, they must answer the following questions: 

• How much more corn will we have to sell to be able to buy or rent the land? 
• How much will it cost per month, depending on various interest rates, loan amounts, 

and loan periods? 
• Will we have to increase the sweet corn retail price? 
• What should the retail price be to increase the forecast profit? 
• Will the extra crop revenue cover the loan repayment? 
• If we increase corn planting initiatives by 5 percent, that will increase production 

costs (seeds, fertilizer, hydration) and increase yield at the end of the season. Will this 
help pay off the loan? 
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Cornerstone 
This module concludes with a Cornerstone project, in which you’ll use logical operations 
and charts, and analyze different scenarios to find the most profitable outcome for 
Munson’s corn-planting initiative. During the Cornerstone, you’ll: 

• Edit the PMT function. 
• Create a nested IF AND function. 
• Use Goal Seek. 
• Modify a chart. 
• Create scenarios for analysis. 
• Create a summary report. 
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Lesson 1: Forecasting data 
Overview 
In this lesson, you’ll forecast data by using logical operations and the Forecast Sheet 
command. You can use a forecast to help predict things such as future sales, inventory 
requirements, future costs, or consumer trends. 

Warm-up 
Ask your neighbor what they enjoyed the most about the previous modules. Do they 
remember how to create an IF function? After a brief discussion, use the following 
questions to find out what you already know about this lesson’s topics: 

1. To which of the following categories do the IF, AND, OR, and NOT functions 
belong? 

Select the correct option. 

a. Statistical 

b. Financial 

c. Logical 

d. Text 

2. Which of the following commands can you use to help predict trends? 

Select the correct option. 

a. Subtotal 

b. Forecast Sheet 

c. Filter 

d. Advanced Filter 

3. When a formula contains another formula within it, it is known as a 
________________________ function. 

Fill in the blank space. 

4. You can find the Forecast Sheet command on the ________________________ tab, in the 
________________________ group. 

Fill in the blank spaces. 
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Topic 1: Use logical operations 
 If you took the Microsoft Excel associate course, you’ll be familiar with basic IF 

functions. In this lesson, you’ll learn about nesting an AND function into an IF function. 
Nesting functions will help you perform many kinds of analysis, and in this lesson, it’ll 
help with forecasting data. 

What is a nested IF? 
You can use an IF function to ask one question of your data, and the result will be either 
true or false. If you need to ask more than one question, for which the result will be 
either true or false, you’ll need to add other function(s) to the IF. For example, you could 
add OR, AND, NOT, or VLOOKUP. This is known as a nested formula. 

If you nest an AND into an IF function, it’s like getting a result for, as an example, “If this 
condition is true, and this condition is true, and this condition is true, then do this. If not, 
do that.” The do-this or do-that choices are up to you. The choices might be to return a 
text string, return a value. or perform a further calculation. 

 

Did you know? 

The AND and OR functions can accommodate up to 255 conditions. 
Let’s hope that you never have to create a formula that has 255 
conditions! 

As you’ve learned in previous lessons, you can create any function: 

• By entering it yourself. 
• By using the Insert Function, next to the Formula Bar or on the Formulas tab, and 

then locating the function there. 
• By using the Formulas tab and selecting the category the function belongs to. 

The syntax for IF is IF(Logical_test, [Value_if_true], [Value_if_false]). Anything within 
square brackets is optional. 

The syntax for IF with a nested AND is IF(AND(Logical1, Logical2,...)[Value_if_true], 
[Value_if_false]). 
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Create a nested IF function by entering it yourself 
To nest an AND into the IF, you start by entering =IF(AND(, in the cell you want the 
result in, and then perform the following steps: 

 
Figure 1: The IF with AND function 

1. Enter your question. 

2. Enter a comma and ask your second question. 

3. Repeat this process until you have asked all your questions. 

4. Enter a closed parenthesis, ( ) ), to close off the AND function. 

 
Figure 2: The IF with AND function, continued 

5. Enter a comma and then let Excel know what should happen if all your questions are 
true. You can do this by entering text in quotes, entering a value, or inserting a 
formula for calculations using different cells. 

6. Enter another comma and let Excel know what should happen if the answers to all 
your questions are false. The following screenshot is an example. 

 
Figure 3: The IF with AND function true and false values 

7. Finish the function with a closed parenthesis. 

The following snippets depict a few examples of nested IF functions: 

=IF(AND(A10>=100,A11>=200),"Good","Poor") 

The above example translates as, “If the value in cell A10 is greater than 100 and the 
value in cell A11 is greater than 200, then the result is good; otherwise the result is 
poor.” 

=IF(AND(B10<100,C10<100,D10>100),A10*5%,A10*2%) 

This example translates as, “If the value in cell B10 is less than 100, the value in cell C10 
is less than 100, and the value in cell D10 is greater than 100, then multiply A10 by 5 
percent; otherwise multiply A10 by 2 percent.” 
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Create a nested IF function by using the Function 
Arguments dialog box 
To create a nested IF function by using the Function Arguments dialog box, perform 
the following steps: 

1. Select the Insert Function box, which is next to the Formula Bar. In the Insert 
Function dialog box, in the Select a function section, select the IF function, and 
then select OK. The Function Arguments dialog box displays. 

Note: You can also open the Function Arguments dialog box by going to the 
Formulas tab, and then, in the Function Library group, selecting Logical, and then 
selecting IF. 

2. Before entering anything into the Logical_test box in the Function Arguments 
dialog box, go to your spreadsheet. Select the Name Box drop-down list directly 
beneath the ribbon. The following screenshot depicts this step. 

 
Figure 4: The Name Box drop-down list 

3. Select AND if it is listed. If not, select More Functions and then, in the Insert 
Function dialog box, in the Select a function section, select AND, and then select 
OK. 
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4. The Formula Bar will display =IF(AND()). You can now ask your first question in the 
Logical1 box, which the following screenshot depicts. 

 
Figure 5: The Formula Bar and Function Arguments dialog box 

5. Enter your second question into Logical2 and continue in Logical3, Logical4, and 
others if you have further questions. Excel automatically provides more boxes for you 
to enter your questions. 

6. When you’ve asked all your questions, select the IF formula directly in the Formula 
Bar. 

7. The Function Arguments box will return to the IF function where you can enter the 
value_if_true and then the value_if_false. 

8. Select OK or select Enter to complete the function. 

Note: When you’re using the Function Arguments dialog box to edit a nested function, 
when you select the function name directly in the Formula Bar, the Function 
Arguments dialog box will open the corresponding dialog box for that part of the 
formula. For example, in Figure 5, the AND part is selected. If you select the IF part, then 
the IF function dialog box will open. Select the AND part again and you will be returned 
to the AND dialog box. 

 

Video 

To review the video on using IF with AND, go to: Using IF with AND, 
OR and NOT functions 

https://aka.ms/Using-IF-with-AND-OR-and-NOT-functions
https://aka.ms/Using-IF-with-AND-OR-and-NOT-functions
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Did you know? 

There’s an exciting new addition in Excel! Instead of creating a nested 
IF, you can use the IFS function. Of course, if you were paying 
attention during Module 2, you know that already. If you have extra 
time, why not try nesting an IFS with an AND or an OR function? 
How much fun would that be? 

Activity: Discuss, demo, and learn 
Your teacher will start a discussion about the formulas that are already in a workbook 
containing sample test results. The teacher will then demonstrate how to create a nested 
IF function and how to edit a nested IF with AND function. 

Resources required 
You’ll need the following resources for this activity: 

• Open L1_T1_act_soil_report_starter.xlsx in this lesson’s Learning Activity Resources. 

Activity instructions 
Participate in the activity by following these instructions: 

1. Examine the formula in cell G2 on the Samples worksheet. 

2. Think about the question “Could the formula be written in any other way?” 

3. Follow the demonstration on how to create the same formula in cell G3. 

4. Examine the formula in cell F2 on the Trace Elements worksheet. 

Is the formula correct? 

5. Follow the teacher’s demonstration on how to edit the formula. 

Try-it: Use logical operations 
 In this leveled try-it activity, you’ll examine a nested function, describe the 

intention of a nested function, or create a nested function. 

Try-it 1 
Use an existing function to help create another function. 



Analyzing data 
 

 
13 

Resources 
You’ll need the following resources for this try-it: 

• Open L1_T1_try1_results_starter.xlsx in this lesson’s Learning Activity Resources. 

Instructions 
The following are the general tasks that you must perform during this try-it: 

1. Examine the formula in cell C5. 

2. Create a similar formula in cell C6 that asks if the value in cell B6 is less than 200 and 
less than the Potassium value in B2. If so, that is ideal. If not, the result must be 
retested. (You can copy the formula and then edit the cells if you want.) 

3. Save the file as the same filename plus your initials. 

Try-it 2 
Enter a description next to a few functions to help your classmates understand what the 
formula does. 

Resources 
You’ll need the following resources for this try-it: 

• Open L1_T1_try2_results_starter.xlsx in this lesson’s Learning Activity Resources. 

Instructions 
The following are the general tasks that you must perform during this try-it: 

1. Examine the formula in cell C5 and enter a description of what the formula is 
intending to do in cell D5. 

2. Examine the formula in cell C15 and enter a description of what the formula is 
intending to do in cell D15. 

3. Save the file as the same filename plus your initials. 

Try-it 3 
Create an IF with a nested AND function. 

Resources 
You’ll need the following resources for this try-it: 

• Open L1_T1_try3_results_starter.xlsx in this lesson’s Learning Activity Resources. 
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Instructions 
The following are the general tasks that you must perform during this try-it: 

1. Create a formula in cell C6 that gives a result of Ideal if the sample result for 
Magnesium is less than 200 and less than the sample results of Potassium. If not, 
the result should be Retest. 

2. Fill the formula for Sodium and Sulphur. 

3. Save the file as the same filename plus your initials. 

 

Did you know? 

Potassium is a mineral that’s important for the heart, kidneys, and 
other organs to work normally. Some foods that contain potassium 
are bananas, tomatoes, peas, broccoli, and melons.  

Topic 2: Create a forecast sheet 
If your data contains consistent time-based data, you can use the Forecast Sheet 
command to create a new worksheet that can help you forecast data trends in the 
future. It’s a great command to experiment with, although you might need a good 
dictionary to understand some of the mathematical terminology! To create a forecast 
sheet, perform the following steps: 

1. Select the cells containing the known dates and data. 

Note that if you select more than one row, Excel will use the last selected row to 
create the forecast. 

2. Select the Data tab and then, in the Forecast group, select Forecast Sheet. A Create 
Forecast Worksheet dialog box opens and displays the data as a line chart, as the 
following screenshot depicts. 
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Figure 6: The Create Forecast Worksheet dialog box 

3. Select a line or column chart from the corner of the dialog box. 

4. Set the Forecast End date if you need to change it. 

5. Select Options to expand the dialog and refine the forecast details. 

6. Select Create to proceed to create the forecast sheet. 
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7. A separate worksheet will display in your workbook, as the following screenshot 
depicts. 

 
Figure 7: A Forecast Worksheet 

8. Edit the Forecast, Lower Confidence Bound, or Upper Confidence Bound 
headings and figures if you want, because this won’t affect the actual data. 
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Forecast sheet options 
The following screenshot depicts the Options section in the Create Forecast 
Worksheet dialog box, in which you can configure additional settings. 

 
Figure 8: Forecast Sheet options 
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The following table describes the settings that you can configure in the Options section 
of the Create Forecast Worksheet dialog box. 

Forecast Start Set the date for the forecast to begin. If you pick a date before the 
end of the historical data, Excel only uses the data prior to the start 
date in the prediction. This is sometimes referred to as hindcasting. 

Confidence 
Interval 

Select or clear the Confidence Interval checkbox to display or hide 
it. A smaller interval implies more confidence in the forecast 
prediction. 

Seasonality Leave this option as Detect automatically if your data is something 
like an annual sales cycle with monthly figures. In such cases, Excel 
will detect the seasonality as 12. If you select Set manually instead, 
avoid setting the value to less than 2 cycles of historical data to help 
Excel identify the seasonal components. 

Timeline Range Use this option if you need to change the range for your timeline; it 
must match the Values Range values. 

Values Range Use this option if you need to change the value range; it must match 
the Timeline Range values. 

Fill Missing Points 
Using 

Use Interpolation to create an average for missing points in your 
data. You can have up to 30 percent missing data and Excel will still 
be able to create a forecast sheet. Use Zeros if you want to treat the 
missing data as zeros. 

Aggregate 
Duplicates Using 

If your data contains multiple values with the same date, Excel will 
average the values. You can choose to aggregate duplicates by using 
Average, Count, CountA, Max, Median, Min, and Sum. 

Include forecast 
statistics 

Select this checkbox if you want to add additional statistical data. 
Excel will add a table of statistics by using the Forecast.Est.Stat 
function. 

Table 2: Forecast Worksheet options 
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Additional information 

For more information on forecast sheets, go to: Create a forecast in 
Excel for Windows 

Activity: Show and tell 
In this activity, you’ll examine a workbook containing a forecast sheet. Follow your 
teacher as the teacher creates a forecast for Nuts. 

Resources required 
You’ll need the following resources for this activity: 

• Open L1_T2_act_forecast_starter.xlsx in this lesson’s Learning Activity Resources. 

Activity instructions 
Participate in the activity by following these instructions: 

1. Examine the data on the Sales by Category worksheet and note that the data is not 
complete for the entire year. 

2. Switch to the Forecast Seeds worksheet and examine the information that has been 
created by using the Forecast Sheet command. 

3. Follow along as your teacher creates another forecast for Nuts. 

Try-it: Create a forecast sheet 
 In this leveled try-it activity, you’ll create a forecast worksheet or edit the options 

for a forecast worksheet. 

Try-it 1 
Create a forecast worksheet and accept all defaults. 

Resources 
You’ll need the following resources for this try-it: 

• Open L1_T2_try1_forecast_vegetables_starter.xlsx in this lesson’s Learning Activity 
Resources. 

https://aka.ms/create-a-forecast-in-excel-for-windows
https://aka.ms/create-a-forecast-in-excel-for-windows
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Instructions 
The following are the general tasks that you must perform during this try-it: 

1. From the Sales by Category worksheet, create a forecast sheet for Vegetables by 
using the default settings. 

2. Rename the new worksheet Forecast Vegetables and move the worksheet after the 
Sales by Category worksheet. 

3. Save the file as the same filename plus your initials. 

Try-it 2 
Create a forecast sheet with set specific options. 

Resources 
You’ll need the following resources for this try-it: 

• Open L1_T2_try2_forecast_vegetables_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you must perform during this try-it: 

1. From the Sales by Category worksheet, create a forecast sheet with a column chart 
for Vegetables with the forecast end date in four months and a confidence level of 
80%. 

2. Accept all other default settings. 

3. Rename the new worksheet Forecast Vegetables and move the worksheet behind 
the Sales by Category worksheet. 

4. Save the file as the same filename plus your initials. 
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Wrap-up 
Record why you might need to nest a formula. Hand in your answer before leaving the 
classroom. You can then use the following questions to check what you learned in this 
lesson: 

1. Instead of creating a nested IF function, what single function can you use if you have 
multiple criteria to meet? 

Select the correct option. 

a. AND 

b. IFS 

c. OR 

d. NOT 

2. Which type of chart can you use when using the Forecast Sheet command? 

Select all that apply. 

a. Pie 

b. Bar 

c. Column 

d. Line 

3. How many conditions can you have within an AND function? 

Select the correct option. 

a. 255 

b. 64 

c. 1 

d. 8 

4. A ________________________ interval implies more confidence in the forecast prediction 
when you’re using the Forecast Sheet command. 

Fill in the blank space. 
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Lesson 2: Analyzing financial 
data 
Overview 
In this lesson, you’ll use the PMT and NPER functions to analyze financial data. You can 
use the PMT function to calculate how much of the loan repayments will be based on 
the interest rate and the amount loaned, and how often the repayments are made. You 
can use the NPER function to calculate the number of payments you’ll need to make to 
reach a set target, based on the amount you want to reach and the interest rate. 

Warm-up 
Do you have any concerns about the last lesson? Make sure that you note your concern 
and share it with the class to ask for their assistance. Use the following questions to find 
out what you already know about this lesson’s topics: 

1. What is PMT an abbreviation of? 

Select the correct option. 

a. Interest paid 

b. Periodic interest 

c. Payment 

d. Previous coupon data 

2. What does NPER stand for? 

Select the correct option. 

a. Net present value 

b. Net future value 

c. Nominal interest rate 

d. Number of periods 
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3. Which of the following categories does the NPER function belong to? 

Select the correct option. 

a. Logical 

b. Financial 

c. Text 

d. Math & Trig 

4. In the PMT function, Rate refers to the ________________________ rate per period for a 
loan. 

Fill in the blank space. 

Topic 1: Use the PMT function 
 The PMT function calculates the payment for a loan, based on constant regular 

payments and a constant interest rate. Imagine having to borrow money from a bank 
and you wanted to know how much it would cost you to repay per month. The PMT 
function can help you work it out; however, you’ll need to gather some facts first, such 
as: 

• What is the interest rate? 
• What is the interest term period? 
• How much money do you want to borrow?  

Create a PMT function manually 
You can create a PMT function by using the Insert Function or by selecting the 
Formulas tab on the Ribbon, then selecting Financial and then PMT. Alternatively, you 
can create a PMT function manually, which is a bit more work. To create a PMT function 
manually, perform the following steps: 

1. Enter =PMT( in the cell in which you want to make the calculation. 

2. Enter the interest rate per period, followed by a comma, such as 5%/12. 

3. Enter the number of periods over which you’ll make the payment, followed by a 
comma, such as 120 or 10*12. 

4. Enter the amount of money that you are borrowing. 

5. If you want to have no balance left and make payments at the end of each month, 
close the function by using a closed parenthesis, ), and then select Enter to complete 
the function. If not, enter a comma. 
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6. Enter the future value if you would like to leave a balance outstanding, followed by a 
comma. 

7. Enter 1 for payment at the beginning of the period or 0 for payment at the end of 
the period. 

8. Enter a closed parenthesis, ), to finish the formula, and then select Enter to complete 
the function. 

Create a PMT function by using the Function 
Arguments dialog box 
Rather than creating a PMT function manually, why not take advantage of a little 
assistance from the Function Arguments dialog box? To do so, perform the following 
steps: 

1. On your worksheet, select the Insert Function next to the Formula Bar, locate the 
PMT function, and then select OK. Alternatively, you can select the Formulas tab, 
select Financial in the Function Library group, and then select PMT. 

2. In the Function Arguments dialog box, in the Rate box, enter the interest rate. 

3. In the Nper box, enter the number of payments that you will make over the entire 
loan period. Note that as you select each part of the formula, a description will result 
that you might find helpful. 

4. In the Pv box, enter the amount loaned. 

5. In the Fv box, enter the balance that you would like to remain at the end of the loan 
period. Leave it empty if you would like no balance left. 

6. Finally, in the Type box, enter 1 if the payment will be made at the beginning of the 
period. Leave the Type box blank or enter 0 if the payment will be made at the end 
of the period. 

7. Select OK or select Enter to complete the function. 

In the following screenshot, the amount loaned is $40,000 over a period of 10 years at 
an interest rate of 5 percent annually. In this example, the calculation is monthly. 
Therefore, the loan period and interest rates should be adjusted accordingly. 
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Figure 9: The PMT Function Arguments dialog box 

The syntax for PMT is PMT(rate, nper, pv, [fv], [type]). The following table describes 
these arguments. 

Rate The interest rate per period for the loan. For example: 
• Quarterly would be B1/4 or 5%/4. 
• Monthly would be B1/12 or 5%/12. 

Nper The total number of payments for the loan. For example: 
• Quarterly would be B2*4 or 10*4. 
• Monthly would be B2*12 or 10*12 or 120. 

Pv The present value (the total amount that a series of future payments 
is worth now). 

Fv This value is optional. It is the future value, or a cash balance you 
want to reach after the last payment is made. If you leave this blank, 
the assumption is that a balance of zero is required. 

Type This value is optional. Enter 1 for payment at the beginning of the 
period. Leave this value blank or enter 0 if payment is at the end of 
the period. 

Table 3: PMT arguments 
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Did you know? 

You can easily switch a result from a negative result to a positive 
result by inserting a minus after the equals. For example, the PMT 
function gives a result that is negative by default because it is a debit 
rather than credit. If you edit the beginning of the formula to =-
PMT(…), the result will be positive. 

 

Additional information 

For more information on the PMT function, go to: PMT function 

Activity: Discuss and learn 
In this activity, your teacher will initiate a discussion about the PMT function. 

Resources required 
You’ll need the following resources for this activity: 

• Open L2_T1_act_tractor_price.xlsx in this lesson’s Learning Activity Resources. 

Activity instructions 
Participate in the activity by following these instructions: 

1. Select cell B5. 

2. Select Insert Function next to the Formula Bar. 

3. Follow the teacher’s explanation of the formula. 

4. Consider why this function might be useful to you in the future. For example, what 
might you, your friends, or family need a loan for? 

Try-it: Use the PMT function 
 This is a leveled try-it, in which you’ll edit an existing PMT function or create one 

from scratch. 

Try-it 1 
In this try-it, you’ll edit cells that will affect the monthly repayment amount. 

https://aka.ms/pmt-function
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Resources 
You’ll need the following resources for this try-it: 

• Open L2_T1_try1_tractor_price_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you must perform during this try-it: 

1. Examine the formula in cell B5. 

2. Edit the annual interest rate to 7% and note the monthly repayment result in cell G3. 

3. Edit the annual interest rate to 6% and note the monthly repayment result in cell G4. 

4. Edit the annual interest rate to 5% and edit the loan period to 8 years. 

5. Note the monthly repayment result in cell G5. 

6. Save the file as the same filename plus your initials. 

Try-it 2 
Create a PMT formula that will calculate the monthly repayment amount for a loan over 
five years, and then calculate the loan’s amount for one year. 

Resources 
You’ll need the following resources for this try-it: 

• Open L2_T1_try2_tractor_price_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you must perform during this try-it: 

1. Examine the PMT function in cells B5 and B14. 

2. Create a PMT function in cell B24 that will calculate the monthly repayment if the 
annual interest is 5%, the loan period is 5 years, and the amount of loan is 100000. 
Also include the price of a loader and backhoe, which is listed in the table. 

3. Calculate the annual payment total for a year in cell B25. 

4. Save the file as the same filename plus your initials. 
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Try-it 3 
Create a PMT function from scratch in a blank workbook for a loan that’s paid off 
quarterly over five years. 

Resources 
You’ll need the following resources for this try-it: 

• Open a blank workbook. 

Instructions 
The following are the general tasks that you must perform during this try-it: 

1. Enter the following information into the worksheet: 

a. In cell A1, enter Loan amount, and in B1, enter 5000. 

b. In cell A2, enter Interest rate, and in B2, enter 4.5%. 

c. In cell A3, enter Loan period, and in B3, enter 20. 

d. In cell A4, enter Quarterly repayment. 

2. In cell B4, create a PMT function that will calculate the monthly repayment by using 
the contents of cells B1, B2, and B3. 

3. Change the result to a positive number. 

4. Save the file as Loan_calculation_plus your initials. 

Topic 2: Use the NPER function 
 The NPER function is similar to the PMT function, except that it refers to an 

investment rather than a loan. Use the NPER function to determine the number of 
periods for an investment if you’re making constant payments periodically at a constant 
interest rate. As with the PMT function, you can create it yourself or use Insert Function 
to help you. 

Create an NPER function manually 
You can create an NPER function by using the Insert Function or by selecting the 
Formulas tab on the Ribbon, then selecting Financial and then NPER. To create an 
NPER function manually, perform the following steps: 

1. Enter =NPER( in the cell in which you want to make the calculation. 

2. Enter the interest rate per period followed by a comma, such as 5%/12,. 
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3. Enter the amount you are paying as a negative number followed by a comma, such 
as -100,. 

4. Enter the amount that you have paid to date, followed by a comma, such as 2000,. 

5. Enter 1 to calculate the payment from the beginning of the month, or 0 to pay at the 
end of the month, as in 120 or 10*12. 

6. Enter the target amount you want to reach, followed by a comma, such as 20000,. 

7. Enter 1 for payment at the beginning of the period or 0 for payment at the end of 
the period. 

8. Enter a closed parenthesis, ), to finish the formula, and then select Enter to complete 
the function. 

Create an NPER function by using the Function 
Arguments dialog box 
When you create an NPER function by using the Function Arguments dialog, you 
might observe similarities with the PMT function. As you select each part of the formula, 
a description will result that you might find helpful. 

1. On your worksheet, select the Insert Function next to the Formula Bar, locate the 
NPER function, and then select OK. Alternatively, you can select the Formulas tab, 
select Financial in the Function Library group, and then select NPER. 

2. In the Function Arguments dialog box, in the Rate box, enter the interest rate. 

3. In the PMT box, enter the amount to pay per period. 

4. In the Pv box, enter the amount saved to date. 

5. In the Fv box, enter the amount that you want to save. 

6. Finally, in the Type box, enter 1 if the payment will be made at the beginning of the 
period. Leave the Type box blank or enter 0 if the payment will be made at the end 
of the period. 

7. Select OK or select Enter to complete the function. 

In the following screenshot, which depicts the Function Arguments dialog box for 
NPER, the amount to save is $10,000 with an interest rate of 1% annually. An amount of 
$100 is paid monthly, and $1,500 has been saved to date. The interest rate needs to be 
divided by 12 to make it monthly. To reach the target of $10,000, it will take 81 months. 
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Figure 10: The NPER function dialog box 

The syntax for the NPER function is =NPER(rate, pmt, pv, [fv], [type]). Note the 
similarities with the PMT syntax. The following table describes these arguments. 

Rate The interest rate for each period for the investment. 

Pmt The payment that you’ll make for each period. Note that you cannot 
change this for the life of the investment. You usually enter this value 
as a negative number. 

Pv The present value or lump sum (the amount that a series of future 
payments is worth now). You usually enter this value as a negative 
number. 

Fv This value is optional and specifies the future value, or a cash balance 
that you want to achieve after making the last payment. If you leave 
this blank, the assumption is that a balance of zero is required. 

Type This value is optional. Enter 1 if you’ll pay at the beginning of the 
period. Leave it blank or enter 0 if you’ll pay at the end of the period. 

Table 4: NPER arguments 
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Additional information 

For more information on the NPER function, go to: NPER function 

For more information on the financial functions available in Microsoft 
Excel 2019, go to: Financial functions (reference) 

Activity: Tell a story 
In this activity, your teacher will tell a story about monthly investments that Fernando 
Vasquez, the Munson’s beekeeper, is making to save for some new beekeeping 
equipment. 

Resources required 
You’ll need the following resources for this activity: 

• Open L2_T2_act_investment.xlsx in this lesson’s Learning Activity Resources. 

Activity instructions 
Participate in the activity by following these instructions: 

1. Examine the contents of cell B7. 

2. Consider how long the investment would be if the interest rate was higher, if 
Fernando paid more money per month, or if the future value was changed. 

Try-it: Use the NPER function 
 In this leveled try-it, you’ll examine an NPER function and edit it, or create one 

from scratch. 

Try-it 1 
Edit the monthly investment amount and note the new investment period value. 

Resources 
You’ll need the following resources for this try-it: 

• Open L2_T2_try1_investment_starter.xlsx in this lesson’s Learning Activity 
Resources. 

https://aka.ms/nper-function
https://aka.ms/financial-functions-reference
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Instructions 
The following are the general tasks that you must perform during this try-it: 

1. Edit the contents of cell B5 to -150. 

2. Enter the new value for the investment period in cell B13. 

3. Edit the contents of cell B5 to -200. 

4. Enter the new value for the investment period in cell B14. 

5. Save the file as the same filename plus your initials. 

Try-it 2 
Edit an NPER function to set the payment to be due at the beginning of the month. 

Resources 
You’ll need the following resources for this try-it: 

• Open L2_T2_try2_investment_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you must perform during this try-it: 

1. Select cell B7 and use the Insert Function to change the payment to be due at the 
beginning of the month. 

2. Save the file as the same filename plus your initials. 

Try-it 3 
Create an NPER function, with the payment due at the end of each month. The aim is to 
save $2,000 with an annual interest rate of 1.5 percent, paying $50 per month. 

Resources 
You’ll need the following resources for this try-it: 

• Open L2_T2_try3_investment_starter.xlsx in this lesson’s Learning Activity 
Resources. 
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Instructions 
The following are the general tasks that you must perform during this try-it: 

1. Examine the formula in cell B7. 

2. Insert a new worksheet and rename it My Investment Plan. 

3. Enter the following data into the new worksheet: 

a. Enter Annual interest rate in cell A1 and 1.5% in cell B1. 

b. Enter Total to reach in A2 and 2000 in cell B2. 

c. Enter Present value in A3 and 500 in cell B3. 

d. Enter Monthly investment in cell A4 and -50 in cell B4. 

e. Enter Length of Investment in cell A5. 

4. Create a formula in cell B5 that calculates the length of the investment by using the 
data in cells B1, B2, B3, and B4 with the payment due at the end of each month. 

5. Save the file as the same filename plus your initials. 

Wrap-up 
Discuss with your classmates when you think you might need the NPER or PMT 
function in the future. If you could save money, what would you like to invest in? What 
expenditure would you take out a loan for? After your discussion, use the following 
questions to check what you learned in this lesson: 

1. Which of the following must you complete when creating an NPER function? 

Select all that apply. 

a. Rate 

b. Pmt 

c. Pv 

d. Fv 

2. The PMT function returns a ________________________ value by default. 

Fill in the blank space. 

3. If a function’s syntax contains brackets ([ ]) around any segment of the function (for 
example, [pv]), that means that segment is ________________________. 

Fill in the blank space. 
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4. What’s the order of the syntax for the PMT function? 

Indicate the correct sequence by adding numbers 1-5 next to the following items. 

a. Fv 

b. Pv 

c. Rate 

d. Type 

e. Nper 
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Lesson 3: Performing a what-if 
analysis 
Overview 
Have you or a friend ever wondered "what if this happened?" or "what if that 
happened?" when you’re thinking about a financial or numerical calculation? Well, Excel 
can help answer questions like that. In this lesson, you’ll perform a what-if analysis by 
using Goal Seek and Scenario Manager. 

Warm-up 
Use these questions to find out what you already know about this lesson’s topics: 

1. Which of the following belongs to the what-if analysis tools? 

Select all that apply. 

a. Data Tables 

b. Scenario Manager 

c. Goal Seek 

d. Data Validation 

2. Which of the following describes what you can do with Goal Seek? 

Select the correct option. 

a. Find the correct input for the value you want. 

b. Create different groups of values or scenarios. 

c. Display the results of multiple inputs at the same time. 

d. Choose from a list of rules to limit the type of data that people can enter. 
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3. Which of the following statements are false? 

Select all that apply. 

a. Goal Seek can replace one value at a time. 

b. Goal Seek can replace multiple values at the same time. 

c. You can use Goal Seek to limit the type of data that people can enter. 

d. Goal Seek can create different groups of values. 

4. You can find Scenario Manager on the ________________________ tab, in the 
________________________ group. 

Fill in the blank spaces. 

Topic 1: Perform a goal seek 
 Goal Seek is a command that you can use when you know the result that a formula 

should provide, and you want to know the value an item must to give that result. You 
could keep guessing what the value should be and you might get to the result you want; 
however, Goal Seek can do the work for you much faster. 

Use Goal Seek 
In Goal Seek, you can only use one variable input and the variable item must be in the 
existing formula. If you need to use multiple variable inputs, Excel has an excellent 
Solver add-in that you can activate via File > Options > Add-ins. To use Goal Seek, 
perform the following steps: 

1. Create the formula that you need in your worksheet. 

2. Select the Data tab, and then, in the Forecast group, select What-If Analysis. 

3. Select Goal Seek. 

4. In the Goal Seek dialog box, in the Set cell box, enter the cell that you want to set. 

5. In the To value box, enter the value that you want the result to be. 

6. In the By changing cell box, enter the cell to be changed. 

7. Select OK to finish. 

In the following screenshot, the PMT function is used and the desired result is 400 per 
month. You could change the interest rate, the length of the loan period, or the amount 
loaned because all of these are in the result cell. 

Note: The value entered is -400 because the current result is a negative number. 
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Figure 11: Goal Seek dialog box 

If you aren’t satisfied with the changes to your data, you can select Undo on the Quick 
Access Toolbar (or Ctrl + Z) to return to the original values. You can then run Goal 
Seek again to change a different variable. 

 

Additional information 

For more information on Goal Seek, go to: Use Goal Seek to find the 
result you want by adjusting an input value 

For more information on Solver, go to: Define and solve a problem by 
using Solver 

Activity: Tell a story 
In this activity, your teacher will continue the story of Fernando’s investment plans, and 
how Goal Seek can be useful in performing an analysis. 

Resources required 
You’ll need the following resources for this activity: 

• Open L3_T1_act_investment.xlsx in this lesson’s Learning Activity Resources. 

Activity instructions 
Participate in the activity by following these instructions: 

1. Examine the formula in cell B7, as a reminder of how the NPER function works. 

2. Your teacher will demonstrate using Goal Seek to find the best interest rate to pay 
off the loan within 30 months. 

https://aka.ms/Use-Goal-Seek-to-find-the-result-you-want-by-adjusting-an-input-value
https://aka.ms/Use-Goal-Seek-to-find-the-result-you-want-by-adjusting-an-input-value
https://aka.ms/Define-and-solve-a-problem-by-using-Solver
https://aka.ms/Define-and-solve-a-problem-by-using-Solver
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3. Your teacher will split the class into two groups. One group will guess the amount to 
save monthly to be able to pay off the loan within 30 months. The other group will 
guess what the future value will be to pay off the loan within 30 months. 

4. Perform the Goal Seek to get the actual value. How close where you in guessing the 
correct value? 

5. What would your preferred solution be if you were Fernando? 

Try-it: Perform a goal seek 
 In this leveled try it activity, you’ll use Goal Seek to reduce the monthly 

repayment to $40 for a new drone. 

Try-it 1 
The maximum amount that you can afford to pay for a new drone is $40 per month. Use 
Goal Seek to help reduce the monthly repayment value down to -40 to keep within 
your budget. 

Resources 
You’ll need the following resources for this try-it: 

• Open L3_T1_try1_drone_payment_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you must perform during this try-it: 

1. Use Goal Seek to reduce the monthly repayment value to -40 by changing the 
amount you borrow. 

2. Save the file as the same filename plus your initials. 

Try-it 2 
The maximum amount that you can afford to pay for a new drone is $40 per month. Use 
Goal Seek to help reduce the monthly repayment value to -40. You aren’t sure if you 
should try to find a lower interest rate, reduce the loan amount, or increase the loan 
period. You decide to note three values to discuss with your colleagues before you 
make a final decision. 
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Resources 
You’ll need the following resources for this try-it: 

• Open L3_T1_try2_drone_payment_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you must perform during this try-it: 

1. Use Goal Seek to calculate the best interest rate to reduce the monthly repayment 
value to $40. 

2. Note the value suggested in cell B9, and then undo the solution. 

3. Repeat for the loan period and note the value in cell B10. 

4. Repeat for the loan amount and note the value in cell B11. 

5. Save the file as the same filename plus your initials. 

Topic 2: Use the Scenario Manager 
 Have you ever created multiple worksheets that contain versions of the same data, 

with minor differences, and then find yourself switching from sheet to sheet to compare 
results? Well, the Scenario Manager could be just the tool for you. The tool will not 
only save time but also will keep everything in one place and enable you to easily switch 
between different sets of data when necessary. 

Create a scenario 
The scenario in the following example is a simple one based on changing one cell. You 
can change as many cells as you need to in each scenario you create. To create a 
scenario, perform the following steps: 

1. Select the Data tab, and then, in the Forecast group, select What-If Analysis. 

2. Select Scenario Manager. 

3. In the Scenario Manager dialog box, select Add to create a new scenario. 

4. In the Add Scenario dialog box, in the Scenario name box, enter a suitable name 
for the scenario. 
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Figure 12: The Add Scenario dialog box 

5. In the Changing cells box, enter the cell(s) to be changed. You can do this by 
entering their cell reference or by selecting the cells on the worksheet. 

6. Add a comment in the Comment box if you want to, and then select OK. The 
Scenario Values dialog box displays, as depicted in the following screenshot. 

 
Figure 13: The Scenario Values dialog box 

7. In the Scenario Values dialog box, select OK. The values that are currently in the 
cells will be entered automatically. 

8. Repeat the above steps until you have created all the scenarios that you need. 
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9. Select OK to return to the Scenario Manager dialog box, which the following 
screenshot depicts. 

 
Figure 14: Scenario Manager dialog box 

10. In the Scenario Manager dialog box, select any scenario in the Scenarios box, and 
then select Delete to remove it or Edit to make alterations. 

11. To switch to a different scenario, select any scenario, and then select Show. Your 
data will update to that scenario. 

12. Select Close to close the dialog box. 

At any time, you can access the Scenario Manager and switch to a different scenario, 
edit existing scenarios, and delete scenarios. You can also merge scenarios from another 
workbook. 

Create a summary report 
When you’ve created multiple scenarios, you might decide to create a report that will 
summarize the data for every scenario. To do this, you can create a summary report by 
performing the following steps: 

1. Select the Data tab, and then, in the Forecast group, select What-If Analysis. 

2. Select Scenario Manager. 
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3. In the Scenario Manager dialog box, select Summary, and then the Scenario 
Summary dialog box, which is depicted in the following screenshot, in the Results 
cells box, enter the cell on which to base the report. (In most cases, it will be the 
total value cell.) 

 
Figure 15: The Scenario Summary dialog box 

4. Select OK. 

A Summary report will be created in a separate worksheet for easy comparison, as 
depicted in the following screenshot. 

 
Figure 16: A Summary report 

5. Edit the references in the report to make it easier to understand if you want to. For 
example, in Figure 16, $G$1 could be edited to Predicted Percentage Increase. 

 

Additional information 

For more information on the Scenario Manager, go to: Switch 
between various sets of values by using scenarios 

  

https://aka.ms/switch-between-various-sets-of-values-by-using-scenarios
https://aka.ms/switch-between-various-sets-of-values-by-using-scenarios
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Activity: Remind, explain, and learn 
In this activity, your teacher will remind you about a few formulas that you learned in 
Module 2. You’ll then create several scenarios, with your teacher’s help. 

Resources required 
You’ll need the following resources for this activity: 

• Open L3_T2_act_forecast_starter.xlsx in this lesson’s Learning Activity Resources. 

Activity instructions 
Participate in the activity by following these instructions: 

1. Examine the formulas in cells I8, I9, and I10. 

2. What does each formula calculate? Prepare to share with the class if you’re asked. 

3. Consider the following questions: 

a. What if you wanted the summary for different months and seasons? 

b. What if the forecast value was different? 

c. Imagine creating different worksheets to summarize different values or having to 
create lots of different formulas to get the answers you want. You might end up 
duplicating a lot of work and losing track of where you are. How would you avoid 
this? 

4. Follow the teacher’s instructions to create several scenarios. 

Try-it: Use the Scenario Manager 
 In this leveled try-it, you’ll either edit an existing scenario or create new scenarios. 

Try-it 1 
Rename an existing scenario, edit a scenario value, and display the results. 

Resources 
You’ll need the following resources for this try-it: 

• Open L3_T2_try1_sales_forecast_starter.xlsx in this lesson’s Learning Activity 
Resources. 
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Instructions 
The following are the general tasks that you must perform during this try-it: 

1. Edit the scenario named Farm Shop to Farm Shop Autumn and change the current 
value in the last scenario value to November. 

2. Show the Farm Shop Autumn scenario. 

3. Save the file as the same filename plus your initials. 

Try-it 2 
Create two additional scenarios and display a scenario result. 

Resources 
You’ll need the following resources for this try-it: 

• Open L3_T2_try2_sales_forecast_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you must perform during this try-it: 

1. Create a new scenario named Wholesale Winter that stores the contents in cells H2, 
H5, H6, and H7:J7 as they currently exist. 

2. Create an additional scenario named Wholesale Summer that changes the cells as 
follows: 

o H2 to 4% 
o H5 to Wholesale Summary (unchanged) 
o H6 to Summer 
o H7 to June 
o I7 to July 
o J7 to August 

3. Show the Wholesale Summer scenario. 

4. Save the file as the same filename plus your initials. 

Try-it 3 
Create two new scenarios and create a summary report. 
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Resources 
You’ll need the following resources for this try-it: 

• Open L3_T2_try3_sales_forecast_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you must perform during this try-it: 

1. Create a new scenario named Wholesale Winter that stores the contents in cells I2, 
I6, and I7:K7 as they currently exist. 

2. Create an additional scenario named Wholesale Spring that changes the cells as 
follows: 

o I2 to 3% 
o I6 to Spring 
o I7 to March 
o J7 to April 
o K7 to May 

3. Show the Wholesale Spring scenario. 

4. Create a Summary report based on cells I2, I10, J10, and K10. 

5. Rename the summary worksheet as Wholesale Summary. 

6. Save the file as the same filename plus your initials. 

Wrap-up 
Ask your neighbor if there is anything they don’t understand from today’s lesson, and 
then help them if possible. If you’re unable to assist, help your neighbor note down the 
problem for the mud puddle or parking lot. Then, use these questions to check what 
you learned in this lesson: 

1. Which of the following commands are available in the Scenario Manager dialog 
box? 

Select all that apply. 

a. Merge 

b. Summary 

c. Add 

d. Show All 
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2. Which of the following statements are correct? 

Select all that apply. 

a. The cell changed when you use Goal Seek does not need to be a precedent of 
the value you want to set. 

b. The cell changed you use Goal Seek must be a precedent of the value you want 
to set. 

c. The cell changed when you use Goal Seek must be a dependent of the value you 
want to set. 

d. The cell changed when you use Goal Seek does not need to be a dependent of 
the value you want to set. 

3. Which of the following command categories is Goal Seek part of? 

Select the correct option. 

a. What-If Analysis 

b. Formula Auditing 

c. Calculation options 

d. Financial functions 

4. Which of the following steps isn’t required to delete an existing scenario in a 
workbook? 

Indicate the incorrect step by marking it as false. 

a. Select What-If Analysis. 

b. Select Scenario Manager. 

c. Select the scenario to delete. 

d. Select Delete. 

e. Select OK. 

f. Select Close. 
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Lesson 4: Creating advanced 
charts 
Overview 
In this lesson, you’ll create dual-axis charts and an advanced chart. Sometimes, you 
might need to display several categories in a chart that have vastly different numerical 
values. For example, one series might contain values between 50 and 100, another series 
might contain values between 1000 and 2000, and another might contain values that are 
all less than 10. If you were to display all the categories on one axis, it would make the 
lower number very difficult to understand. If the series containing numbers between 
1000 and 2000 were plotted against a different axis in the same chart, it would be much 
easier to understand. 

Warm-up 
Use these questions to find out what you already know about this lesson’s topics: 

1. When a chart combines two or more types of charts, what is it known as? 

Select the correct option. 

a. Doughnut 

b. Combo 

c. 3D bar 

d. Surface 

2. To display progressively smaller steps, which of the following charts would you use? 

Select the correct option. 

a. Sunburst 

b. Scatter 

c. Radar 

d. Funnel 
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3. Which of the following are types of charts? 

Select all that apply. 

a. Waterfall 

b. Win/Loss 

c. Box-and-whisker 

d. 3D map 

4. How many series of data can you use in a pie chart? 

Select the correct option. 

a. A maximum of 6 

b. A maximum of 3 

c. 2 

d. 1 

Topic 1: Create dual-axis charts 
 Have you ever observed a chart that uses a wide range of data, thereby making it 

difficult for you to understand the data? For example, in a column chart, some columns 
might be very small when compared to other columns that are huge. Such data might 
be perfect for a dual-axis chart, also known as a secondary axis chart. The following 
screenshots contain a few examples. Which one can you understand better? 

The following is a column chart with totals alongside the categories. 

 
Figure 17: A column chart 
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The following is a combo chart displaying the totals as a line against a secondary axis. 

 
Figure 18: A combo chart with secondary axis 

Add a secondary axis 
To add a secondary axis to a chart, perform the following steps: 

1. Select the chart that you want to edit. 

2. On the Chart Tools contextual tab, select the Design tab. 

3. In the Type group, select Change Chart Type. 

4. In the Change Chart Type dialog box, in the navigation pane, select Combo. 
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Figure 19: A Change Chart Type dialog box 

5. In the Secondary Axis column, select the check box against the series that you want 
to display against a secondary axis. 

6. If you also want to change the chart type, in the Chart Type column, select the drop-
down list, and then select a different type of chart, for example, Line with Markers. 

7. Select OK to close the dialog box. 

 

Video 

To review the video on dual-axis charts, go to: Add or remove a 
secondary axis in a chart in Excel 

To review the video on data visualization, go to: Data visualization 

Activity: Discuss and learn 
This activity is student driven. You or one of your classmates will use the teacher’s 
computer to edit an existing chart. 

https://aka.ms/Add-or-remove-a-secondary-axis-in-a-chart-in-Excel
https://aka.ms/Add-or-remove-a-secondary-axis-in-a-chart-in-Excel
https://aka.ms/video-data-visualization
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Resources required 
You’ll need the following resources for this activity: 

• Open L4_T1_act_sales_starter.xlsx in this lesson’s Learning Activity Resources. 

Activity instructions 
Participate in the activity by following these instructions: 

1. Volunteer to add the totals per quarter to the existing chart on the teacher’s 
computer, which will be projected on-screen. You could also offer assistance to your 
classmate. 

2. After including the totals, determine if there is anything unusual about the chart. 

3. Consider what could help make the chart easier to understand. 

4. Be prepared to share your thoughts with the class. 

Try-it: Create dual-axis charts 
 In this leveled try-it, you’ll change a chart to a combo chart and add a secondary 

axis. 

Try-it 1 
Change an existing chart to a combo chart with a secondary axis. 

Resources 
You’ll need the following resources for this try-it: 

• Open L4_T1_try1_average_price_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you must perform during this try-it: 

1. Display the Fresh sweetcorn category as a Line with Markers chart against a 
secondary axis. 

2. Save the file as the same filename plus your initials. 

Try-it 2 
Add a data series to an existing chart and change it to a combo chart, with one series 
plotted on a secondary axis. 
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Resources 
You’ll need the following resources for this try-it: 

• Open L4_T1_try2_average_price_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you must perform during this try-it: 

1. Add Fresh sweetcorn to the existing chart. 

2. Display the Canned and Frozen sweet corn categories as a Line with Markers chart 
type. 

3. Display the Fresh sweetcorn category as an Area chart against a secondary axis. 

4. Save the file as the same filename plus your initials. 

Topic 2: Create and modify charts 
 Have you observed how many types of charts are available in Excel 2019? There are 

loads of chart types that you can try out. Maybe on a rainy day, you can practice 
creating and modifying them! In the meantime, why not review the video on Data 
visualization that demonstrates how data can come to life when you create various kinds 
of charts? Of course, maybe you’ve reviewed it already! 

Create a chart 
If you took the Excel associate course, you probably created many different types of 
charts, such as column, line, pie, or bar charts. In this topic, you’ll create some of the 
newer, more specialized charts, such as a box-and-whisker, combo, funnel, histogram, 
map, sunburst, and waterfall chart. 

To create a chart, perform the following steps: 

1. Select the data that you want to include in the chart. 

2. On the Insert tab, in the Charts group, select the category of chart that you would 
like to create. 

 
Figure 20: The Charts group on Insert tab 

https://aka.ms/video-data-visualization
https://aka.ms/video-data-visualization
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3. Select the chart from the gallery. 

4. A chart will immediately load into the current worksheet. 

Funnel chart 
You typically use a funnel chart for values across phases in a process. However, you can 
use it for any single series of data. This type of chart is more effective to sort the values 
in descending or ascending order. That way, the chart will resemble a funnel. The 
following screenshot indicates that the Development phase will cost the most and that 
the Testing phase will cost the least. 

 
Figure 21: A funnel chart 

 

Additional information 

For more information on Funnel charts, go to: Create a funnel chart 

Treemap chart 
A treemap chart is useful when you have a lot of data that is organized hierarchically 
within a few categories. It displays proportions within hierarchal levels in squares or 
rectangles. In the following screenshot, the chart indicates that vegetables have the 
biggest proportion of sales, with summer and autumn sales nearly equal. Nuts comprise 
the smallest proportion of sales, particularly in winter. There are no variations on a 
treemap chart. 

https://aka.ms/Create-a-funnel-chart
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Figure 22: A treemap chart 

Waterfall chart 
You typically use a waterfall chart to help understand the breakdown of a running total; 
for example, cash coming in and cash going out. Positive values usually display in blue 
and negative values display in red or orange. This might vary if you are using a theme 
other than the Office theme in your workbook. You can change the colors by using the 
Change Colors command on the Design tab. You could also, as with all other charts, 
select an individual value or the whole series and change the color on the Format tab. 

The following screenshot indicates that from a starting point of zero, the final amount is 
approximately 400. Money going out displays downward and money coming in displays 
upward. 

 
Figure 23: A waterfall chart 
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Sunburst chart 
A sunburst chart is a hierarchical chart like a treemap chart, except that the data displays 
in rings. A ring displays each level, with the innermost ring being the top level. The outer 
rings or segments are the breakdown of the inner ring. The following screenshot 
indicates the seasonal sales by category, with vegetables comprising the largest 
segment of the innermost ring. 

 
Figure 24: A sunburst chart 

Pareto chart 
The Pareto chart belongs to the histogram category of charts. Pareto charts are ideal for 
representing frequencies within a list of values. Imagine a list of temperatures across all 
U.S. states for the month of January. A histogram chart can depict how many times 
temperatures fall within set ranges. For example, it can depict the number of 
occurrences between 0°C and 5°C, or between 22°F and 34°F. 

Columns are called bins and the line in a Pareto chart represents the aggregate total 
percentage. You can edit the number of bins to display, and set the width (range) of the 
bins, the overflow value, and the underflow value. Values between the overflow or 
underflow range will not display. 
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The image indicates that donations within the range 17 to 32 are the most frequent 
amounts and donations within the range 77 to 92 are the least frequent. 

 
Figure 25: A Pareto chart 

 

Additional information 

For more information on Pareto charts, go to: Create a Pareto chart 

Box-and-whisker chart 
You can use a box-and-whisker chart to display variations with a set of data that is 
arranged from lowest to highest. You can use the box-and-whisker chart with multiple 
sets of related data. In this chart type, the whiskers are the lines that stick out of the 
boxes. These lines depict the variability outside the upper and lower quartiles. An outlier 
is any point that is outside the whisker. 

The following screenshot indicates the time that visitors spent at the farm in one day. 
The mean (average) in each hour block is marked with a line inside each block, and there 
are three outliers that are outside the upper and lower quartiles. 

https://aka.ms/create-a-pareto-chart
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Figure 26: A box-and-whisker chart 

 

Additional information 

For more information on box-and-whisker charts, go to: Create a box 
and whisker chart 

Map 
If your data contains values with geographical labels, a map chart is ideal. You’ll need to 
accept that your data will be shared with Bing, and you’ll need internet access. You 
format the map to display only regions with data, by country/region, by multiple 
countries/regions, and even by the entire world. The following screenshot indicates the 
number of bee colonies in the United States, with California having the most colonies, 
followed by Texas and Florida. 

https://aka.ms/Create-a-box-and-whisker-chart
https://aka.ms/Create-a-box-and-whisker-chart
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Figure 27: A map chart 

Which chart to choose? 
In most cases, this decision is objective and is totally up to you. However, to get your 
message across, you might sometimes need to give your chart selection a little more 
consideration. When deciding which chart to use, ask yourself two questions: 

• Which chart would be the best type to represent my data? 
• Is the data prepared well enough to effectively use the chart that I want to choose? 

 

Additional information 

For more information on the types of charts available in Office 2019, 
go to: Available chart types in Office 

Modify a chart 
When you’ve created a chart, you can use the Chart Tools contextual tabs (Design and 
Format) to make any alterations that you need. On the Chart Tools contextual Design 
tab, you can: 

• Select Add Chart Element in the Chart Layouts group to add or remove chart 
elements, such as labels, gridlines, and chart and axis titles. The following screenshot 
depicts this option. 

https://aka.ms/available-chart-types-in-office
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Figure 28: The Add Chart Element button 

• Apply quick layout styles for quick formatting by using Quick Layout in the Chart 
Layouts group. 

• Select Change Colors in the Chart Styles group to apply a colorful or 
monochromatic color scheme. 

• Select any of the options in the Chart Styles group to apply different styles. 
• Reselect the data used to create the chart by using Select Data in the Data group. 

You can also simply drag the current area inward or outward to redefine the area 
used in the current chart. 

• Select Change Chart Type in the Type group to apply a different chart type to an 
existing chart. 

• Move the chart to a different location in the same workbook by using Move Chart in 
the Location group. 

Depending on the chart type, you might also be able to: 

• Transpose the chart by selecting Switch Row/Column in the Data group. 
• Remove a series from the chart. 
• Add a series to the chart. 
• Add a trendline by using Add Chart Element in the Chart Layouts group. 

The following screenshot depicts the Design tab within the Chart Tools contextual tab, 
which appears when you select a chart. 

 
Figure 29: The Chart Design tab 
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Depending upon the type of chart that you have created and what elements you’ve 
selected within the chart, you can use the Chart Tools contextual Format tab to: 

• Apply styles to whatever you have selected within the chart. 
• Format elements within the chart by using the options in the Shape Styles group. 
• Apply formatting if you select text in the chart and use an option in the WordArt 

Styles group. You can also do this by using options in the Font group on the Home 
tab. 

• Add a description for the chart by using Alt Text in the Accessibility group. 
• Resize the chart to an exact width and height by using the options in the Size group. 
• Open the Selection Pane in the Arrange group. This is very helpful when you have a 

lot of data or objects on screen. 
• Select any of the dialog-box launchers on the groups on the Format tab. This will 

open the format pane for detailed editing options that are not available on the 
ribbon. 

 
Figure 30: Format tab 

Alternatively, you can perform the following steps: 

1. Select the chart and then select the Chart Elements plus button (+) on the side of 
the chart to add or remove chart elements. 

2. Select the arrow on the side of each element listed for further options. 

3. As an example, like the following screenshot depicts, you can open the Format Data 
Labels pane by selecting the arrow next to Data Labels, and then selecting More 
Data Label Options. 

 
Figure 31: Chart Elements 
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You could also select the chart and then select Chart Styles (paintbrush) on the side of 
the chart to apply a different style to the chart or color scheme. 

 
Figure 32: Chart Styles  

You can also: 

1. Double-click any element within the chart to open the format pane. You can also 
right-click or activate the context menu for the element, and then select the 
formatting option. For example, if you have selected the Chart Title, you’ll open the 
Format Chart Title pane. 

 
Figure 33: The Format Chart Title pane 

2. Select any of the tabs on the format pane to switch between options. 
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3. Select the drop-down list at the top of the format pane to select a different chart 
area. For example, you can switch from Chart Title to Plot Area. These options are 
also available on the Chart Elements drop-down list in the Current Selection group 
on the Format tab. Both of these methods are very helpful if you’re having difficulty 
selecting specific elements within the chart. 

 
Figure 34: Title options on the Format Chart Title pane 

4. Select Close (the X in the corner of the pane) to close it. 

Another option is to right-click or activate the context menu for the chart element that 
you want to edit, and then select the option for formatting that particular element. 

As with many of the fantastic Excel features, the best way to learn about charts is to go 
ahead and create one—and don’t be afraid to experiment! Remember, depending upon 
the type of chart that you have used and the element you have selected within that 
chart, the modifications you can make will differ. 

 

Did you know? 

There are many types of color blindness. However, Microsoft has a 
Color filter tool that can help! Select Start, select Settings, and then 
search for color filters. Why don’t you give it a try? Using the tool 
might make your charts and other graphics easier to understand. 
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Video 

To review the video on adding a trendline to a chart, go to: Add a 
trend or moving average line to a chart 

Activity: Team research 
In this activity you’ll be given a chart type to research. Partner with anyone who has the 
same chart type as you have, and then work together to find out as much as possible 
about it. 

Resources required 
You’ll need the following resources for this activity: 

• Open L4_T2_act_charts.xlsx in this lesson’s Learning Activity Resources. 

Activity instructions 
Participate in the activity by following these instructions: 

1. Partner with anyone who has the same chart type as you have. 

2. Use any method available to research the chart type that you have been allocated. 

3. Use L4_T2_act_charts.xlsx if you want, for reference or to use any data that you 
have access to. 

4. Consider these questions while researching: 

a. What type of formatting can be applied? 

b. Are there any important things to prepare within the data before creating the 
chart? 

c. Is there anything unique or special about the chart? 

5. You’ll get a chance to create the chart that you have researched in the try-it. 

Try-it: Create and modify charts 
 In this standalone try-it activity, you’ll remain in the same group and work 

together to create and modify a chart. 

  

https://aka.ms/Add-a-trend-or-moving-average-line-to-a-chart
https://aka.ms/Add-a-trend-or-moving-average-line-to-a-chart
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Try-it 
Create and modify the chart that your team researched. If you perform this try-it by 
yourself, instead of with a team, make sure to compare your chart with everyone who 
has selected the same chart type as you have. 

Resources 
You’ll need the following resources for this try-it: 

• Open L4_T2_try_charts_starter.xlsx in this lesson’s Learning Activity Resources. 

Instructions 
The following are the general tasks that you must perform during this try-it: 

1. Select the worksheet labeled with the chart that you have been researching, then do 
one of the following as appropriate: 

a. Funnel: Create a funnel chart that displays all the data in an upside-down funnel. 
Change the gap width between each series to 5%. Apply Quick Layout 2. Enter 
the chart title Estimated Production Costs. 

b. Treemap: Create a treemap chart that displays all the data with Season as the 
top level. Display the value on each segment and the Category name. Apply 
Quick Layout 6. Enter the chart title Seasonal Sales. 

c. Sunburst: Create a sunburst chart that displays all the data with Season as the 
top level. Apply Quick Layout style 3. Move the legend to the bottom and enter 
the chart title Seasonal Sales. 

d. Waterfall: Create a waterfall chart for all the data. Apply Quick Layout 4 and 
remove connector lines. Set the series gap width to 60% and enter the chart 
title Cashflow. 

e. Pareto: Create a Pareto chart that displays the frequency of all the donations. 
Change the gap width between each series to 5%. Apply Quick Layout 2. Enter 
the chart title Frequency of donation amounts. 

f. Box-and-whisker: Create a box-and-whisker chart that displays the time and 
number of visitors. Set the Quartile Calculation as the Inclusive Median and 
remove the mean markers. Apply Quick Layout 4 and enter the chart title 
Number of visitors per hour. 

g. Map: Create a map chart for the percentage of bee colonies renovated in the 
United States. Apply Quick Layout style 2 and format the data series to display 
Map labels for all states. Enter the chart title % of Bee Colonies renovated in 
US. 
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2. Reposition/resize the chart to ensure that the chart doesn’t cover any data and that 
the chart is large enough to display all categories clearly. 

3. Add Alt Text describing the chart content. Note: Screen readers read alt-text or 
alternative text to help people with low vision understand the images and other 
objects in a document. 

4. Save the workbook as the same name plus the team name that the team chooses. 

5. Compare your chart with other teams if time permits. 

Wrap-up 
If time permits, create any other chart in the L4_T2_try_charts_starter.xlsx workbook. 
Then, use these questions to check what you learned in this lesson: 

1. To create a dual-axis chart, which chart type should you use? 

Select the correct option. 

a. Bar 

b. Column 

c. Combo 

d. Line 

2. What is the additional axis on a dual-axis chart also known as? 

Select the correct option. 

a. Vertical axis 

b. Horizontal axis 

c. Horizontal (category) axis 

d. Secondary vertical (value) axis 

3. Which of the following charts would be useful for displaying frequencies? 

Select all that apply. 

a. Pareto 

b. Sunburst 

c. Waterfall 

d. Histogram 
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4. In a box-and-whisker chart, any point outside of the whisker is known as an 
________________________. 

Fill in the blank space. 

Glossary 
Outlier A value outside the quartile range within a box-and-whisker chart. 

Quartile A calculation used in a box-and-whisker chart. More detail is 
provided in Lesson 4, Topic 2, plus a link to Microsoft Office support. 

Stacked An option available within various chart types.  

Summary Report A report created automatically on a separate worksheet by using the 
Scenario Manager. 

Syntax The order of a formula. 

Table 5: Glossary terms and definitions  
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Cornerstone 
Overview 
In this Cornerstone, you’ll analyze data by using the PMT function, Goal Seek, Scenario 
Manager, and a nested IF with AND. Munson’s management team has been working 
on two workbooks, which you’ll analyze further to answer several questions. 

Objectives 
The following table outlines the Cornerstone objectives and their corresponding 
Microsoft Office Specialist (MOS) exam objectives. 

Perform a what-if 
analysis 

• 3.4.2: Perform a what-if analysis by using Goal Seek and 
Scenario Manager. 

Forecast data by 
using nested IF and 
AND 

• 3.4.3: Forecast data by using the AND(), IF(), and NPER() 
functions. 

Analyze financial 
data 

• 3.4.4: Calculate financial data by using the PMT() 
function. 

Modify a chart • 4.1.2: Create and modify charts including box-and-
whisker, combo, funnel, histogram, map, sunburst, and 
waterfall charts. 

Table 6: Cornerstone objectives 

Duration 
50 minutes 
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Instructions 
1. Complete the tasks for each file. 

2. When saving your file, add your name to the end of the filename, for example: 
Sweetcorn_Dwayne_Espino.xlsx. Follow your teacher’s directions for where to save 
your files. 

3. When you’re done with the Cornerstone, assess your completion and enter the 
points that you think you earned within the task lists. You can ask your teacher for 
help, if required. 

Tasks 
You’ll work with two files in this Cornerstone. The following are the tasks you must 
complete within each file. 

File 1: Cornerstone_sweetcorn_analysis_starter.xlsx 
Task: Edit a PMT function (2 points) 
1. Examine the PMT function on the Buy Land worksheet (cell B5). 

2. Edit the function so that it returns the correct result. (2 points) (Exam objective 3.4.4) 

Points scored: ________ / 2 

Task: Create a nested IF AND function (4 points) 
• In cell B19 on the Rent Land worksheet, create a nested function that will calculate if 

E9 minus C9 is greater than B4 on the Rent Land, and if E12 minus C12 is greater 
than B7 on the Buy Land worksheet, return the value No, otherwise return the value 
Yes. (4 points) (Exam objective 3.4.3) 

Points scored: ________ / 4 

Task: Perform a goal seek (2 points) 
• On the Buy Land worksheet, use Goal Seek to calculate how much the retail price 

for sweet corn should increase if the forecast profit (E16) is raised to 24000. (2 
points) (Exam objective 3.4.2) 

Points scored: ________ / 2 
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Task: Modify the chart (4 points) 
1. On the Forecast Chart worksheet, edit the data source to display the Forecast Buy 

Land data instead of the Forecast Rent Land data. (2 points) (Exam objective 4.1.2) 

2. Sort the table so that the chart resembles a funnel. (1 point) (Exam objective 4.1.2) 

3. Apply the Monochromatic Palette 3 color scheme to the chart. (1 point) (Exam 
objective 4.1.2) 

Points scored: ________ / 4 

FILE 1 TOTAL POINTS: ______ /12 

File 2: 
Cornerstone_sweetcorn_scenarios_starter.xlsx 
Task: Create three scenarios (7 points) 
1. Create a scenario named 4% - 4 years as follows: 

a. Change B2 to 4% 

b. Change B3 to 4 years 

c. Change B4 to $4000 (2 points) (Exam objective 3.4.2) 

2. Create a scenario named 4.5% - 5 years as follows: 

a. Change B2 to 4.5% 

b. Change B3 to 5 years 

c. Change B4 to $5000 (2 points) (Exam objective 3.4.2) 

3. Create a scenario named 5% - 4 years as follows: 

a. Change B2 to 5% 

b. Change B3 to 4 years 

c. Change B4 to $4500 (2 points) (Exam objective 3.4.2) 

4. Show the 5% - 4 years scenario and close the Scenario Manager dialog box. (1 
point) 

Points scored: ________ / 7 
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Task: Create a summary report (3 points) 
1. Create a summary report based on the cells B5 and B6. (2 points) (Exam objective 

3.4.2) 

2. Rename the new worksheet Loan Scenarios. (1 points) 

Points scored: ________ / 3 

FILE 2 TOTAL POINTS: ________ / 10 
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Module overview 
Description 
As you use Microsoft Excel 2019, you’re likely to find that you do certain tasks over and 
over again. Perhaps your boss asks you to create a report on a regular basis, and you 
always set up the same row and column headings. Maybe your company wants you to 
include the same information at the beginning of every spreadsheet, such as the logo 
and contact information. Macros help automate these repetitive tasks so that you can 
create and manage your workbooks more efficiently. 

In this module, you’ll learn how macros work and how you can record your own macros. 
You’ll run, copy, and edit macros so that you can use them wherever and whenever you 
need them. 

The following table outlines the lessons in this module and their corresponding learning 
and exam objectives. 

Lesson Learning objective Exam objective(s) 

Understanding 
macros 

Display the Developer tab in the ribbon and 
enable macros in a workbook. 

• 1.1.3 

Recording and 
running 
macros 

Record and run a simple macro. • 3.6.1 

Using the 
Visual Basic 
Editor 

View Visual Basic for Applications (VBA) 
macros and reuse existing macros by 
copying VBA code from one workbook to 
another. 

• 1.1.1 

Editing macros Name and edit an existing macro. • 3.6.2 
• 3.6.3 

Understanding 
relative 
macros 

Create and run a relative macro. None 
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Lesson Learning objective Exam objective(s) 

Cornerstone: 
Using macros 

Automate report formatting by copying, 
editing, and recording macros. 

• 1.1.1 
• 1.1.3 
• 3.6.1 
• 3.6.2 
• 3.6.3 

Table 1: Objectives by lesson 

Scenario 
Based on your experience at Munson's Pickles and Preserves Farm, you think that 
creating some simple macros will help team members with less confidence in Excel 
easily carry out repetitive tasks—like applying Munson’s branding to cells and setting 
workbooks for printing. For example, one repetitive task at the farm is importing reports 
to Excel and setting up those reports for printing. You’ll use your knowledge of macros 
to help with this task. 

Cornerstone 
This module concludes with a Cornerstone in which you’ll use macros to automate some 
repetitive reporting tasks at Munson's. In the Cornerstone, you'll: 

• Enable and run a macro. 
• Copy and edit a macro with Visual Basic Editor. 
• Record a macro. 
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Lesson 1: Understanding macros 
Overview 
In this lesson, you’ll learn how to add the Developer tab to the ribbon and use it to 
access tools for creating, editing, and running macros. You'll learn the role that macros 
play in Microsoft Excel, and how you can enable them when you open a workbook. The 
activities, discussions, and demonstrations in this lesson will enhance your learning and 
give you the opportunity to practice and articulate what you learn about using macros. 

Warm-up 
Use these questions to find out what you already know about this lesson’s topics: 

1. Which tab includes commands related to macros? 

Select the correct option. 

a. Home 

b. Insert 

c. Formulas 

d. Data 

e. Developer 

2. Which of the following do you use to automate repetitive tasks? 

Select the correct option. 

a. Filters 

b. Formulas 

c. Macros 

d. PivotTables 

3. To save a workbook with macros, you must select ________________________ as the file 
type. 

Fill in the blank space. 
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Topic 1: Display the Developer tab 
As you explore macros in this module, you’ll need the commands on the Developer tab. 
The Developer tab includes features that are often unnecessary for day-to-day Excel 
use, so it’s hidden by default. You must enable it if you want to create, edit, and run 
macros. 

Select the File tab, and then, in the Backstage view, select Options to open Excel 
Options. In Excel Options, select Customize Ribbon. The following screenshot depicts 
Excel Options with Customize Ribbon highlighted: 

 
Figure 1: Excel Options with Customize Ribbon highlighted 
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In the Customize the Ribbon pane, in the Main Tabs section, select the Developer 
check box, and then select OK to close Excel Options. The following screenshot depicts 
the Customize the Ribbon pane in Excel Options with the Developer check box 
highlighted. 

 
Figure 2: Excel Options with Customize Ribbon selected and the Developer check box 
highlighted 
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The Developer tab will remain available until you clear the Developer check box in 
Excel Options to disable it. Note that you might have to enable it again if you open 
Excel on a different device. The following screenshot depicts the Developer tab. 

 
Figure 3: The Developer tab 

 

Additional information 

For more information on the Developer tab, go to: Show the 
Developer tab 

Activity: Setting the scene 
In this activity, your teacher will lead a discussion about macros. Then, the teacher will 
demonstrate how to add the Developer tab to the ribbon. 

Resources required 
You’ll need the following resources for this activity: 

• None 

Activity instructions 
Participate in the class discussion and then follow along as the teacher demonstrates 
adding the Developer tab to the ribbon. Ask any clarifying questions that you might 
have. 

Try-it: Display the Developer tab 
 In this leveled try-it activity, you’ll practice customizing the ribbon to display the 

Developer tab. 

Try-it 1 
In this try-it activity, you’ll enable the Developer tab on the ribbon. 

https://aka.ms/Show-the-Developer-tab
https://aka.ms/Show-the-Developer-tab
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Resources 
You’ll need the following resources for this try-it: 

• None 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Open Excel with a blank workbook. 

2. Select the File tab to open the Backstage view and access Excel Options. 

3. Select Customize Ribbon, select the check box for the Developer tab, and then 
close Excel Options. 

4. Select the Developer tab to confirm that it’s enabled. 

5. If time allows, practice repeating the steps to remove the Developer tab and then 
add it again. 

Try-it 2 
In this try-it activity, you’ll enable the Developer tab on the ribbon and learn about 
some of the commands that it includes. 

Resources 
You’ll need the following resources for this try-it: 

• None 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Open a blank workbook in Excel. 

2. Select the File tab to open the Backstage view and access Excel Options. 

3. Select Customize Ribbon, select the check box for the Developer tab, and then 
close Excel Options. 

4. Select the Developer tab to confirm that it’s enabled. 

5. Explore the Developer tab, hovering over different commands to reveal the 
ScreenTip. Focus on commands in the Code group. 

6. As time allows, visit Office Help and Training and research commands that you'd like 
to know more about. 

https://aka.ms/Office_Help_and_Training
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Topic 2: Get an introduction to macros 
When you use Excel regularly, you might find that you do some tasks . For example, for 
school assignments, you might have to enter your name, the teacher's name, and the 
date at the beginning of every new worksheet. Or your boss at work might want you to 
add the same header and footer on each worksheet, so that they’re easy to identify 
when you print them. 

You can use macros to automate these kinds of repetitive tasks by grouping a series of 
actions together into a single command. You can create a macro with all the necessary 
steps to complete the repetitive task, and then replay the macro any time that you need 
it. 

A macro consists of Visual Basic for Applications (VBA) code, which is a programming 
language available in most Microsoft Office applications. The code conducts the steps 
that you wish to repeat, and you can review or modify it by using the Visual Basic Editor. 

 

Did you know? 

You don't need to know VBA to create macros, thanks to the macro 
recorder. This tool records the steps that you take to perform an 
action and creates the VBA code to repeat your steps. 

The following is an example of VBA code for a macro that puts basic information at the 
beginning of a worksheet: 

Range("A1").Select 

ActiveCell.FormulaR1C1 = "Munson's Pickles and Preserves Farm" 

Range("A2").Select 

ActiveCell.FormulaR1C1 = 
"http://www.munsonspicklesandpreservesfarm.com" 

Range("A3").Select 

ActiveCell.FormulaR1C1 = "=TODAY()" 
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In this example, the user selected A1 and entered the text Munson's Pickles and 
Preserves Farm, and then selected A2 and entered 
http://www.munsonspicklesandpreservesfarm.com. Finally, they selected A3 and 
entered a formula to display the current date. The macro recorder created the VBA code 
based on those actions. 

 

Did you know? 

When it's recording, the macro recorder captures almost everything 
that you do. It even captures your mistakes! If you add a misspelled 
word to a cell and then delete it and add it back correctly, those 
incorrect steps and corrections become part of the macro. If you want 
to remove them, you'll have to record the sequence again or change 
the VBA code. 

A macro is part of the workbook, so Excel uses a different file type to save workbooks 
that have macros. An Excel Macro-Enabled Workbook has the .xlsm file extension. If 
you attempt to save a workbook containing macros as an Excel Workbook with the .xlsx 
file extension, you’ll receive a warning that the macro will be lost. 

 

Additional information 

For more information on macros, go to: Automate tasks with the 
Macro Recorder 

Activity: Discuss and learn 
In this activity, the teacher will lead a class discussion about basic macro concepts. 

Resources required 
You’ll need the following resources for this activity: 

• None 

Activity instructions 
Participate in the group discussion and ask clarifying questions about any topics that 
you don’t fully understand. 

Try-it: Get an introduction to macros 
 In this leveled try-it, you’ll summarize what you know about macros. 

https://aka.ms/automate-tasks-with-the-macro-recorder
https://aka.ms/automate-tasks-with-the-macro-recorder
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Try-it 1 
In this try-it activity, you’ll summarize basic macro concepts. 

Resources 
You’ll need the following resources for this try-it: 

• None 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Create a paragraph responding to the following prompts: 

o What is the purpose of a macro? 
o What are some tasks that using macros can help you with? 
o What programming language and tools do you use to create and edit macros? 

2. If time allows, do some research by going to Office Help and Training to review 
concepts that you aren't sure about. Add what you learn to your response. 

Try-it 2 
In this try-it activity, you’ll summarize basic macro concepts, including key terminology. 

Resources 
You’ll need the following resources for this try-it: 

• None 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Create a paragraph responding to the following prompts: 

o What is the purpose of a macro? 
o What are some tasks that using macros can help you with? 
o Explain what macro recorder does. 
o Explain the role of the Visual Basic Editor in creating and editing macros. 

2. If time allows, do some research by going to Office Help and Training to review 
concepts you aren't sure about. Add what you learn to your response. 

  

https://aka.ms/Office_Help_and_Training
https://aka.ms/Office_Help_and_Training
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Topic 3: Enable macros in a workbook 
 Some macros can pose significant security risks, such as making your computer or 

network vulnerable to a virus or other malicious attacks. Therefore, Excel takes 
precautions when you open a file that includes a macro. By default, macros will be 
disabled when you open a macro-enabled workbook. To run a macro, you'll need to 
enable it. 

Always think carefully before enabling macros in a file from a source you don’t know or 
can't verify—malicious hackers can distribute workbooks with macros in hope that 
someone will enable their commands. If you don't enable macros, it’s safe to open a 
workbook and examine—or even edit—its contents. 

If you trust the source of the macro-enabled workbook, or if you created the workbook, 
you can enable macros and take advantage of the automation that they provide. 

When you open a workbook with one or more macros, the SECURITY WARNING 
message bar displays with the Enable Content option. Select Enable Content to enable 
macros. The following screenshot depicts the SECURITY WARNING message bar with 
Enable Content highlighted. 

 
Figure 4: The SECURITY WARNING message bar with Enable Content highlighted 
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You can also enable macros from the Backstage view. Select the File tab, and then, in 
the Backstage view, select Info. Select the Enable Content drop-down box, and then 
select Enable All Content. The following screenshot depicts the Backstage view with 
the Enable Content drop-down box open and with Enable All Content highlighted. 

 
Figure 5: The Backstage view with the Enable Content drop-down box open and Enable 
All Content highlighted 

 

Additional information 

For more information on enabling macros, go to: Edit a macro 

Activity: Pose a question 
In this activity, the teacher will ask questions about macro security to engage the class in 
a discussion. Then the teacher will demonstrate how to enable macros when opening a 
macro-enabled workbook. 

Resources required 
You’ll need the following resources for this activity: 

• None 

https://aka.ms/edit-a-macro
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Activity instructions 
Participate in the group discussion and ask clarifying questions about any topics that 
you don’t fully understand. 

Try-it: Enable macros in a workbook 
 In this standalone try-it activity, you’ll open a workbook and enable macros. 

Resources 
You’ll need the following resources for this try-it: 

• Open L1_T3_try_munsons_starter.xlsm in this lesson’s Learning Activity Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

• Open L1_T3_try_munsons_starter.xlsm and enable macros. 

Wrap up 
Use these questions to check what you learned in this lesson:  

1. Which of the following converts actions that you perform into VBA code? 

Select the correct option. 

a. Developer tab 

b. Macro recorder 

c. Visual Basic Editor 

d. Visual Basic for Applications 

2. Where can you enable macros when you open a macro-enabled workbook? 

Select all that apply. 

a. A command in the Backstage view 

b. On the Home tab 

c.  On the message bar 

d.  On the Review tab 

3. To work with macros, you should first enable the ________________________ tab. 

Fill in the blank space. 
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Lesson 2: Recording and 
running macros 
Overview 
In this lesson, you’ll learn how to record and run a simple macro. The activities, 
discussions, and demonstrations in this lesson will give you the opportunity to practice 
creating and running simple macros. 

Warm-up 
Use these questions to find out what you already know about this lesson’s topics: 

1. Where can you find the Record Macro command? 

Select the correct option. 

a. On the Data tab 

b. On the Developer tab 

c. On the Formulas tab 

d. On the Home tab 

2. By default, where are macros saved? 

Select the correct option. 

a. In the current workbook 

b. In a Personal Macro Workbook 

c. In a separate text file 

3. On the Developer tab, select ________________________ to begin recording a macro. 

Fill in the blank space. 
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Topic 1: Record simple macros 
 You can create macros by writing VBA code, but the macro recorder makes it 

quicker and easier to create a simple macro, even if you don’t know VBA. 

Before recording a macro, you should carefully plan each step that you’ll take to 
perform the tasks that you wish to automate. The macro recorder will capture almost 
everything you do, including mistakes, and create corresponding VBA code. It’s a good 
idea to practice the steps prior to recording the macro. 

To record a macro, select the Developer tab in the ribbon, and then, in the Code group, 
select Record Macro. The following screenshot depicts the Code group with Record 
Macro highlighted: 

 
Figure 6: The Code group with Record Macro highlighted 

This activates the Record Macro dialog box. In the Macro name box, enter a name for 
your macro. You might have more than one macro in a workbook; so, make sure that 
your macro names are descriptive. Macro names are often verbs that describe what the 
macro does, such as SetupPage or FormatReport. The first character of the name must 
be a letter, but subsequent characters can be numbers or underscore characters. 

If you want to assign a keyboard shortcut to your new macro, select the Shortcut key 
box and enter any letter. It's a good idea to use Ctrl+Shift key combinations so that you 
don't overwrite any default Excel keyboard shortcuts. For example, if you use Ctrl+Z you 
won't be able to use that combination to Undo in Excel while that workbook is active, 
but Ctrl+Shift+Z does not overwrite Undo. Therefore, it's usually a good idea to 
include Shift in your shortcut combination to avoid conflicts. 

In the Store macro in drop-down box, you can select a location for the macro that 
you’re recording. Usually, you'll select This Workbook and keep the macro in the 
workbook that you're currently editing. However, you can also choose to store it in your 
Personal Macro Workbook, which will be created if it doesn’t already exist. Finally, you 
can select New Workbook to create a new blank workbook for the new macro. 

In the Description box, you can describe the macro’s function, which is especially 
helpful in a workbook with more than one macro. It's a good idea to write a brief 
sentence explaining what the macro does. 
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The following screenshot depicts the Record Macro dialog box. 

 
Figure 7: The Record Macro dialog box 

 

Did you know? 

The keyboard shortcut to access the Record Macro dialog box is 
Alt+T+M+R. 

After you've entered the information that you want in the Record Macro dialog box, 
select OK to begin recording. Perform the actions that you want to record. When you’re 
ready to stop, select the Developer tab, and then, in the Code group, select Stop 
Recording. The following screenshot depicts the Code group with Stop recording 
highlighted. 

 
Figure 8: The Code group with Stop Recording highlighted 
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Remember that each action that you perform before selecting Stop Recording will be 
included in the macro, so it’s a good idea to plan your steps carefully and rehearse them 
prior to recording. 

 

Did you know? 

If you’re planning to record a long process as a macro, consider 
breaking it up and recording smaller macros. Then, record one macro 
that runs each of the other macros in the correct sequence. 

 

Additional information 

For more information on recording a macro, go to: Quick start: Create 
a macro 

 

Video 

To review the video on recording a macro, go to: Work with macros 

Activity: Student-and-teacher collaboration 
In this activity, the class will collaborate with the teacher to create a simple macro that 
formats a cell. 

Resources required 
You’ll need the following resources for this activity: 

• None 

Activity instructions 
Participate in the activity by collaborating with the teacher and other students to create 
a macro. 

Try-it: Record simple macros 
 In this leveled try-it activity, you’ll record a macro to apply formatting to a cell. 

https://aka.ms/Quick-start-Create-a-macro
https://aka.ms/Quick-start-Create-a-macro
https://aka.ms/video-work-with-macros
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Try-it 1 
In this try-it activity, you’ll record a simple macro to format numbers. 

Resources 
You’ll need the following resources for this try-it: 

• None 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Create and save a new macro-enabled workbook named 
L2_T1_try1_number_style.xlsm. 

2. Add random numbers with at least three decimal digits to cells A1:A3. 

3. Select one of the numbers that you entered and record a macro named 
ApplyFancyFormat. In the macro, apply the following formatting to the cell: 

o Number displayed to one decimal place 
o Italics 
o Font color Blue 

4. Stop recording and save your workbook. 

Try-it 2 
In this try-it activity, you’ll record a simple macro to format dates, including a keyboard 
shortcut and description. 

Resources 
You’ll need the following resources for this try-it: 

• None 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Create and save a new macro-enabled workbook named 
L2_T1_try2_date_style.xlsm. 

2. Add random date to cells A1:A3. You might wish to use your birthday or other 
significant dates. 
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3. Select one of the dates that you entered and record a macro named 
ApplyFancyFormat by using the following steps: 

a. Configure the macro to use the keyboard shortcut combination Ctrl+Shift+D. 

b. Enter the following text for the description: Applies a fancy date format to the 
active cell. 

c. In the macro, apply the following formatting to the cell: 

 Date is displayed in the format 2012-03-14. 

 Italics 

 Font color is Blue 

4. Stop recording and save your workbook. 

Topic 2: Run simple macros 
After you’ve recorded a macro, you can run it any time that you want to repeat the 
recorded steps. It's like recording a song and playing it whenever you want. 

If you set up a combination shortcut key for the macro, simply select that keyboard 
combination and the macro will run. Regardless of whether the macro has a 
combination keyboard shortcut, you can run it from the ribbon. Select the Developer 
tab, and then, in the Code group, select Macros to open the Macro dialog box. The 
following screenshot depicts the Code group with Macros highlighted. 

 
Figure 9: The Code group with Macros highlighted 
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In the Macro dialog box, select the macro that you want to run in Macro name, and 
then select Run. The following screenshot depicts the Macro dialog box with the 
AddReportHeading macro selected and Run highlighted. 

 
Figure 10: The Macro dialog box with the AddReportHeading macro selected and Run 
highlighted 

Add a macro to the Quick Access Toolbar 
To make it even easier to run a macro, you can add it to the Quick Access Toolbar. 
Select File, and then, in the Backstage view, select Options to open Excel Options. 
Select Quick Access Toolbar, and then use the Choose commands from drop-down 
list to select Macros. The following screenshot depicts Excel Options with Quick Access 
Toolbar and the Macros option highlighted: 
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Figure 11: Excel Options with Quick Access Toolbar and the Macros option highlighted 

Then, select the macro you want to add to the Quick Access Toolbar and select Add. 
Select OK to close Excel Options. The following screenshot depicts Excel Options with 
the AddWorksheetInfo macro added to the Quick Access Toolbar and the Add 
command highlighted. 



Using simple macros 
 

 
25 

 
Figure 12: Excel Options with the AddWorksheetInfo macro added to the Quick Access 
Toolbar and the Add command highlighted 

To run the macro, select the macro in the Quick Access Toolbar. The following 
screenshot depicts the Quick Access Toolbar with the macro icon highlighted: 

 
Figure 13: The Quick Access Toolbar with the macro icon highlighted 

 

Additional information 

For more information on running macros, go to: Run a macro 

https://aka.ms/run-a-macro
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Additional information 

For more information on adding macro to the Quick Access Toolbar, 
go to: Assign a button to a macro 

 

Video 

To review the video on adding a macro to the Quick Access Toolbar, 
go to: Assign a button to a macro 

Activity: Guess and learn 
In this activity, the teacher will lead a group discussion about different ways to run 
macros. Then, the teacher will demonstrate several different options for running a 
macro. 

Resources required 
You’ll need the following resources for this activity: 

• None 

Activity instructions 
Participate in the activity by following these instructions: 

1. Participate in the teacher-led group discussion. 

2. Follow along as the teacher demonstrates how to run macros. 

3. Ask any clarifying questions that you might have. 

Try-it: Run simple macros 
 In this leveled try-it, you’ll run macros by using the ribbon or a keyboard shortcut. 

Try-it 1 
In this try-it activity, you’ll use the ribbon to run the macro that you created in the 
previous try-it. 

  

https://aka.ms/assign-a-macro-to-a-button
https://aka.ms/video-assign-a-button-to-a-macro
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Resources 
You’ll need the following resources for this try-it: 

• Open L2_T1_try1_number_style.xlsm from the previous activity and save it as 
L2_T2_try1_number_style_starter.xlsm. Alternatively, open 
L2_T2_try1_number_style_starter.xlsm in this lesson’s Learning Activity Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Select one of the cells with a random number. 

2. Use the ribbon to run the ApplyFancyFormat macro. 

3. As time allows, repeat the process on other cells with random numbers. 

Try-it 2 
In this try-it activity, you’ll use a keyboard shortcut to run the macro that you created in 
the previous try-it. 

Resources 
You’ll need the following resources for this try-it: 

• Open L2_T1_try2_date_style.xlsm from the previous activity and save it as 
L2_T2_try2_date_style_starter.xlsm. Alternatively, open 
L2_T2_try2_date_style_starter.xlsm in this lesson’s Learning Activity Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Select one of the cells with a date. 

2. Run the ApplyFancyFormat macro by selecting Ctrl+Shift+D. 

3. As time allows, repeat the process on other cells with dates. 
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Wrap-up 
Use these questions to check what you learned in this lesson:  

1. Which of the following best describes what the macro recorder captures? 

Select the correct option. 

a. Almost all the actions that you perform 

b. Text input and cell formatting 

c. Actions you perform by using the ribbon 

2. Which of the following can you configure from the Record Macro dialog box? 

Select all that apply. 

a. Description 

b. Macro name 

c. Security settings 

d. Shortcut key 

3. Add a frequently used macro to the ________________________ to provide a convenient 
way to run it. 

Fill in the blank space. 

4. To make a macro available to any worksheet that you open from the same computer, 
save it to a ________________________. 

Fill in the blank space. 
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Lesson 3: Using the Visual Basic 
Editor 
Overview 
In this lesson, you’ll learn to review VBA code and reuse existing macros by copying 
macros from one workbook to another. The discussions, activities, and demonstrations 
will reinforce your learning and provide the opportunity to practice these skills. 

Warm-up 
Use these questions to find out what you already know about this lesson’s topics: 

1. Which command opens the code for a macro? 

Select the correct option. 

a. Macros 

b. Record Macro 

c. Visual Basic 

2. Macros consist of code in which programming language? 

Select the correct option. 

a. Basic 

b. C# 

c. Machine language 

d. Visual Basic for Applications 

Topic 1: Access the Visual Basic Editor 
Macros are saved as VBA code. This code is just text, and Office includes the Visual 
Basic Editor for viewing and editing VBA code. 

To open macros in the Visual Basic Editor, select the Developer tab on the ribbon. 
Then, in the Code group, select Visual Basic. The following screenshot depicts the Code 
group with Visual Basic highlighted. 
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Figure 14: The Code group with Visual Basic highlighted 

 

Did you know? 

The keyboard shortcut to open the Visual Basic Editor is Alt+F11. 

The Visual Basic Editor will open as a separate window displaying a text editor with the 
VBA code for all the macros in your workbook. The following screenshot depicts the 
Visual Basic Editor with the VBA code for a macro highlighted. 

 
Figure 15: The Visual Basic Editor with the VBA code for a macro highlighted 
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The line Sub AddReportHeading() indicates the start of the AddReportHeading 
macro, which is called a subroutine in coding. End Sub indicates the end of the macro. 
These two lines establish the borders for all the information about the macro. Additional 
macros in the workbook would be listed following End Sub. 

The first set of lines all start with an apostrophe and the editor shades them green. This 
indicates that those lines are informational and aren’t part of the steps that the macro 
will take. In fact, Excel just skips those lines when running the macro. You can think of 
them as a heading that displays the name of the macro and the text that you entered in 
the Description box before you started recording. You can add a similar note, called a 
comment by programmers, by entering an apostrophe and entering any text that you 
want. Comments are often useful in providing additional information to people who 
read the code later. 

The code itself displays in black text. Some of the lines might be easy to figure out, but 
others are not as obvious. For example, Range("A1").Select is the code that the macro 
recorder generated when the user selected cell A1. The line ActiveCell.FormulaR1C1 = 
"Munson's Pickles and Preserves Farm" is what the macro recorder generated when 
the user entered the name of the farm. Note that the creator then selected A2 and 
entered the farm's web address, and then selected A3 and entered a formula to display 
the current date. 

If you make any changes to VBA code in the Visual Basic Editor, you'll need to use 
Save to save the changes to the macro-enabled workbook. You can close the editor at 
any time and reopen it from Excel. 

Activity: Show and tell 
In this activity, the teacher will demonstrate how to open and use the Visual Basic 
Editor. You’ll examine the code for simple macros created with the macro recorder. 

Resources required 
You’ll need the following resources for this activity: 

• Open L3_T1_act_days_starter.xlsm in this lesson’s Learning Activity Resources. 

Activity instructions 
Participate in the activity by following along with the teacher’s demonstration. During 
the demonstration, ask questions about topics or tasks that are unclear to you. 
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Try-it: Access the Visual Basic Editor 
 In this leveled try-it, you’ll open the Visual Basic Editor and examine the VBA code 

for two macros. 

Try-it 1 
In this try-it, you’ll open the Visual Basic Editor from the ribbon. 

Resources 
You’ll need the following resources for this try-it: 

• Open L3_T1_try1_months_starter.xlsm in this lesson’s Learning Activity Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Use the Visual Basic command on the ribbon to open the Visual Basic Editor. 

2. If necessary, use the View menu to access Project Explorer. 

3. If necessary, expand Modules and double-click Module1, or select it, and then 
select Enter. 

4. After the line that reads ' MonthsV Macro, add the following comment: ' Lists the 
months vertically starting in the active cell. 

5. Close the Visual Basic Editor. 

Try-it 2 
In this try-it, you’ll open the Visual Basic Editor with the keyboard shortcut and elements 
of the Project Explorer and the VBA code for two macros. 

Resources 
You’ll need the following resources for this try-it: 

• Open L3_T1_try2_months_starter.xlsm in this lesson’s Learning Activity Resources. 

Instructions 
The following are the general tasks that you must perform during this try-it: 

1. Use the Visual Basic command on the ribbon to open the Visual Basic Editor. 

2. If necessary, use the View menu to access Project Explorer. 
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3. If necessary, expand Modules and double-click Module1, or select it, and then 
select Enter. 

4. After the line that reads ' MonthsV Macro, add the following comment: ' Lists the 
months vertically starting in the active cell. 

5. Close the Visual Basic Editor. 

Topic 2: Copy macros between 
workbooks 

Unless you save a macro to a Personal Macro Workbook, it will only be attached to 
the workbook you were using when you recorded it. If you want the same automation in 
a different workbook, you can copy the macro, instead of recording it again. 

When macros are attached to a workbook, they are organized into modules. By default, 
Excel creates a module named Module1 when you record a macro, and each 
subsequent macro that you record is added to Module1. 

To find Module1 for your file, you'll need to open the Project Explorer in Visual Basic 
Editor. To do so: 

1. Select the Developer tab, and then, in the Code group, select Visual Basic. 

2. If the Project Explorer does not display, select the View tab, and then select Project 
Explorer. 

 

Did you know? 

The Project Explorer displays a variety of VBA elements for each 
workbook that you have open at the time, not just the workbook that 
you’re using. 
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The following screenshot depicts the Visual Basic Editor with Project Explorer 
highlighted. 

 
Figure 16: The Visual Basic Editor with Project Explorer highlighted 

The screenshot depicts Project Explorer with two workbooks open: Drone_data.xlsm 
and Report.xlsm. Drone_data.xlsm doesn’t have any modules because it doesn’t 
contain any macros yet. 

Copy and paste the VBA code for a macro 
To copy an individual macro from one workbook to another, you can Copy and Paste 
the VBA code in the Visual Basic Editor. Begin by opening the workbook that contains 
the macro module that you want to copy and the workbook that you want to copy it to. 
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Select the Developer tab, and then, in the Code group, select Visual Basic to open the 
Visual Basic Editor. If Project Explorer is not already available, select the View tab, and 
then select Project Explorer. 

In Project Explorer, select the module that you wish to copy, which is often Module1. 
This displays the VBA code for all macros in that module. Both the source and 
destination workbooks might have modules named Module1; so, you must make sure 
that you select the module within the source workbook. The following screenshot 
depicts the Visual Basic Editor with Module1 in Project Explorer highlighted: 

 
Figure 17: The Visual Basic Editor with Module1 in Project Explorer highlighted 
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Next, select the text for the entire macro that you wish to copy from the line that begins 
Sub to the line End Sub. Select the Edit menu, and then select Copy. The following 
screenshot depicts the Visual Basic Editor with a single macro selected in preparation for 
being copied. 

 
Figure 18: The Visual Basic Editor with a single macro selected in preparation for being 
copied 
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If the destination workbook doesn’t have a module, or if you wish to copy the macro to 
a new module, right-click or activate the context menu for the destination workbook. 
Select Insert, and then select Module. A new module will be added to the workbook. 
The following screenshot depicts the context menu for a workbook in Project Explorer, 
with Insert selected and Module highlighted. 

 
Figure 19: The context menu for a workbook in Project Explorer, with Insert selected and 
Module highlighted 

To open the code, double-click the module name or select the module name, and then 
select Enter. Position the cursor after the last line of code. If there are no existing 
macros, position the cursor on the first line. Select the Edit menu, and then select Paste. 

Copy a macro module 
You can copy a macro module, including all the macros in that module, to another 
workbook. To do so, begin by opening the workbook that contains the macro module 
and the workbook that you want to copy it to. 

Select the Developer tab, and then, in the Code group, select Visual Basic to open the 
Visual Basic Editor. If Project Explorer isn’t already available, select the View menu 
and then select Project Explorer. 
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In Project Explorer, select the module that you wish to copy, which is often Module1. 
Drag the module to the destination workbook. The following screenshot depicts Project 
Explorer with the module to copy highlighted and the destination workbook 
highlighted. 

 
Figure 20: Project Explorer with the module to copy highlighted and the destination 
workbook highlighted 

The macro module will be added to the destination workbook, and any macros that it 
contains will be usable in the destination workbook. 

 

Additional information 

For more information on copying macros, go to: Copy a macro 
module to another workbook 

Activity: Show and learn 
In this activity, the teacher will demonstrate how copy a macro module to a different 
workbook and how to copy a single macro by copying the VBA code. 

Resources required 
You’ll need the following resources for this activity: 

• Open L3_T2_act_module_starter.xlsm in this lesson’s Learning Activity Resources. 

https://aka.ms/copy-a-macro-module-to-another-workbook
https://aka.ms/copy-a-macro-module-to-another-workbook
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Activity instructions 
Participate in the activity following along with the teacher’s demonstration. During the 
demonstration, ask questions about topics or tasks that you’re unclear about. 

Try-it: Copy macros between workbooks 
 In this leveled try-it activity, you’ll copy one or more macros to a new workbook. 

Try-it 1 
In this try-it, you’ll copy an entire macro module to a new workbook. 

Resources 
You’ll need the following resources for this try-it: 

• Open L3_T2_try1_module_starter.xlsm in this lesson’s Learning Activity Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Ensure that the starter file is open. 

2. Create a new macro-enabled workbook named L3_T2_try1_module.xlsm. 

3. Copy Module1 from L3_T2_try1_module_starter.xlsm to L3_T2_try1_module.xlsm. 

4. Close L3_T2_try1_module_starter.xlsm. 

5. Run the two macros in L3_T2_try1_module.xlsm. 

Try-it 2 
In this try-it, you’ll copy the VBA code for one macro to a new workbook. 

Resources 
You’ll need the following resources for this try-it: 

• Open L3_T2_try2_copy_starter.xlsm in this lesson’s Learning Activity Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Ensure that the starter file is open. 

2. Create a new macro-enabled workbook named L3_T2_try2_copy.xlsm. 
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3. Copy the VBA code for the MonthsH macro from L3_T2_try1_copy_starter.xlsm to 
L3_T2_try2_copy.xlsm. 

4. Close L3_T2_try2_copy_starter.xlsm. 

5. Run the MonthsH macro in L3_T2_try2_copy.xlsm. 

Wrap-up 
Use these questions to check what you learned in this lesson:  

1. Which of the following is a container that organizes macros in a workbook? 

Select the correct option. 

a. Blocks 

b. Modules 

c. Subs 

d. Workbooks 

2. Which character indicates a comment in a macro? 

Select the correct option. 

a. Ampersand 

b. Apostrophe 

c. Comma 

d. Slash 

3. How can you copy a macro from one workbook to another? 

Select all that apply. 

a. Open the Macro dialog box. 

b. Copy and paste the VBA code. 

c. Drag and drop in the Visual Basic Editor. 

d. Use a command on the Developer tab. 

4. The last line of VBA code for a macro is ________________________. 

Fill in the blank space. 
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Lesson 4: Editing macros 
Overview 
In this lesson, you’ll learn to change the name of a macro and edit macro code. The 
activities, discussions, and demonstrations will give you the opportunity to apply and 
practice the concepts that you learn. 

Warm-up 
Use these questions to find out what you already know about this lesson’s topics: 

1. Where can you change the name of a macro?

Select the correct option.

a. From the context menu

b. From the Macro dialog box

c. In the Visual Studio Editor

d. In the Backstage view

2. How can you change or correct a macro after you’ve recorded it?

Select all that apply.

a. By recording it again

b. By editing the VBA code for the macro

c. By adding it to the Quick Access Toolbar

d. You cannot change a macro after it's been recorded.

3. A macro name must start with a ________________________.

Fill in the blank space.
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Topic 1: Name simple macros 
 After you’ve recorded a macro, you cannot change its name in Excel. However, you 

can change a macro name by editing the macro in the Visual Basic Editor. 

Select the Developer tab on the ribbon, and then, in the Code group, select Visual 
Basic to open the Visual Basic Editor. To open the VBA code in the editor, double-click 
the module containing the macro, which is usually Module1, or select it, and then select 
Enter. 

The name of the macro is part of the first line of that macro's VBA code, which begins 
with Sub and ends with parentheses. The following screenshot depicts the VBA code 
for a macro, with the name highlighted: 

 
Figure 21: The VBA code for a macro, with the name highlighted 

To change the name of the macro, select the name in the editor, being careful not to 
select the space before the name or the parentheses following the name. Then, enter 
the new name for the macro. The first character of the name must be a letter, but 
subsequent characters can be letters, numbers, or underscore characters. You should 
give the macro a name that describes the task or tasks that it will record. Avoid using 
the same name as another macro in the workbook. 
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After entering the new name, select Save. The following screenshot depicts the Visual 
Basic Editor, with Save highlighted. 

 
Figure 22: The Visual Basic Editor, with Save highlighted 

Activity: Show and tell 
In this activity, your teacher will discuss the importance of macro names and will 
demonstrate how to change the name of an existing macro. 

Resources required 
You’ll need the following resources for this activity: 

• Open L4_T1_act_days_starter.xlsm in this lesson’s Learning Activity Resources. 

Activity instructions 
Participate in the activity by following along with the teacher’s demonstration. During 
the demonstration, ask questions about topics or tasks that you’re not clear about. 

Try-it: Name simple macros 
 In this leveled try-it, you’ll access the Visual Basic Editor, which you’ll then use to 

change the names of macros. 

Try-it 1 
In this try-it, you’ll open the Visual Basic Editor from the ribbon or the Macro dialog 
box, and then you’ll change the name of a macro. 
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Resources 
You’ll need the following resources for this try-it: 

• Open L4_T1_try1_months_starter.xlsm in this lesson’s Learning Activity Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Use the ribbon to open the Visual Basic Editor. You can use the Visual Basic 
command or select Macros and, in the Macro dialog box, select Edit. 

2. Rename the MonthsH macro to FillMonthsHortizontal. 

3. Return to Excel and open the Macro dialog box to confirm your changes. 

Try-it 2 
In this try-it, you’ll open the Visual Basic Editor with the keyboard shortcut, and then 
you’ll change the name of a macro. 

Resources 
You’ll need the following resources for this try-it: 

• Open L4_T1_try2_months_starter.xlsm in this lesson’s Learning Activity Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Select Alt+F11 to open the Visual Basic Editor. 

2. Rename the MonthsH macro to FillMonthsHortizontal. 

3. Return to Excel and open the Macro dialog box to confirm your changes. 
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Topic 2: Edit simple macros 
 You can use the Visual Basic Editor to change any part of a macro's VBA code. 

Although making extensive changes or additions requires knowledge of the VBA 
programming language, you can add comments and make simple substitutions to the 
parts of the code that are easy to understand. 

Consider the following VBA code: 

Range("A1").Select 

ActiveCell.FomulaR1C1 = "The Farm" 

Range("A2").Select 

ActiveCell.FormulaR1C1 = "Weekly Report" 

Range("A2").Select 

With Selection.Font 

.Name = "Calibri" 

.Size = 14 

.Strikethrough = False 

.Superscript = False 

.Subscript = False 

.OutlineFont = False 

.Shadow = False 

.Underline = xlUnderlineStyleNone 

.ThemeColor = xlThemeColorLight1 

.TintAndShade = 0 

.ThemeFont = xlThemeFontMinor 

End With 

This macro selects A1 and enters the text The Farm, and then selects A2 and enters 
Weekly Report. After that, it selects A2 and sets the font to Calibri with the font size 
14. 
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However, the user made a couple of mistakes. Instead of The Farm, they intended to 
input Munson's Pickles and Preserves Farm. To fix this mistake, select The Farm in the 
second line code, being careful not to select the quotation marks themselves, and then 
enter the correct text. 

The user also intended to select A1 instead of A2 before setting the font properties. You 
can fix this by finding the second instance of the line Range("A2").Select, which is on 
the fifth line of code. Select A2, and then enter A1. 

The VBA code for the macro is now as follows: 

Range("A1").Select 

ActiveCell.FomulaR1C1 = "Munson's Pickles and Preserves Farm" 

Range("A2").Select 

ActiveCell.FormulaR1C1 = "Weekly Report" 

Range("A1").Select 

With Selection.Font 

.Name = "Calibri" 

.Size = 14 

.Strikethrough = False 

.Superscript = False 

.Subscript = False 

.OutlineFont = False 

.Shadow = False 

.Underline = xlUnderlineStyleNone 

.ThemeColor = xlThemeColorLight1 

.TintAndShade = 0 

.ThemeFont = xlThemeFontMinor 

End With 

You can also use an apostrophe to add a comment to the code explaining the most 
complicated part of the macro. To do so, position the cursor at the start of the line and 
select Enter to insert a new line. Position the cursor on that new line and enter the 
following text: 

' Change the font to Calibri size 14. 
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The final version of this macro is as follows: 

Range("A1").Select 

ActiveCell.FomulaR1C1 = "Munson's Pickles and Preserves Farm" 

Range("A2").Select 

ActiveCell.FormulaR1C1 = "Weekly Report" 

Range("A1").Select 

' Change the font to Calibri size 14. 

With Selection.Font 

.Name = "Calibri" 

.Size = 14 

.Strikethrough = False 

.Superscript = False 

.Subscript = False 

.OutlineFont = False 

.Shadow = False 

.Underline = xlUnderlineStyleNone 

.ThemeColor = xlThemeColorLight1 

.TintAndShade = 0 

.ThemeFont = xlThemeFontMinor 

End With 

You can also change colors by editing the macro. The following code sets the color of 
the text in A1 to red: 

Range("A1").Font.Color = -16776961 

The macro recorder uses an unusual value to represent red: -16776961. However, VBA 
has a system for using name colors. For example, vbRed represents red and vbYellow 
represents yellow. To set the color to green, use the following line of VBA code: 

Range("A1").Font.Color = vbGreen 
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Video 

To review the video on editing a macro, go to: Edit a macro 

Activity: Student-and-teacher collaboration 
In this activity, the class will collaborate with the teacher to edit a macro by using the 
Visual Basic Editor. 

Resources required 
You’ll need the following resources for this activity: 

• None 

Activity instructions 
Participate in the activity by collaborating with the teacher and other students to create 
a macro. 

Try-it: Edit simple macros 
 In this leveled try-it, you’ll use the Visual Basic Editor to make simple changes to an 

existing macro. 

Try-it 1 
In this try-it, you’ll change two formatting options in an existing macro. 

Resources 
You’ll need the following resources for this try-it: 

• Open L4_T2_try1_months_starter.xlsm in this lesson’s Learning Activity Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Open the Visual Basic Editor to examine the macro in the starter file. 

2. Find the line of VBA code that sets the font size to 16. Change the font size to 14. 

3. Save and close the editor, and then run the macro to verify that the changed code 
works as expected. 

https://aka.ms/Video-Edit-a-macro
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4. Find the line of VBA code that sets the font style to Bold Italic. Change the font style 
to Italic. 

5. Save and close the editor, and then run the macro to verify that the changed code 
works as expected. 

Try-it 2 
In this try-it, you’ll change three formatting options in an existing macro. 

Resources 
You’ll need the following resources for this try-it: 

• Open L4_T2_try2_months_starter.xlsm in this lesson’s Learning Activity Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Open the Visual Basic Editor to examine the macro in the starter file. 

2. Find the line of VBA code that sets the font size to 16. Change the font size to 14. 

3. Save and close the editor, and then run the macro to verify that the changed code 
works as expected. 

4. Find the line of VBA code that sets the font style to Bold Italic. Change the font style 
to Italic. 

5. Save and close the editor, and then run the macro to verify that the changed code 
works as expected. 

6. Find the line of VBA code that sets the color to the numeric value 192. Change the 
color to blue. 

7. Save and close the editor, and then run the macro to verify that the changed code 
works as expected. 
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Wrap-up 
Use these questions to check what you learned in this lesson:  

1. Which of the following is the correct name for the color blue in VBA? 

Select the correct option. 

a. blue 

b. vbBlue 

c. vbaBlue 

d. rgbBlue 

2. Which of the following are valid macro names? 

Select all that apply. 

a. ApplySettings 

b. Apply_Settings 

c. Apply-Settings 

d. 2Settings 

e. Apply2Settings 

3. You can find the macro name on a line that starts with ________________________. 

Fill in the blank space. 
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Lesson 5: Understanding 
relative macros 
Overview 
In this lesson, you’ll learn the difference between absolute and relative references in 
macros. You’ll also record a relative macro. The activities, discussions, and 
demonstrations will give you the opportunity to practice and apply what you learn. 

Warm-up 
Use these questions to find out what you already know about this lesson’s topics: 

1. Which of the following options refers to macro references that change depending on 
the active cell when you run a macro? 

Select the correct option. 

a. Absolute cell references 

b. Macro cell references 

c. Relative cell references 

d. VBA cell references 

2. Which type of cell references should you use if you always want a macro to run on 
the same exact cells? 

Select the correct option. 

a. Absolute cell references 

b. Macro cell references 

c. Relative cell references 

d. VBA cell references 

3. To record a relative macro, select the ________________________ command. 

Fill in the blank space. 
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Topic 1: Understand relative vs. 
absolute macros 
The macro recorder has two different ways to manage the cells that you select while 
recording actions. By default, the VBA code for the macro will record the exact cells that 
you select during the recording. If you start the recording in C4, select A1 and enter 
Munson's, and then move to A2 and enter Weekly Report, the resulting VBA code 
would be as follows: 

Range("A1").Select 

ActiveCell.FormulaR1C1 = "Munson's" 

Range("A2").Select 

ActiveCell.FormulaR1C1 = "Weekly Report" 

The macro will always put the text in cells A1 and A2, no matter which cell you’ve 
selected when you start the macro. This is called absolute cell references. 

If you record the same macro with relative cell references, the location of the text will be 
relative to the cell that you have selected when you begin recording. The same steps, 
recorded by using relative cell references beginning from C4, generate the following 
VBA code: 

ActiveCell.Offset(-3, -2).Range("A1").Select 

ActiveCell.FormulaR1C1 = "Munson's" 

ActiveCell.Offset(1, 0).Range("A1").Select 

ActiveCell.FormulaR1C1 = "Weekly Report" 

When you select cell A1 by using relative references, the macro recorder doesn't create 
code to select A1. Instead, it creates code to select a cell based on an offset: it moves to 
a cell that is three rows and two columns before the starting point and enters 
Munson's. It then moves to the next row from there and adds Weekly Report. 

If you select cell F13 and run the previous macro with absolute cell references, 
Munson's is added to A1. However, if you run the code with relative references from 
that location, the text will be added to D10, because that cell is three rows and two 
columns before F13. 

Use absolute cell references when you want the steps performed in the exact same cells 
on the worksheet every time, regardless of which cell is active when the macro starts. 
For example, a macro to place heading information at the beginning of a worksheet 
would use absolute cell references. 
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Use relative cell references when you want the macro to perform steps on any cell, 
based on the selected location when it begins. An example of this would be a macro 
that adds the days of the week beginning in the selected cell. 

 

Did you know? 

Relative cell references can cause problems in a macro. For example, 
if the macro includes instructions to move a few columns or rows 
before a cell, and you run it from cell A1, it will stop responding, 
because A1 is the first cell in the worksheet. 

Activity: Show and tell 
In this activity, your teacher will discuss and demonstrate the difference between 
absolute cell references and relative cell references when recording a macro. 

Resources required 
You’ll need the following resources for this activity: 

• None 

Activity instructions 
Participate in the activity by following along with the teacher’s demonstration. During 
the demonstration, ask questions about topics or tasks that you’re unclear about. 

Try-it: Understand relative vs. absolute macros 
 In this standalone try-it activity, you’ll create a macro by using absolute cell 

references. 

Resources 
You’ll need the following resources for this try-it: 

• None 
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Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Create a new macro-enabled workbook named L5_T1_try_my_info.xlsm. 

2. Select any cell other than A1 before you begin recording. 

3. Use the macro recorder to begin recording a macro, and: 

a. Name the macro InsertMyInfo. 

b. Assign it the shortcut keyboard combination Ctrl+Shift+M. 

c. For the Description, enter the text Inserts a few lines of information about 
me, starting in cell A1. 

4. After you begin recording, enter the following information: 

a. Enter your name in cell A1. 

b. Enter your location (city, state, province, or similar) in cell A2. 

c. Enter your date of birth in cell A3. 

5. Apply the formatting of your choice to the information that you’ve entered. 

6. Stop recording. Clear the contents of cells A1:A3 and run your macro to verify that it 
works as expected. 

Topic 2: Record a relative macro 
The macros that you've recorded to this point have used absolute cell references. The 
Developer tab on the ribbon includes a command to switch to relative references and 
back to absolute references. To record steps by using relative references, select the 
Developer tab, and then, in the Code group, select Use Relative References. To switch 
back to absolute references, select Use Relative References again. The following 
screenshot depicts the Code group with Use Relative References enabled and 
highlighted. 

 
Figure 23: The Code group with Use Relative References enabled and highlighted. 

Generally, you'll turn Use Relative References on or off before you select Record 
Macro, but you can use the command while you’re recording. 
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Activity: Discuss and learn 
In this activity, the teacher will lead a class discussion about the Use Relative 
References feature and will then demonstrate recording a macro with relative 
references. 

Resources required 
You’ll need the following resources for this activity: 

• None 

Activity instructions 
Participate in the group discussion and ask clarifying questions about any topics that 
you don’t fully understand. 

Try-it: Record a relative macro 
 In this standalone try-it activity, you’ll record a macro with relative references. 

Resources 
You’ll need the following resources for this try-it: 

• Open your workbook from the previous try-it activity. Alternatively, open 
L5_T2_try_my_info_starter.xlsm in this lesson’s Learning Activity Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Turn on the Use Relative References feature and record a macro named 
InsertMyInfoRelative. Assign the keyboard shortcut Ctrl+Shift+R and add an 
appropriate description.  

2. After you begin recording, enter a few lines of information, as you did in the 
previous try-it: 

a. Enter your name in the currently selected cell. 

b. Enter your location (city, state, province, or similar) on the next row, in the same 
column. 

c. Enter your date of birth on the next row, in the same column. 

3. Apply the formatting of your choice to the information that you’ve entered. 
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4. Stop recording. Select a cell in an unused area of the worksheet and run your macro 
to verify that it works as expected. It should add your name to the current cell and 
then add the additional information on the next rows. 

Wrap-up 
Use these questions to check what you learned in this lesson: 

1. On which tab can you enable relative references? 

Select the correct option. 

a. Home 

b. Insert 

c. Formulas 

d. Data 

e. Review 

f. Developer 

2. When can you enable or disable relative references? 

Select the correct option. 

a. Only before you record 

b. Only after you record 

c. Only while you record 

d. At any time 

3. Use the ________________________ command to disable relative references. 

Fill in the blank space. 
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Glossary 
Absolute cell 
references 

Macro locations that do not change regardless of the active cell 
when you start the macro. 

Developer tab A tab on the ribbon with commands for working with macros, which 
is hidden by default. 

Macro A series of actions grouped together into a single command. 

Macro-enabled 
Workbook 

A workbook type that can save macros for use when you open the 
workbook in the future. 

Macro recorder A tool that creates a macro by capturing actions and recording them 
in VBA code. 

Module A container for one or more macros. 

Personal Macro 
Workbook 

A special workbook that stores macros so they are available any time 
you use Excel on the same computer. 

Relative cell 
references 

Macro locations that are based on the active cell when the macro is 
started. 

VBA Visual Basic for Applications, a programming language available in 
most Microsoft Office apps. 

Visual Basic Editor An environment for creating and editing VBA code and procedures.  

Table 2: Glossary terms and definitions 
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Cornerstone 
Overview 
In this Cornerstone, you’ll help automate a report for Munson’s Pickles and Preserves 
Farm by managing, editing, and creating macros to format imported data. You’ll copy 
macros between workbooks, edit macros in Visual Basic Editor, and record a macro to 
add information to the beginning of a workbook. 

Objectives 
The following table outlines the Cornerstone objectives and their corresponding 
Microsoft Office Specialist (MOS) exam objectives. 

Enable and run a 
macro 

• 1.1.3: Enable macros in a workbook  

Copy and edit a 
macro with Visual 
Basic Editor 

• 1.1.1: Copy macros between workbooks 
• 3.6.2: Name simple macros 
• 3.6.3: Edit simple names  

Record a macro • 3.6.1: Record simple macros 

Table 3: Cornerstone objectives 

Duration 
50 minutes 

Instructions 
1. Complete the following tasks for each file. 

2. When saving your file, add your name to the end of the filename, for example: 
Cornerstone_macros_Dwayne_Espino. Follow your teacher’s directions for where to 
save your files.  

3. When you’re done with the Cornerstone, assess your completion and enter the 
points that you think you earned within the following task lists. You can ask your 
teacher for help if required. 
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Tasks 
You’ll work with two files in this Cornerstone. The following are the tasks you must do 
within each file. 

File 1: Cornerstone_macros_starter.xlsm 
Task: Enable and run a macro (2 points) 
1. Open Cornerstone_macros_starter.xlsm and enable macros. This worksheet is an 

example of the raw data that Munson’s employees import when generating a report. 
(1 point) (Exam objective 1.1.3) 

2. Run the macro named AddHeadings to insert column and row headings. You can 
use the ribbon or the keyboard shortcut combination Ctrl+Shift+H. (1 point)  

Points scored: ________ / 2 

FILE 1 TOTAL POINTS: ________/ 2 

File 2: Cornerstone_report_starter.xlsm 
Task: Copy and edit a macro with the Visual Basic Editor (9 
points) 
1. Open Cornerstone_report_starter.xlsm and enable macros. This worksheet is the 

report that you’ll prepare by using macros. 

2. Access the Visual Basic Editor and copy Module1 from 
Cornerstone_report_starter.xlsm to Cornerstone_macros_starter.xlsm. This will 
create a new module named Module11. (1 point) (Exam objective 1.1.1) 

3. Copy only the AddHeadings VBA code from Cornerstone_macros_starter.xlsm to 
Cornerstone_report_starter.xlsm. Place it after the DeleteHeadings macro already 
in the workbook. (2 points) (Exam objective 1.1.1) 

4. Close Cornerstone_macros_starter.xlsm. 

5. In the VBA code for Cornerstone_report_starter.xlsm, make the following edits to 
the AddHeadings macro: 

a. Change the font color from vbRed to vbBlack. 

b. Change the bold setting from False to True. (4 points) (Exam objective 3.6.3) 

6. Change the name of the DeleteHeadings macro to RemoveHeadings. (1 point) 
(Exam objective 3.6.2) 
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7. Close the Visual Basic Editor and switch back to Cornerstone_report_starter.xlsm 
in Excel. 

8. Run the AddHeadings macro. (1 point) 

Points scored: ________ / 9 

Task: Record a macro (3 points) 
1. Create a new macro with the following settings: 

a. Name: AddInfo 

b. Shortcut key: Ctrl+Shift+I 

c. Description: Adds company information at the top of the current worksheet 
(1 point)  

2. The macro should perform the following actions: 

a. Add three blank rows before the existing row 1. 

b. Place the text Munson’s Pickles and Preserves Farm in A1. Apply the Title style 
to this text. 

c. Place the text http://www.munsonspicklesandpreservesfarm.com in A2. 

d. Place the text Summary Report in A3. (2 points) (Exam objective 3.6.1) 

Points scored: ________ / 3 

FILE 2 TOTAL POINTS: ________ /12 
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Module overview 
Description 
In Microsoft Excel 2019, you can use PivotTables and PivotCharts to summarize and 
present large amounts of data. PivotCharts and PivotTables complement each other by 
enabling you to present complex information in attractive and user-friendly ways. At the 
end of this module, you’ll be able to use and manage PivotCharts and PivotTables. 

Lesson Learning objective Exam objective(s) 

Using 
PivotTables 

Understand and create PivotTables. • 4.2.1 

Modifying 
PivotTables 

Modify and format PivotTables and the data 
in them. 

• 4.2.2 
• 4.2.6 

Performing 
PivotTable 
calculations 

Create calculated fields in a PivotTable, 
calculate how values display in a PivotTable. 

• 4.2.5 
• 4.2.2 

Filtering and 
grouping 
PivotTables 

Filter, group, and ungroup data in a 
PivotTable. 

• 4.2.3 
• 4.2.4 

Using 
PivotCharts: 
the basics 

Create PivotCharts and change options that 
affect PivotCharts. 

• 4.3.1 
• 4.3.2 

Using 
PivotCharts: 
beyond the 
basics 

Format PivotCharts, and expand, collapse, 
and display details in a PivotChart. 

• 4.3.3 
• 4.3.4 
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Lesson Learning objective Exam objective(s) 

Cornerstone: 
Creating a 
sales 
dashboard 

• Create and format a PivotTable. 
• Perform PivotTable calculations. 
• Group and filter data. 
• Create and modify a PivotChart. 

• 4.2.1 
• 4.2.2 
• 4.2.3 
• 4.2.4 
• 4.2.5 
• 4.2.6 
• 4.3.1 
• 4.3.2 
• 4.3.3 
• 4.3.4 

Table 1: Objectives by lesson 

Scenario 
You’re approaching the end of your one-year internship at Munson’s Pickles and 
Preserves Farm, and your team members have asked you to create a summary of the 
sales that Munson’s generated at farmers markets, through retail and wholesale outlets, 
and at the farm shop. The marketing team will use the charts and tables that you create 
as a dashboard to present to new students in the next academic semester. 

Cornerstone 
This module concludes with a Cornerstone project, in which you’ll create charts and 
tables that the sales team will use as an interactive dashboard. In the Cornerstone, you’ll: 

• Create a PivotTable. 
• Modify and format the PivotTable. 
• Perform PivotTable calculations. 
• Group and filter data. 
• Create and modify a PivotChart. 
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Lesson 1: Using PivotTables 
Overview 
PivotTables in Excel enable you to analyze and summarize complex data. You can use 
PivotTables to present a large amount of data in a concise manner, make comparisons 
between data, and study data trends. At the end of this lesson, you’ll be able to create 
PivotTables in Excel. 

Warm-up 
Use these questions to find out what you already know about this lesson’s topics: 

1. What can PivotTables help you do with large volumes of data? 

Select all that apply. 

a. Summarize 

b. Organize 

c. Optimize 

d. Analyze 

2. To create PivotTables, you select the ________________________ tab. 

Fill in the blank space. 

Topic 1: Use Recommended PivotTables 
Did you know that when you’re working with PivotTables, Excel can recommend 

PivotTables that suit your data? To use this option, you can select Recommended 
PivotTables in the Tables group. 

To create a recommended PivotTable: 

1. Select a cell in the data range. 

2. Select the Insert tab. 
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3. Select Recommended PivotTables in the Tables group, which the following 
screenshot depicts. 

 
Figure 1: Tables group of the Insert tab 

4. Select an option in the Recommended PivotTables dialog box, which the following 
screenshot depicts. 

 
Figure 2: Recommended PivotTables dialog box 
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Additional information 

To review the tutorial on PivotTables, go to: Overview of PivotTables 
and PivotCharts 

Activity: Think-pair-share 
In this activity, your teacher will demonstrate how to use Recommended PivotTables, 
and then pair you with a partner. Review the online tutorial and discuss with your 
partner the different ways that you might use PivotTables to analyze data. 

Resources required 
You’ll need the following resources for this activity: 

• None 

Activity instructions 
Participate in the activity by following these instructions: 

1. Follow along as the teacher demonstrates how to use recommended PivotTables. 

2. Ask the teacher clarifying questions. An example is: How can I choose different 
PivotTables? 

3. Review the online tutorial and think about how you might choose different 
PivotTables to determine different information, for example: sum of sales versus 
count of sales. 

4. Discuss your idea(s) with your partner. 

Try-it: Use Recommended PivotTables 
 In this standalone try-it activity, you’ll create a recommended PivotTable with 
sums and also a recommended PivotTable with counts. 

Resources 
You’ll need the following resources for this try-it: 

• Open L1_T1_try_farm_shop_sales_starter.xlsx in this lesson’s Learning Activity 
Resources. 

  

https://aka.ms/Overview-of-PivotTables-and-PivotCharts
https://aka.ms/Overview-of-PivotTables-and-PivotCharts
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Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Use Recommended PivotTables to create a Sum of Farm Shop Sales by Category 
PivotTable. 

2. Use Recommended PivotTables to create a Count of Product by Category 
PivotTable. 

Topic 2: Create PivotTables 
 Using Recommended PivotTables is helpful when you need results fast, but there 

might be situations in which you need to control all the options for your PivotTable. 
When you’re working with specific data and you want to precisely control all the 
options, you’ll need to create a PivotTable yourself. 

To create a PivotTable: 

1. Select the data that you want to use for your PivotTable. 

Note: Your data shouldn't have any empty rows or columns. It must have only a single-
row heading. 

2. Select the Insert tab. 

3. Select PivotTable in the Tables group. The Create PivotTable dialog box displays, 
as the following screenshot depicts. 
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Figure 3: Create PivotTable dialog box 

4. In the Create PivotTable dialog box: 

a. In the Choose the data that you want to analyze section, select: 

i. Select a table or range to enter the Table/Range to use. 

ii. Use an external data source to use an external data source, select Choose 
Connection, and then select a connection from the Existing Connections 
dialog box. 

b. In the Choose where you want the PivotTable report to be placed section, 
select: 

i. New worksheet to place the PivotTable in a new worksheet. 

ii. Existing worksheet to place the PivotTable in an existing worksheet, and 
then select the location where you want the PivotTable. 

5. Select OK. 
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6. In the PivotTable Fields pane (also known as the Field List), select the desired fields, 
as the following screenshot depicts. 

 
Figure 4: PivotTable Fields pane 

 

Video 

To review the video on how to create PivotTables, go to: Create a 
PivotTable to analyze worksheet data 

Activity: Show and Tell 
In this activity, your teacher will demonstrate the steps to create a PivotTable. 

Resources required 
You’ll need the following resources for this activity: 

• None 

https://aka.ms/create-a-pivottable-to-analyze-worksheet-data
https://aka.ms/create-a-pivottable-to-analyze-worksheet-data
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Activity instructions 
Participate in the activity by following these instructions: 

1. Follow along as the teacher demonstrates how to create a PivotTable.

2. Ask the teacher clarifying questions. An example is: How can I put the PivotTable on
the same worksheet as the data?

Try-it: Create PivotTables 
 In this standalone try-it activity, you’ll create a PivotTable with sales by category. 

Resources 
You’ll need the following resources for this try-it: 

• Open L1_T2_try_farm_shop_sales_starter.xlsx in this lesson’s Learning Activity
Resources.

Instructions 
The following are the general tasks that you need to perform during this try-it: 

• Create a PivotTable by using Category as the row and Farm Shop Sales as the value.

Wrap-up 
Use these questions to check what you learned in this lesson: 

1. Which feature on the Insert tab provides preconfigured PivotTable options?

Select the correct option.

a. Preset PivotTables

b. Recommended PivotTables

c. PivotTable Options

d. Table
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2. What are the data sources that you can use for a PivotTable? 

Select all that apply. 

a. Table 

b. Range 

c. External data source 

d. Grid 
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Lesson 2: Modifying PivotTables 
Overview 
You can modify your PivotTables by moving fields around and formatting the data to 
make analysis easier. At the end of this lesson, you’ll be able to modify and format 
PivotTables. 

Warm-up 
Use these questions to find out what you already know about this lesson’s topics: 

1. Which of the following characteristics can you modify in the PivotTable Styles 
group? 

Select all that apply. 

a. Color 

b. Font 

c. Layout 

d. Totals 

2. Which of the following characteristics can you change in the Layout group for 
PivotTable design? 

Select all that apply. 

a. Repetition of item labels 

b. Subtotals 

c. Color 

d. Grand Totals 

Topic 1: Modify field selections and 
options 

 Field placement determines the data grouping and display in a PivotTable. 
Typically, Excel adds non-numeric fields to the Rows box, numeric fields to the Values 
box, and date fields to the Columns box of the PivotTable Fields pane. 
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Change field selections in a PivotTable 
To change the field selection in a PivotTable: 

1. Select the PivotTable. 

2. If the PivotTable Fields pane does not automatically display, select the Analyze tab, 
and then select Field List in the Show group. The following screenshot depicts the 
Show group. 

 
Figure 5: Show group on the Analyze tab 

3. Select the field(s) that you would like to add or remove from the PivotTable by 
selecting the check boxes in the PivotTable Fields pane. 

4. Select the field that you want to move, and then select the box that you want to 
move it to by using the Field drop-down list in the PivotTable Fields pane. You can 
also move the field before or after other fields in the same box. Alternatively, you can 
drag and drop the field to different boxes. The following screenshot depicts the field 
drop-down list. 
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Figure 6: Field drop-down list in the PivotTable Fields pane 

 

Did you know? 

The act of moving fields around is known as pivoting the data, and 
this is how PivotTables and PivotCharts get their name. 

Change PivotTable options 
To change PivotTable options: 

1. Select the PivotTable. 

2. Select the Analyze tab, and then select Options in the PivotTable group. 

3. Select the desired options in the PivotTable Options dialog box, and then select 
OK. The following screenshot depicts the PivotTable Options dialog box. 
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Figure 7: PivotTable Options dialog box 

Note: Be sure to include alt text in the Alt Text tab of the PivotTable Options dialog 
box to describe your PivotTable. Alt text provides alternative, text-based descriptions of 
images and tables to persons who have visual or cognitive impairments and use screen 
readers. 

 

Video 

To review the video on modifying PivotTables, go to: Use the Field List 
to arrange fields in a PivotTable 

 

Additional information 

To review the tutorial on PivotTable options, go to: PivotTable options 

https://aka.ms/Use-the-Field-List-to-arrange-fields-in-a-PivotTable
https://aka.ms/Use-the-Field-List-to-arrange-fields-in-a-PivotTable
https://aka.ms/pivottable-options
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Activity: Discuss and learn 
In this activity, your teacher will demonstrate moving and changing fields by using the 
field list. There will also be a discussion on how this can be helpful when you’re 
analyzing data. 

Resources required 
You’ll need the following resources for this activity: 

• None 

Activity instructions 
Participate in the activity by following these instructions: 

1. Follow along as the teacher demonstrates how to move and change fields by using 
the field list. 

2. Ask the teacher clarifying questions. An example is: How can I move fields? 

3. Think about how you might choose different field placement to determine different 
information; for example, filtering by season. 

Try-it: Modify field selections and options 
 In this leveled try-it activity, you’ll add a field to a PivotTable and review the impact 

on the PivotTable. You’ll rearrange fields in the PivotTable field list and review the 
impact on the PivotTable. 

Try-it 1 
Resources 
You’ll need the following resources for this try-it: 

• Open L2_T1_try1_farm_shop_sales_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following is the general task that you need to perform during this try-it: 

• Add the Seasons field to the existing PivotTable. 
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Try-it 2 
Resources 
You’ll need the following resources for this try-it: 

• Open L2_T1_try2_farm_shop_sales_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Move the Seasons field from the Row box to the Category box. 

2. Hide column grand totals. 

3. Add alt text to the PivotTable. 

Topic 2: Format data 
 How you display data in a PivotTable can help or hinder your analysis. Make sure 

that you use PivotTables to your best advantage and impress your audience by 
presenting information that is clear, concise, and easy to interpret. In this lesson, you'll 
learn how to change the appearance and layout of a PivotTable to maximize its use. 

Change PivotTable layout 
To change the layout of a PivotTable: 

1. Select the PivotTable. 

2. Select the Design tab, and then select the Report Layout drop-down list in the 
Layout group. The following screenshot depicts the Report Layout drop-down list. 
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Figure 8: Report Layout drop-down list in the Layout group 

3. Select the desired option. 

Change PivotTable styles 
To change the style of your PivotTable: 

1. Select the PivotTable. 

2. Select the Design tab, and then select the desired style in the PivotTable Styles 
group. The following screenshot depicts the options in the PivotTable Styles group. 
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Figure 9: PivotTable Styles options 

Change the number format for a field 
You can also change the number format for the fields in your PivotTable. To do so: 

1. Select the header cell of the Value field in the PivotTable; for example, Sum of Farm 
Shop Sales. 

2. Select the Analyze tab, and then select Field Settings in the Active Field group, 
which the following screenshot depicts. 
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Figure 10: Active Field group of the Analyze tab 

3. Select Number Format in the Value Field Settings dialog box, which the following 
screenshot depicts. 

 
Figure 11: Value Field Settings dialog box 

4. Change the number format to the desired setting in the Format Cells dialog box, 
which the following screenshot depicts. Select OK. 
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Figure 12: Format Cells dialog box 

 

Additional information 

To review the article on formatting a PivotTable, go to: Design the 
layout and format of a PivotTable 

Activity: Show and tell 
In this activity, your teacher will demonstrate how to change a PivotTable layout and 
design, and also how to format the value fields in a PivotTable. 

https://aka.ms/Design-the-layout-and-format-of-a-PivotTable
https://aka.ms/Design-the-layout-and-format-of-a-PivotTable
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Resources required 
You’ll need the following resources for this activity: 

• None 

Activity instructions 
Participate in the activity by following these instructions: 

1. Follow along as the teacher demonstrates how to change a PivotTable layout and 
design, and how to format the value fields in a PivotTable. 

2. Ask the teacher clarifying questions. An example is: How can I change the design to 
another color? 

Try-it: Format data 
 In this leveled try-it activity, you’ll change PivotTable layout and design, and format 

the sales field to display currency without decimal points. 

Try-it 1 
Resources 
You’ll need the following resources for this try-it: 

• Open L2_T2_try1_farm_shop_sales_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Change Report Layout to tabular form. 

2. Change PivotTable style to Light, Row 2, Column 4 (Light Blue, Pivot Style Light 
17). 

Try-it 2 
Resources 
You’ll need the following resources for this try-it: 

• Open L2_T2_try2_farm_shop_sales_starter.xlsx in this lesson’s Learning Activity 
Resources. 
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Instructions 
The following is the general task that you need to perform during this try-it: 

• Change the number format for Farm Shop Sales to currency with no decimal points. 

Wrap-up 
Use these questions to check what you learned in this lesson:  

1. What are the choices for field placement (boxes) in the PivotTable Fields pane? 

Select all that apply. 

a. Value 

b. Column 

c. Row 

d. Header 

2. When you move a field from Rows to Columns in a PivotTable, you are 
________________________ the data. 

Fill in the blank space. 
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Lesson 3: Performing PivotTable 
calculations 
Overview 
At the end of this lesson, you’ll be able to calculate data in PivotTables. You’ll create a 
calculated field in a PivotTable and calculate how values display in a PivotTable. 

Warm-up 
Use these questions to find out what you already know about this lesson’s topics: 

1. You can summarize values in a PivotTable by:

Select all that apply.

a. Sum

b. Average

c. Dividend

d. Count

2. Calculated fields use a ________________________ to create a new field in a PivotTable.

Fill in the blank space.

Topic 1: Add calculated fields 
 You can use the Calculated Field option to create new fields for your PivotTable 

that did not exist in your original data. For example, you could add a new field that 
depicts the amount of tax on sales. 
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Add a calculated field 
To add a calculated field: 

1. Select the PivotTable. 

2. Select the Analyze tab, and then, select the Fields, Items, & Sets drop-down list in 
the Calculations group. The following screenshot depicts the Fields, Items, & Sets 
drop-down list. 

 
Figure 13: Fields, Items, & Sets drop-down list 

3. Select Calculated Field. 

4. In the Insert Calculated Field dialog box, enter a Name for the field and a Formula. 
The following screenshot depicts the Insert Calculated Field dialog box. 

 
Figure 14: Insert Calculated Field dialog box 
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5. Select OK. 

 

Additional information 

To review the tutorial on calculated fields in PivotTables, go to: 
Calculate values in a PivotTable 

Activity: Show and tell 
In this activity, your teacher will demonstrate how to create a calculated field of 15 
percent commission on sales. 

Resources required 
You’ll need the following resources for this activity: 

• None 

Activity instructions 
Participate in the activity by following these instructions: 

1. Follow along as the teacher demonstrates how to add a calculated field. 

2. Ask the teacher clarifying questions. An example is: How can I pick the field to use 
for my formula? 

Try-it: Add calculated fields 
 In this standalone try-it activity, you’ll create a calculated field for 10 percent sales 

tax on the Farm Shop Sales field. 

Resources 
You’ll need the following resources for this try-it: 

• Open L3_T1_try_farm_shop_sales_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following is the general task that you need to perform during this try-it: 

• Add a calculated field with the name Sales Tax by using the formula ='Farm Shop 
Sales' * -.10. 

https://aka.ms/Calculate-values-in-a-PivotTable
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Topic 2: Depict values in different ways 
 Value field settings in Excel are useful in improving the versatility of your data 

presentation. You can choose from a variety of options to determine the type of 
calculation that you want to use to summarize data for a field. You can choose from 
calculations such as sums, averages, or counts. You can display values as a part of the 
total, as a running total, as a rank, and more. 

Change PivotTable value field settings 
1. Select the header cell of the Value field in the PivotTable; for example, Sum of Farm 

Shop Sales. 

2. Select the Analyze tab, and then select Field Settings in the Active Field group, 
which the following screenshot depicts. 

 
Figure 15: Active Field group on the Analyze tab 

3. Select the desired settings in the Value Field Settings dialog box, which the 
following screenshot depicts. 
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Figure 16: Value Field Settings dialog box 

4. Select OK. 

 

Additional information 

To review the tutorial on displaying calculations in PivotTables, go to: 
Show different calculations in PivotTable value fields 

Activity: Think-pair-share 
In this activity, your teacher will demonstrate how to change values of field settings and 
then pair you with a fellow student. Review the tutorial and consider how you can use 
the different Show Values As options to find out different things. 

Resources required 
• None 
  

https://aka.ms/Show-different-calculations-in-PivotTable-value-fields
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Activity instructions 
Participate in the activity by following these instructions: 

1. Follow along as the teacher demonstrates how to change the values of field settings. 

2. Ask the teacher clarifying questions. An example is: How can I display a value as part 
of the total? 

3. Review the online tutorial and think about how you might choose from the various 
options to determine different information; for example, sum of sales vs. count of 
sales. 

4. Discuss your idea(s) with your partner. 

Try-it: Depict values in different ways 
 In this standalone try-it activity, you’ll change the Sum of Farm Shop Sales field 

to display the value as a running total. You’ll change the Count of Farm Shop Sales 
field to display the value as a percentage of the grand total. 

Resources 
You’ll need the following resources for this try-it: 

• Open L3_T2_try_farm_shop_sales_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Change the Sum of Farm Shop Sales field to display the value as a running total. 

2. Change the Count of Farm Shop Sales field to display the value as a percentage of 
the grand total. 
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Wrap-up 
Use these questions to check what you learned in this lesson:  

1. You can display values in a PivotTable as: 

Select all that apply. 

a. % of Grand Total 

b. Dividend of a specified field 

c. Running Total in a specified field 

d. Rank smallest to largest 

2. Calculated fields use formulas to calculate new ________________________ in a 
PivotTable. 

Fill in the blank space. 
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Lesson 4: Filtering and 
grouping PivotTables 
Overview 
At the end of this lesson, you’ll be able to filter and group data in a PivotTable. You’ll 
filter data with slicers, group and ungroup data in a PivotTable, and filter dates with a 
timeline. 

Warm-up 
Use these questions to find out what you already know about this lesson’s topics: 

1. What is the purpose of filters in a PivotTable? 

Select the correct option. 

a. Group data 

b. Drill down into data 

c. Expand data 

d. Categorize data 

2. What type of fields can be grouped? 

Select all that apply. 

a. Date 

b. Text 

c. Numeric 

d. Labels 

Topic 1: Create slicers 
 Excel provides slicers, which you can use to filter the data in a PivotTable. When 

you insert a slicer into your PivotTable, a box displays that you can use to filter your 
PivotTable data. Slicers also indicate the filtering state in a PivotTable, so that you can 
understand what exactly is currently on display. 
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Creating slicers to filter data 
To create a slicer to filter data: 

1. Select the PivotTable. 

2. Select the Analyze tab. 

3. Select Insert Slicer in the Filter group, which the following screenshot depicts. 

 
Figure 17: Filter group on the Analyze tab 

4. In the Insert Slicers dialog box, select the field(s) for the slicer. 

 
Figure 18: Insert Slicers dialog box 

5. Select OK. 
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6. Make selections in the slicer filter that displays, and then filter your data. The 
following screenshot depicts the slicer filter. 

 
Figure 19: Slicer filter 

 

Video 

To review the video on filtering data in a PivotTable, go to: Filter data 
in a PivotTable 

Activity: Show and tell 
In this activity, your teacher will demonstrate adding and using a slicer for the season 
field. 

Resources required 
You’ll need the following resources for this activity: 

• None 

Activity instructions 
Participate in the activity by following these instructions: 

1. Follow along as the teacher demonstrates how to add and use a slicer in a 
PivotTable. 

2. Ask the teacher clarifying questions. An example is: How can I pick the field(s) to use 
for my slicer(s)? 

Try-it: Create slicers 
 In this standalone try-it activity, you’ll add slicers for the Category and Product 

fields. You’ll experiment with filtering the PivotTable by using your slicers. 

https://aka.ms/Filter_data_in_a_Pivot_Table
https://aka.ms/Filter_data_in_a_Pivot_Table
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Resources 
You’ll need the following resources for this try-it: 

• Open L4_T1_try_farm_shop_sales_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Insert slicers for the Product and Category fields. 

2. Move the slicers on the worksheet so that both are visible. 

3. Filter the PivotTable by Dairy. 

4. Filter the PivotTable by using two or more categories of your choice. 

5. Clear the filters. 

Topic 2: Group fields 
 You can group date fields and numeric fields to analyze the data in more 

manageable subsets. For example, instead of reviewing the data for every day, you can 
group it into months, quarters, or years. Fields must be in the row or column areas in the 
order in which you want to group them. 

Group date or numeric fields 
To group data or numeric fields: 

1. Select a cell in the Date or Numeric field that you want to group. 

2. Select the Analyze tab. 

3. Select Group Field in the Group group. 

 
Figure 20: Group group on the Analyze tab 

Note: To group a portion of the field, select the cells that you want to group, and then 
select Group Selection. 
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4. Select how you want to group the field in the Grouping dialog box. The following 
screenshot depicts the Grouping dialog box for numeric fields. 

 
Figure 21: Grouping dialog box for numeric fields 

The following screenshot depicts the Grouping dialog box for date fields. 

 
Figure 22: Grouping dialog box for date fields 

5. Select OK. 

 

Video 

To review the video on grouping or ungrouping data in a PivotTable, 
go to: Group or ungroup data in a PivotTable 

  

https://aka.ms/Group_data_in_Pivot_Tables
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Activity: Discuss and learn 
In this activity, you’ll review the video in the link above. Your teacher will demonstrate 
how to group and ungroup data in a PivotTable, and then discuss how you can analyze 
data better by grouping it. 

Resources required 
You’ll need the following resources for this activity: 

• None 

Activity instructions 
Participate in the activity by following these instructions: 

1. Review the video. 

2. Follow along as the teacher demonstrates how to group and ungroup data. 

3. Ask the teacher clarifying questions. An example is: What types of fields can be 
grouped? 

4. Think about how you might use grouping to analyze data and participate in the 
discussion. 

Try-it: Group fields 
 In this standalone try-it activity, you’ll group sales date by month and year, 

ungroup the sales date, and regroup the sales date by quarters. You’ll group farm shop 
sales by hundreds. 

Resources 
You’ll need the following resources for this try-it: 

• Open L4_T2_try_farm_shop_sales_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Group sales date by month and year. 

2. Ungroup sales date. 

3. Group sales date by quarter. 

4. Group farm shop sales by hundreds. 
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Topic 3: Create timelines 
 You can use timelines to easily filter dates in your data. Before you can add a 

timeline filter, make sure that your source data has dates in order. The Date field does 
not have to be displayed in your PivotTable. The process of adding timelines is not very 
complicated and is similar to adding slicers. 

Add a timeline filter 
To add a timeline filter to your PivotTable: 

1. Select the PivotTable. 

2. Select the Analyze tab. 

3. Select Insert Timeline in the Filter group, which the following screenshot depicts. 

 
Figure 23: Filter group on the Analyze tab 

4. Select the desired date field in the Insert Timelines dialog box, which the following 
screenshot depicts. 

 
Figure 24: Insert Timelines dialog box 
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5. Select OK. 

6. To filter the data by date, select the desired date(s) in the timeline filter, as the 
following screenshot depicts. 

 
Figure 25: Timeline filter 

 

Additional information 

To review the tutorial on creating timelines, go to: Create a PivotTable 
timeline to filter dates 

 

Video 

To review the video on using slicers, timelines, and PivotCharts, go to: 
Use slicers, timelines and PivotCharts 

Activity: Each one, teach one 
In this activity, your teacher will pair you with a partner and ask you to review the 
tutorial in the previous Video section. You’ll then teach each other how to add timelines. 

Resources required 
You’ll need the following resources for this activity: 

• Open L4_T3_act_farm_shop_sales_starter.xlsx in this lesson’s Learning Activity 
Resources. 

  

https://aka.ms/create-a-pivottable-timeline-to-filter-dates
https://aka.ms/create-a-pivottable-timeline-to-filter-dates
https://aka.ms/Video-Use-slicers-timelines-and-PivotCharts-to-analyze-your-PivotTable-data
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Activity instructions 
Participate in the activity by following these instructions: 

1. Review the tutorial with your partner. 

2. The first student teaches their partner how to insert a timeline filter for Harvest 
Date. 

3. The second student teaches their partner how to use the timeline filter. 

Try-it: Create timelines 
 In this standalone try-it activity, you’ll add and use a timeline filter for Sales Date. 

Resources 
You’ll need the following resources for this try-it: 

• Open L4_T3_try_farm_shop_sales_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Insert a timeline filter for Sales Date. 

2. Filter the data to display only the data for June, July, and August. 

3. Clear the timeline filter. 

Wrap-up 
Use these questions to check what you learned in this lesson: 

1. Which areas of a PivotTable must grouped fields be in? 

Select all that apply. 

a. Filter 

b. Rows 

c. Columns 

d. Values 

2. You can insert slicers and timelines from the ________________________ group on the 
Analyze tab. 

Fill in the blank space. 
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Did you know? 

You can also add slicer and timeline filters to regular tables in an 
Excel worksheet. 
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Lesson 5: Using PivotCharts: the 
basics 
Overview 
PivotTables might not be the best choice for all your audiences, especially if some of 
them cannot understand data in a table and a visual depiction. In such situations, 
PivotCharts provide a great way to summarize and present your data in an appealing 
manner. At the end of this lesson, you’ll be able to create and modify PivotCharts. You’ll 
also be able to change the options that affect PivotCharts. 

Warm-up 
Use these questions to find out what you already know about this lesson’s topics: 

1. What is the Field List for a PivotChart called? 

Select the correct option. 

a. PivotTable Fields pane 

b. PivotChart Fields pane 

c. Chart Fields pane 

d. Chart pane 

2. What are some of the area fields of a PivotChart? 

Select all that apply. 

a. Filter 

b. Legend (Series) 

c. Columns 

d. Rows 
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Topic 1: Create PivotCharts 
 PivotTables are great for organizing and summarizing data, but sometimes it's still 

difficult for some people to evaluate the data in a table. PivotCharts provide visual 
representation of the data in a PivotTable and can make it easier for some of your 
audience members to analyze the data. 

Creating a PivotChart 
To create a PivotChart: 

1. Select the PivotTable. 

2. Select the Analyze tab. 

3. Select PivotChart in the Tools group, which the following screenshot depicts. 

 
Figure 26: Tools group on the Analyze tab 

4. Select the desired chart in the Insert Chart dialog box, which the following 
screenshot depicts. 
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Figure 27: Insert Chart dialog box 

5. Select OK. 

 

Video 

To review the video on creating PivotCharts, go to: Create a PivotChart 

Activity: Show me how 
In this activity, your teacher will demonstrate how to insert a PivotChart. 

Resources required 
You’ll need the following resources for this activity: 

• None 
  

https://aka.ms/Create_a_Pivot_Chart
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Activity instructions 
Participate in the activity by following these instructions: 

1. Follow along as the teacher demonstrates how to add a PivotChart. 

2. Ask the teacher clarifying questions. An example is: How can I choose a chart for my 
PivotTable? 

Try-it: Create PivotCharts 
 In this standalone try-it activity, you’ll create a PivotChart of sales by category and 

date. 

Resources 
You’ll need the following resources for this try-it: 

• Open L5_T1_try_farm_shop_sales_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following is the general task that you need to perform during this try-it: 

• Insert a PivotChart of sales by category and date. 

Topic 2: Manipulate options in existing 
PivotCharts 

 You can easily change PivotChart options by using the PivotChart Fields pane. 
This pane has four boxes in which you can place PivotChart fields—Filter, Axis, Legend, 
and Value. How you place fields in these boxes can have a dramatic impact on your 
PivotChart. You can also make changes to PivotCharts by using the same options that 
you use in regular charts. For example, you can change the chart type or add data labels, 
among other tasks. 
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Change fields in existing PivotCharts 
To change the fields in an existing PivotChart: 

1. Select the PivotChart. 

2. If the PivotChart Fields pane does not automatically display on the right, select the 
Analyze tab, and then select Field List in the Show/Hide group. The following 
screenshot depicts the Show/Hide group. 

 
Figure 28: Show/Hide group on the Analyze tab 

3. In the PivotChart Fields pane, which the following screenshot displays, place fields 
in the desired areas. 
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Figure 29: PivotChart Fields pane 

Change elements in an existing PivotChart 
To change the elements in an existing PivotChart: 

1. Select the PivotChart. 

2. Select the Design tab. 

3. Select Add Chart Element in the Chart Layouts group, which the following 
screenshot depicts. 
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Figure 30: Add Chart Element drop-down list in the Chart Layouts group 

4. Add or change chart elements as you require. 

Change the chart type of an existing PivotChart 
To change the chart type of an existing PivotChart: 

1. Select the PivotChart. 

2. Select the Design tab. 

3. Select Change Chart Type in the Type group, which the following screenshot 
displays. 

 
Figure 31: Change Chart Type in the Type group 
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4. Select the desired chart type in the Change Chart Type dialog box, which the 
following screenshot displays. 

 
Figure 32: Change Chart Type dialog box 

Activity: Four corners 
In this activity, your teacher will demonstrate how to manipulate the options in existing 
PivotCharts. Your teacher will then divide the class into four groups. Each group will go 
to a corner of the classroom. The teacher will assign a field box in the PivotChart Fields 
pane to the students in each corner, so that the four corners will be Filter, Legend, Axis, 
and Value. Each group will work together to create a scenario for using that option. 
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Resources required 
You’ll need the following resources for this activity: 

• None 

Activity instructions 
Participate in the activity by following these instructions: 

1. Follow along as the teacher demonstrates how to manipulate options in a 
PivotChart. 

2. Ask the teacher clarifying questions. An example is: How can I change the fields in 
my PivotChart? 

3. Participate with your team in the four-corners activity to create a scenario for your 
team's designated field area. 

Try-it: Manipulate options in existing PivotCharts 
 In this standalone activity, you’ll pivot the fields in a PivotChart and review the 

impact of your selections on the PivotChart. You’ll change the chart elements and chart 
type to accommodate the field changes you made. 

Resources 
You’ll need the following resources for this try-it: 

• Open L5_T2_try_farm_shop_sales_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Move Category to Axis (Categories) field. 

2. Remove the legend and chart title. 

3. Change the chart to a bar chart. 

4. Change the chart height to 5.5". 
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Wrap-up 
Use these questions to check what you learned in this lesson:  

1. What tabs are available in the PivotChart Tools tab? 

Select all that apply. 

a. Analyze 

b. Insert 

c. Design 

d. Format 

2. When you move a PivotChart field from Legend to Axis, you are 
________________________ the chart. 

Fill in the blank space. 
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Lesson 6: Using PivotCharts: 
beyond the basics 
Overview 
This lesson explains how to perform more advanced tasks in a PivotChart. You’ll learn 
how to format, expand, collapse, and display details in a PivotChart. You’ll also be able 
to format a PivotChart and change chart styles. 

Warm-up 
Use these questions to find out what you already know about this lesson’s topics: 

1. You can find Chart Styles on the ________________________ tab of PivotChart Tools. 

Select the correct option. 

a. Insert 

b. Design 

c. Format 

d. Analyze 

2. If you want to expand a PivotChart, you require two or more fields in the 
________________________ field box. 

Select the correct option. 

a. Filter 

b. Legend (Series) 

c. Axis (Categories) 

d. Values 

Topic 1: Apply styles to PivotCharts 
 You can modify the style of your PivotCharts to make them more attractive to your 

audience. You can also change the style to modify the formatting of multiple PivotChart 
elements in one step. 
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Apply chart styles 
To change the style for a PivotChart: 

1. Select the PivotChart. 

2. Select the Design tab. 

3. Select a style from the Chart Styles gallery in the Chart Styles group. Alternatively, 
select Chart Styles (the paintbrush icon) next to the PivotChart on your worksheet, 
and select a style there. The following screenshot depicts the Chart Styles group. 

 
Figure 33: Chart Styles gallery 

4. To change chart colors, select Change Colors in the Chart Styles group. 

Activity: Show me how 
In this activity, your teacher will demonstrate how to apply chart styles to a PivotChart. 

Resources required 
You’ll need the following resources for this activity: 

• None 

Activity instructions 
Participate in the activity by following these instructions: 

1. Follow along as the teacher demonstrates how to add a chart style to a PivotChart. 

2. Ask the teacher clarifying questions. An example is: How can I change PivotChart 
colors? 

Try-it: Apply styles to PivotCharts 
 In this standalone activity, you’ll apply different styles to PivotChart and review the 

effect on your PivotChart. 
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Resources 
You’ll need the following resources for this try-it: 

• Open L6_T1_try_farm_shop_sales_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Apply Style 12 to the PivotChart. 

2. Optionally, change the chart colors. 

Topic 2: Drill down into PivotChart 
details 

 When a PivotChart has two or more fields in the Axis (Categories) box, you can 
expand or collapse the information to display more or fewer details. You can use the 
field buttons to filter the PivotChart data. You can also place a field in the Filter box to 
create an additional filter in the chart. Using these features can help you display the data 
more clearly in your PivotChart. 

Expand or collapse PivotChart details 
To expand or collapse PivotChart details: 

1. Select the Expand Entire Field (plus (+) sign) in the PivotChart to expand the 
PivotChart details. 

2. Select the Collapse Entire Field (minus (-) sign) in the PivotChart to collapse the 
PivotChart details. 

Alternatively, you can select the field in the PivotTable and use the Expand and 
Collapse buttons in the Active Field group of the Analyze tab. The following 
screenshot depicts the Active Field group of the Analyze tab. 

 
Figure 34: Expand/Collapse buttons 
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Display or hide field buttons 
To display or hide field buttons: 

1. Select the PivotChart. 

2. Select the Analyze tab. 

3. Select Field Buttons in the Show/Hide group. 

 
Figure 35: Show/Hide group on the Analyze tab 

4. Choose the desired field buttons to display or hide. 

Filter PivotChart data 
To filter PivotChart data, select a field drop-down box in the PivotChart on your 
worksheet. Select the check boxes for the fields that you want to filter, and then select 
OK. The following screenshot depicts a field drop-down box. 

 
Figure 36: Filter list 
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Additional information 

To review the tutorial on expanding, collapsing, or displaying details in 
a PivotTable or PivotChart, go to: Expand, collapse, or show details in a 
PivotTable or PivotChart 

Activity: Show me how 
In this activity, your teacher will demonstrate how to expand and collapse PivotChart 
details. The teacher will also demonstrate how to use field drop-down boxes to filter the 
data in a PivotChart. 

Resources required 
You’ll need the following resources for this activity: 

• None 

Activity instructions 
Participate in the activity by following these instructions: 

1. Follow along as the teacher demonstrates expand, collapse, and filter a PivotChart. 

2. Ask the teacher clarifying questions. An example is: How can I hide field buttons? 

Try-it: Drill down into PivotChart details 
 In this standalone try-it activity, you’ll expand and collapse a PivotChart. You’ll 

filter the PivotChart by using field drop-down boxes. 

Resources 
You’ll need the following resources for this try-it: 

• Open L6_T2_try_farm_shop_sales_starter.xlsx in this lesson’s Learning Activity 
Resources. 

  

https://aka.ms/Expand-collapse-or-show-details-in-a-PivotTable-or-PivotChart
https://aka.ms/Expand-collapse-or-show-details-in-a-PivotTable-or-PivotChart
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Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Expand the PivotChart to display Quarters. 

2. Expand the PivotChart to display Months. 

3. Filter the PivotChart to display only 2019 data. 

4. Collapse the PivotChart from Months to Quarters. 

Wrap-up 
Use these questions to check what you learned in this lesson: 

1. You can apply chart styles from the Design tab and the ________________________ next 
to the PivotChart. 

Select the correct option. 

a. Chart Elements (the plus sign (+)) 

b. Chart Styles (the paintbrush icon) 

c. Format pane 

d. Table 

2. You can use ________________________ inside a PivotChart to filter data. 

Select the correct option. 

a. A slicer 

b. A timetable 

c. Field drop-down boxes 

d. A filter 
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Glossary 
Calculated field A data field created with a formula. 

Pivot To move a data field from a row to a column or vice versa. 

PivotChart A chart that uses a PivotTable as its source of data. 

PivotTable A table that you can use to summarize, analyze, explore, and present 
data. 

Slicer A stylized filter for a PivotTable. 

Timeline A stylized date filter for a PivotTable. 

Table #: Glossary terms and definitions 
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Cornerstone 
Overview 
In this Cornerstone, you'll use Munson's sales data to make, modify, and format a 
PivotTable. You’ll also create calculated fields, filter data with slicers, and group data. 
You’ll then create and format a PivotChart and drill down into PivotChart details. 

Objectives 
The following table outlines the Cornerstone objectives and their corresponding 
Microsoft Office Specialist (MOS) objectives. 

Understand and 
create PivotTables 

• 4.2.1: Create PivotTables 

Change and format 
PivotTables and the 
data in them 

• 4.2.2: Modify field selections and options 
• 4.2.6: Format data 

Create a calculated 
field in a PivotTable 

• 4.2.5: Add calculated fields 

Filter data with 
slicers and group 
and ungroup data 
in a PivotTable 

• 4.2.3: Create slicers 
• 4.2.4: Group PivotTable data 

Create PivotCharts 
and change 
options that effect 
PivotCharts 

• 4.3.1: Create PivotCharts 
• 4.3.2: Manipulate options in existing PivotCharts 
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Format PivotCharts 
and expand, 
collapse, or display 
details in a 
PivotChart 

• 4.3.3: Apply styles to PivotCharts 
• 4.3.4: Drill down into PivotChart details 

Table 2: Cornerstone objectives 

Duration 
60 minutes 

Instructions 
1. Complete the tasks below for each file. 

2. When saving your file, add your name to the end of the filename, for example: You-
Pick_Day_Dwayne_Espino. Follow your teacher’s directions for where to save your 
files. 

3. When you’re done with the Cornerstone, assess your completion and enter the 
points you think you earned within the task lists below. You can ask your teacher for 
help if required. 

Tasks 
You’ll work with one file in this Cornerstone. The following are the tasks that you need 
to do within the file. 

File 1: Cornerstone_product_sales_2019_starter.xlsx 
Task: Create a PivotTable (20 points) 
• Create a PivotTable displaying Sum of Wholesale, Sum of Markets, and Sum of 

Farm Shop by Category. (20 points) (Exam objective 4.2.1) 

Points scored: ________ /20 

  



Using Microsoft PivotTables and Microsoft PivotCharts 
 

 
62 

Task: Modify and format the PivotTable (20 points) 
1. Add the Date field to Rows in the PivotTable. (5 points) (Exam objective 4.2.2) 

2. Move the Date and Months fields before the Category field in the Rows box of the 
PivotTable. (5 points) (Exam objective 4.2.2) 

3. Change the PivotTable style to Light Blue, Pivot Style Medium 10. (5 points) (Exam 
objective 4.2.2) 

4. Format values in the PivotTable to display as currency with no decimal points. (5 
points) (Exam objective 4.2.6) 

Points scored: ________ / 20 

Task: Perform PivotTable calculations (20 points) 
• Add the Commission field -15% of Markets to the PivotTable. (20 points) (Exam 

objective 4.2.5) 

Points scored: ________ / 20 

Task: Group and filter data (20 points) 
1. Ungroup the Date field in the PivotTable. (5 points) (Exam objective 4.2.4) 

2. Group the Date field in the PivotTable as Qtrs. (5 points) (Exam objective 4.2.4) 

3. Add a Product slicer filter to the PivotTable. (10 points) (Exam objective 4.2.3) 

Points scored: ________ / 20 

Task: Create and modify a PivotChart (20 points) 
1. Create a stacked column chart using the PivotTable (5 points) (Exam objective 4.3.1) 

2. Remove the Commission field from the PivotChart. (5 points) (Exam objective 4.3.2) 

3. Apply Style 9 to the PivotChart. (5 points) (Exam objective 4.3.3) 

4. Collapse the PivotChart to Qtrs. (5 points) (Exam objective 4.3.4) 

Points scored: ________ / 20 

FILE 1 TOTAL POINTS:  ________/100 
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Module overview 
Description 
After you’ve created your workbook, you can maintain and share it by using the options 
that Microsoft Excel 2019 provides. There might be times when you need to review a 
previous version of your work, for example. Or you might need to protect your 
workbook from changes that others make or collaborate with individuals on your work. 
At the end of this module, you’ll be able to revert to older workbook versions, set 
AutoRecover feature options, protect a workbook's structure and content, and manage 
comments. 

The following table outlines the lessons in this module and their corresponding learning 
objectives. 

Lesson Learning objective Exam objective(s) 

Managing 
workbooks 

Manage a workbook's version so that you can 
revert to an older version if necessary and set 
AutoRecover feature options. 

• 1.1.4 

Helping 
protect 
workbooks 
and 
managing 
comments 

Help protect a workbook's content and 
structure and restrict editing. Manage 
comments in a workbook. 

• 1.2.1 
• 1.2.2 
• 1.2.3 
• 1.2.5 

Cornerstone: 
Sharing data 
for a social-
media 
campaign 

Set AutoRecover options, protect a 
workbook's structure and content, and 
manage comments. 

• 1.1.4 
• 1.2.1 
• 1.2.2 
• 1.2.3 
• 1.2.5 

Table 1: Objectives by lesson 
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Scenario 
Munson's Pickles and Preserves Farm has asked you to provide data to the marketing 
department. This data must be real-time data, but the marketing department shouldn't 
be able to change the data that you provide. Your task is to set up the data file for 
sharing, with restricted access to editing the file. 

Cornerstone 
After all the work you completed in Module 3 for the Community Supported Agriculture 
(CSA) team, you need to share data with the marketing team for their use in creating a 
social-media campaign for the farm's new CSA program. The data will be constantly 
updated so that the marketing team has the latest information to share on social media. 
They’ll need to have ongoing access to the Excel workbook. To protect the data, you 
need to restrict their ability to make changes and allow them only to copy data for their 
use and add comments. 
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Lesson 1: Managing workbooks 
Overview 
In this lesson, you’ll learn how to manage a workbook's version history so that you can 
revert it to an older version if necessary. You'll also set AutoRecover options to prevent 
loss of work during unforeseen circumstances such as a power failure. 

Warm-up 
Use these questions to find out what you already know about this lesson’s topics: 

1. You were working on a large Excel workbook that you haven't saved, and your device 
just stopped responding. How can you get your work back? 

Select the correct option. 

a. Use the Print command to print the workbook. 

b. Reopen Excel, and then use the AutoRecover task pane. 

c. Use the Info tab and inspect the workbook. 

d. You can't get your worksheet back. It is gone. 

2. Which of the following is a true statement about version history? 

Select the correct option. 

a. You can only view the current version. 

b. Version history only stays in memory for 24 hours. 

c. You can only maintain version history by saving multiple copies of a file. 

d. You can restore an older version of a file. 

3. Someone has altered the work in your workbook. If you use the 
________________________ option, you can restore your original work. 

Fill in the blank space. 
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Topic 1: Manage workbook versions 
 When you're working with a file that multiple people are constantly updating, you 

might need to review previous versions of the workbook. For example, if someone 
updates the information within the workbook and makes an error, it might be necessary 
to return to an earlier version to correct the error. 

You must ensure that AutoSave is turned on each time a file is opened if you want to 
save the document's version history. 

Turn on version history 
To utilize the version history, you’ll need to save your files to the cloud by using 
Microsoft OneDrive, which is a file hosting service that you can use with Office apps. 

1. Select the File tab to open the Backstage view. 

2. Select Save As. 

3. Double-select the OneDrive option. 

 
Figure 1: OneDrive option 

4. In the Save As dialog box, enter a name for the file in the File name area. 
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Figure 2: Save As dialog box 

5. Select Save. You’ll be returned to your worksheet. 

6. Select the File tab, and then select History. 

7. The History task pane will now show in the workbook view and will list the saved 
history of the file. 

 
Figure 3: History task pane 
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Viewing previous versions 
1. To view a previous version of a workbook file, select the File tab. 

2. Select History. 

3. The History task pane appears on the right side of the workbook screen, listing the 
saved versions. 

4. Selecting one of the listed versions, and open that version in a separate window. 

 

Additional information 

To review information on restoring previous versions, go to: View 
previous versions of Office files 

Activity: Show and tell 
In this activity, you’ll watch as your teacher demonstrates how to access the version 
history. 

Resources required 
Your teacher will use the following resources for this activity: 

• L1_T1_act_solar_data.xlsx in this lesson’s Learning Activity Resources. 

Activity instructions 
Follow along as your teacher demonstrates these instructions: 

1. Select the File tab. 

2. Set the file to save to OneDrive. 

3. Select the File tab, and then select History. 

4. The Version History task pane is displayed. 

5. Select one of the listed versions to open in a separate window. 

Topic 2: Use the AutoRecover feature 
The AutoRecover feature saves a copy of your work at set intervals even if you don't 

save the work on your own. If your device stops responding or there is a loss of power, 
AutoRecover provides a version containing most of your work, depending on how often 
you set the AutoRecover option to save. When you reopen Excel after your system stops 

https://aka.ms/View-previous-versions-of-Office-files
https://aka.ms/View-previous-versions-of-Office-files
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responding or after a power loss, the AutoRecover task pane will appear and the most 
recently saved version will be reinstated. 

Change AutoRecover settings 
1. Select the File tab, and then select Options. 

2. In the Options dialog box, select the Save tab. 

3. In the Save workbooks section, locate the Save AutoRecover information every 
option.

 
Figure 4: The Excel Options dialog box 

4. Use the scroll box to enter a frequency in minutes that you wish to have your work 
recovered automatically. 
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Activity: Student show and tell 
In this activity, a volunteer will attempt to demonstrate how to change the interval 
setting for AutoRecover. Follow along as your classmate demonstrates. 

Resources required 
You’ll need the following resources for this activity: 

• Open a blank workbook or any previously used Excel file found in this lesson’s 
Learning Activity Resources. 

Activity instructions 
Participate in the activity by following these questions as your teacher leads a classmate 
in the demonstration: 

• Which tab do you think you would use to find the AutoRecover option? Explain your 
choice. 

• Within your tab choice, which area do you think would be the best option to 
proceed? Explain your choice. 

• What does the AutoRecover feature do? Does defining AutoRecover help to guide 
you in finding the option? 

• What is the default interval that Excel sets for AutoRecover? 
• What interval do you plan to set AutoRecover? Why did you choose that interval? 
• What other options do you notice within the same area where you set options for 

AutoRecover? Do you find options for AutoRecover location or exceptions? 

Try-it: Use the AutoRecover feature 
 This leveled try-it activity focuses on changing the AutoRecover option within a file. 

Try-it 1 
Resources 
You’ll need the following resources for this try-it: 

• Open L1_T2_try1_solar_data_starter.xlsx in this lesson’s Learning Activity 
Resources. 
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Instructions 
The following are the general tasks that you must perform during this try-it: 

1. Set the AutoRecover option to a 15-minute interval.  

2. Save your work. 

Try-it 2 
Resources 
You’ll need the following resources for this try-it: 

• Open L1_T2_try2_solar_data_starter.xlsx in this lesson’s Learning Activity 
Resources. 

Instructions 
The following are the general tasks that you must perform during this try-it: 

1. Set the AutoRecover option to a 5-minute interval.  

2. Disable AutoRecover for this workbook only. 

3. Save your work. 

Wrap-up 
Use these questions to check what you learned in this lesson:  

1. Which of the following can you change within AutoRecover? 

Select all that apply. 

a. Location where the autorecovered workbook is saved 

b. The type of file format that the workbook is saved in 

c. The time interval defining how often the workbook is saved 

d. Disabling AutoRecover for a workbook 
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2. List the following steps in the appropriate order for creating an AutoRecover setting. 

Indicate the correct sequence by adding numbers 1-4 next to the following items. 

a. Select Options. ________________________ 

b. Set the time interval. ________________________ 

c. Select Save. ________________________ 

d. Select the File tab. ________________________ 

3. Correctly categorize the processes listed below into one of the following two 
categories: 

o Version history 
o AutoRecover 
Categorize the following items by adding the appropriate group name next to each 
item. 

a. Happens at a user-set time ________________________ 

b. Is created each time a workbook is saved ________________________ 

c. Prompts the recovery of unsaved work when a device stops responding or there 
is a power outage ________________________ 

d. Can be used to compare versions ________________________ 
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Lesson 2: Helping protect 
workbooks and managing 
comments 
Overview 
In this lesson, you’ll learn how to share workbooks and restrict editing by applying 
password protection. You’ll also learn how to protect workbook structures and cell 
ranges. 

Warm-up 
Use these questions to find out what you already know about this lesson’s topics: 

1. Which of the following can you prevent by protecting a worksheet's structure?

Select the correct option.

a. Editing data within the worksheet

b. Adding rows and columns to the worksheet

c. Adding, deleting, or moving worksheets

d. Opening the worksheet requires a password

2. Which of the following can you complete with a comment?

Select the correct option.

a. Post a response to a comment.

b. Resolve a comment.

c. Users can make their own comments.

d. All of the above.
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3. Which of the following methods can you use to create a comment? 

Select all that apply. 

a. The context menu 

b. The Insert tab 

c. The Review tab 

d. The Data tab 

4. Which of the following statements are true when protecting a worksheet? 

Select all that apply. 

a. You can specify the areas of the worksheet that users can access. 

b. Once a worksheet is protected, you cannot unprotect it. 

c. You can create a password to access the worksheet. 

d. You can only protect a worksheet with a password. 

5. To share a worksheet with another user, you’ll need to know the other person's 
________________________. 

Fill in the blank space. 

Topic 1: Restrict editing 
 Often, when you create a workbook, you might want to permit other users to edit 

some areas, while protecting other areas from changes. In this topic, you’ll learn how to 
restrict access to and editing in your workbook. 

Share a workbook 
To share a workbook, perform the following steps: 

1. Select the Share option on the top-right corner of the Excel window. You could also 
select File and then select Share. 

2. Enter the email addresses of the people with whom you wish to share the workbook. 

3. Add a message if necessary. 

4. Select Send. 

5. Owners of the email addresses will receive a copy of your file and will be able to 
open and edit it. 
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Apply a password to protect a workbook 
Another method to share a workbook is to share a file by using a shared drive or other 
method such as a flash drive. When you share a workbook by using this method, you 
can assign a password so that only those with the password can open the workbook. 

1. Select the File tab, select Info, and then select Protect Workbook. 

2. The Protect Workbook menu appears, as depicted in the following screenshot. 

 
Figure 5: Protect Workbook menu options 

3. Select one of the following sharing options within the Protect Workbook menu: 

o Always Open Read-Only. Anyone can display the workbook, but no one can 
make changes to it. 

o Encrypt with Password. Only those with a password can open the workbook. 
o Protect Current Sheet. The sheet within the workbook that is currently open is 

protected. 
o Protect Workbook Structure. Others can display the workbook, but cannot add, 

delete, move, or display hidden sheets. 
o Restrict Access. Others can access the workbook but have restricted access.  
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o Add a Digital Signature. The creator can add an invisible signature to the 
workbook. 

o Mark as Final. Anyone displaying the workbook knows that this is the final 
version. 

4. Enter a password in the Encrypt Document dialog box and confirm the password. 

5. To protect a worksheet, select Protect Current Sheet. 

6. In the Protect Sheet dialog box, select the items that you wish to permit all users of 
this worksheet to be able to do from those listed. 

7. Enter a password in the Password to unprotect sheet box, as the following 
screenshot depicts. 

 
Figure 6: Protect Sheet dialog box 
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8. Confirm the entered password in the Confirm Password dialog box, as the following 
screenshot depicts. 

 
Figure 7: Confirm Password dialog box 

9. Select OK. 

The worksheet is now protected with the password. Users can only edit it if you remove 
protection by using the entered password. 

Unprotect a worksheet 
1. Open the worksheet to unprotect. 

2. Select File, and then select Info. 

3. In the Protect Workbook area that the following screenshot depicts, select 
Unprotect. 

 
Figure 8: Protect Workbook area 

4. In the Unprotect Sheet dialog box, enter the password that you used to protect the 
worksheet, as the following screenshot depicts. 

 
Figure 9: Unprotect Sheet password dialog box 
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The worksheet is now unprotected, and anyone can edit the file. 

 

Additional information 

To review a video on sharing your Excel workbook, go to: Share your 
Excel workbook with others 

 

Additional information 

For more information on protecting worksheet, go to: Protect a 
worksheet 

Activity: Discuss and learn 
You can restrict the editing of a workbook in two ways. The first way is to share the 
workbook with specific people who can display and edit the file. The second way is to 
assign the workbook a password and share that password with others to access the 
workbook on a shared directory. This activity will focus on creating a password to share 
your workbook. 

Resources required 
Your teacher will use the following resource for this activity: 

• L2_T1_act_solar_data_starter.xlsx in this lesson’s Learning Activity Resources. 

Activity instructions 
Follow along as your teacher completes the activity by following these instructions: 

1. Use the Share option to share the workbook with a classmate. 

2. Password protect the workbook by using the password Fl0w3r721. 

Compare the options for restricting the editing of a workbook to using a password to 
protect a workbook. Can you name a scenario in which you might use each option? 

Try-it: Restrict editing 
 In this standalone try-it activity, you’ll restrict the editing of a worksheet by 

applying a password. 

  

https://aka.ms/Share_a_workbook
https://aka.ms/Share_a_workbook
https://aka.ms/Protect-a-worksheet
https://aka.ms/Protect-a-worksheet
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Try-it 
Resources 
You’ll need the following resources for this try-it: 

• Open L2_T1_try_solar_data_starter.xlsx in this lesson’s Learning Activity Resources. 

Instructions 
The following are the general tasks that you must perform during this try-it: 

1. Protect the worksheet from editing by using the password mUn50n57211. 

2. Save your work. 

3. Share your work with a classmate. 

4. Open the file shared with you by your classmate and use the password to access the 
file. 

Topic 2: Help protect worksheets and 
cell ranges 

 There will be times when you might want a user to be able to edit portions of a 
workbook but not the entire workbook. You might want the user to enter their own 
information into specific cells and that information can then determine other protected 
data within the workbook. 

Unlock cells 
The first step in the process of restricting access to specific cells within a workbook is to 
determine which cells you want to preserve. Often, cells containing a formula calculation 
are important and need to be preserved from edits by others. 

Identify those cells that you want to allow others to edit within your workbook. This 
might seem counterproductive, but you need to identify those cells that can be edited 
prior to locking the rest of the workbook. 
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Did you know? 

You can select multiple noncontiguous cells (cells that aren't adjacent 
to each other) by holding down the Ctrl key and then selecting those 
cells. 

1. Select the cells that you want to allow the user to edit. 

2. Right-click or access the context menu anywhere within the worksheet, and then 
select Format Cells, as depicted in the following screenshot. 

 
Figure 10: Format Cells option 

3. In the Format Cells dialog box, select the Protection tab, as the following 
screenshot depicts. 

 
Figure 11: Format Cells dialog box with the Protection tab selected 

4. Clear the Locked check box. 

5. Select OK. 

This process will unlock the selected cells when the worksheet is protected or locked. 
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Lock cells 
1. Select the Review tab. 

2. In the Protect group, select Protect Sheet, as the following screenshot depicts. 

 
Figure 12: Protect Sheet in the Review tab 

3. In the Protect Sheet dialog box, you can select areas of the worksheet that you want 
users to be able to change. The Select unlocked cells option is selected by default, 
as the following screenshot depicts. Therefore, users will be able to edit the cells that 
you unlock. 

 
Figure 13: Protect Sheet dialog box 

4. You can choose to enter a password to access any locked areas if you wish. Entering 
a password prevents others from unlocking the cells that you have locked. 

5. After making your choices, select OK. 

Allow edit ranges 
In Excel, you can identify a range of cells that users can edit by using a password. To do 
so, perform the following steps: 

1. Select the range of cells that you want users to be able to edit by using a password. 

2. On the Review tab, in the Protect group, select Allow Edit Ranges, as the following 
screenshot depicts. 
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Figure 14: Allow Edit Ranges option  

3. In the Allow Users to Edit Ranges dialog box, select New, as the following 
screenshot depicts. 

 
Figure 15: Allow Users to Edit Ranges dialog box. 

4. In the New Range dialog box, enter a name for the range of selected cells in the 
Title box, as the following screenshot depicts. 

 
Figure 16: New Range dialog box 
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5. Enter a password in the Range password box, and then select OK. 

6. Confirm the password in the Confirm Password dialog box. 

7. Select OK. 

8. In the Allows User to Edit Ranges dialog box, select Protect Sheet. 

9. In the Protect Sheet dialog box, enter a password. 

10. Confirm the password. 

Unprotect a worksheet 
Use the following procedure to unprotect a worksheet. 

1. On the Review tab, in the Protect group, select Unprotect Sheet, as the following 
screenshot depicts. 

 
Figure 17: Unprotect Sheet 

2. Enter the password to unprotect the sheet. 

Help protect workbook structure 
Protecting the structure of a workbook means that users won’t be able to move, add, 
delete, or rename worksheets without first unprotecting the workbook or providing a 
password. 

1. On the Review tab, in the Protect group, select Protect Workbook, as the following 
screenshot depicts. 

 
Figure 18: Protect Workbook options 
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2. In the Protect Structure and Windows dialog box, enter a password if you want to 
password-protect the workbook structure, and then select OK, as the following 
screenshot depicts. 

 
Figure 19: Protect Structure dialog box 

3. Reenter the password in the Confirm Password dialog box, as the following 
screenshot depicts, and then select OK. 

 
Figure 20: Confirm Password dialog box 

Name a cell or cell range 
Naming a cell or a range of cells can make it easier to remember and refer to than 
referring to the cell or cell range by the cell reference (example, the cell reference C5: 
C32 versus the named range Income). 

To name a cell or cell range, perform the following steps: 

1. Select the cell or cell range that you want to name. 

2. In the Name box above the spreadsheet, enter a name for the cell or cell range, as 
the following screenshot depicts. Note: You cannot include spaces in the name. An 
underscore can replace the space. 
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Figure 21: Name box 

3. Select the Enter key to save the name for the cell or cell range. 

 

Additional information 

For more information on protecting worksheets, go to: Protect a 
worksheet 

For more information on protection and security in Excel, go to: 
Protection and security in Excel 

Activity: Discuss and learn  
When protecting a worksheet, you might want to allow the user to modify portions of 
the worksheet. It is important to identify these portions to help ensure that the user can 
enter information in those, while also maintaining protection for other portions of the 
worksheet. This activity will focus on identifying those areas as well as naming them. 

Resources required 
You’ll need the following resource for this activity: 

• Open L2_T2_act_time_sheet.xlsx in this lesson’s Learning Activity Resources. 

Activity instructions 
Participate in the activity by following these instructions: 

With the Time Sheet tab open, answer the following questions: 

• Are there cells that you might want to protect from editing? Which cells are those? 
• Are there cells that you would want users to edit? Which cells should users be able to 

edit? 
• Why did you make each of these decisions?  
• Which type of protection would serve best to provide protection for this workbook? 
• How would you name or label each area that you would want to protect? 

Try-it: Help protect worksheets and cell ranges 
 In this leveled try-it activity, you will restrict the editing of different components 

within a workbook. 

https://aka.ms/Protect-a-worksheet
https://aka.ms/Protect-a-worksheet
https://aka.ms/protection-and-security-in-excel
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Try-it 1 
Resources 
You’ll need the following resources for this try-it: 

• Open L2_T2_try1_time_sheet_starter.xlsx in this lesson’s Learning Activity 
Resources. 

• Locate the L2_T1_try_solar_data_starter.xlsx file you password-protected in the 
previous try-it. 

Instructions 
The following are the general tasks that you must perform during this try-it: 

1. In L2_T2_try1_time_sheet_starter.xlsx, allow a user to edit the Employee Name 
area (C3) and the cells containing Hours Worked (C5:C11). 

2. Save your work. 

3. Unprotect L2_T1_try_solar_data_starter.xlsx by using the password mUn50n57211. 

Try-it 2 
Resources 
You’ll need the following resources for this try-it: 

• Open L2_T2_try2_price_list_starter.xlsx in this lesson’s Learning Activity Resources. 

Instructions 
The following are the general tasks that you must perform during this try-it: 

1. Name the cell containing the text Customer Name (C3), Customer_Name. 

2. Name the cell range containing the Quantity Ordered (D5:D11), 
Quantity_Ordered. 

3. Allow a user to edit the cells containing the Customer Name (C3) and the Quantity 
Ordered (D5:D11). 

4. Protect the worksheet. 

5. Save your work and close the workbook. 

6. Reopen L2_T2_try2_price_list.xlsx and try editing different areas of the workbook. 

7. Unprotect the worksheet by using the password that you assigned. 

8. Save your work. 
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Try-it 3 
Resources 
You will need the following resources for this try-it: 

• Open L2_T2_try3_price_list_starter.xlsx in this lesson’s Learning Activity Resources. 

Instructions 
The following are the general tasks that you need to perform during this try-it: 

1. Unprotect the cells containing the Customer Name (C3) and the Quantity Ordered 
(D5:D11). 

2. Protect the workbook structure. 

3. Save your work. 

Topic 3: Manage comments 
 You can use comments to participate in a conversation between team members. 

After a user makes an initial comment, others can respond to the comment, make their 
own comment, or mark a comment as resolved. 

Add comments 
There are two ways to add comments within a worksheet—the context menu and the 
Review tab. To add a comment in a worksheet by using the context menu, perform the 
following steps: 

1. Select the cell in which you want to add a comment. 

2. Right-click or access the context menu, and then select Insert Comment, as the 
following screenshot depicts. 
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Figure 22: New Comment option on the context menu 

3. Enter your comment in the Comment box as the following screenshot depicts. 

 
Figure 23: Comment box 

To add a comment by using the Review tab, perform the following steps: 

1. Select the cell in which you want to add a comment. 

2. On the Review tab, in the Comments group, select New Comment. The following 
screenshot depicts the Comments group. 

 
Figure 24: The Comments group 

3. Enter your comment in the Comment box. 
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Delete comments 
You can delete comments within a worksheet by using the context menu or the Review 
tab. To delete a comment by using the context menu, perform the following steps: 

1. Right-click or access the context menu for the cell from which you want to delete a 
comment. 

2. Select Delete Comment, as the following screenshot depicts.

 
Figure 25: Delete Comment option on the context menu 

To delete a comment by using the Review tab, perform the following steps: 

1. In the Comments task pane, select the comment that you want to delete. 

2. On the Review tab, in the Comments group, select Delete, as the following 
screenshot depicts. 

 
Figure 26: Delete comment option 
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Edit comments 
You can edit any comment by performing the following steps: 

1. Access the cell containing the comment that you wish to edit, and then select Edit 
Comment within the Comments area. 

 
Figure 27: Edit Comment option 

2. Select within the comment and edit the comment as needed. 

Print comments 
You can print comments by performing the following steps: 

1. On the Page Layout tab, in the Page Setup group, select the dialog box launcher 
that the following screenshot highlights. This opens the Page Setup dialog box. 

 
Figure 28: Page Setup dialog box launcher 

2. In the Page Setup dialog box, select the Sheet tab, and then locate the Comments 
drop-down box that the following screenshot highlights. 
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Figure 29: Sheet tab and Comments drop-down box 

3. Select At end of sheet as the following screenshot depicts, and then select OK. 

 
Figure 30: At end of sheet selected for comment printing 

Change the display name for comments 
When you leave comments, it is helpful to attach your name to the comment. You can 
easily change the name that displays with the comment. To do so, perform the following 
steps: 

1. Select the File tab, and then select Options. 

2. In the Personalize your copy of Microsoft Office dialog box, in the User name  
box, verify or change the username to your name, as the following screenshot 
depicts. 

 
Figure 31: Change username 

3. Select OK. 
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Additional information 

To obtain information about formatting a comment, go to: Format 
worksheet comments 

Activity: Pose a question 
Comments are a great way for you to add notes for yourself or others about the data 
and information within a worksheet. This activity will focus on the management of 
comments within a worksheet. 

Resources required 
You’ll need the following resources for this activity: 

• Open L2_T3_act_solar_array_starter.xlsx in this lesson’s Learning Activity Resources. 

Activity instructions 
Participate in the activity by following these instructions: 

1. Delete the comment in cell B8. 

2. Verify or change the name that is associated with the comments. Make sure that 
your name appears with the comments that you make. 

3. Add a comment to cell A6 with the text Why is the data for Wednesdays missing?. 

4. Edit the comment in cell B3 with the text Can anyone provide an explanation why 
production was so low during Week 1?. 

5. Set the comments to print at the end of the worksheet. 

Try-it: Manage comments 
 In this leveled try-it activity, you’ll add, delete, and edit the comments in the 

worksheet. 

Try-it 1 
Resources 
You’ll need the following resources for this try-it: 

• Open L2_T3_try1_price_list_starter.xlsx in this lesson’s Learning Activity Resources. 

https://aka.ms/Format-worksheet-comments
https://aka.ms/Format-worksheet-comments
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Instructions 
The following are the general tasks that you must perform during this try-it: 

1. Delete the comment in cell A5.

2. Save your work.

Try-it 2 
Resources 
You’ll need the following resources for this try-it: 

• Open L2_T3_try2_price_list_starter.xlsx in this lesson’s Learning Activity Resources.

Instructions 
The following are the general tasks that you must perform during this try-it: 

1. Edit the comment in cell F4 with the text Will the sales tax rate be changing next
month?.

2. Set the document so that the comments will print at the end of the worksheet.

3. Follow your teacher's directions on whether to print the worksheet.

4. Save your work.

Wrap-up 
Use these questions to check what you learned in this lesson: 

1. Which of the following can you protect by using Excel?

Select the correct option.

a. An entire workbook

b. A worksheet

c. A range of cells except for those identified as editable

d. All the above
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2. Which of the following are ways to control the sharing of your worksheet?

Select all that apply.

a. Control access to the worksheet by using a password.

b. Protect the worksheet as a read-only copy.

c. Protect the worksheet by using a function.

d. Use the Share option to share your work with others by using their email
addresses.

3. Which of the following can you use comments for in Excel?

Select the correct option.

a. To edit the data contained within a cell

b. To protect the contents of a cell

c. To start a conversation about data within a cell

d. To add information to data contained within a cell

4. Place the following steps in the correct order to help protect specific areas of a
worksheet.

Indicate the correct sequence by adding numbers 1-4 next to the following items.

a. Select the Format Cells option. ________________________

b. Select cells to allow users to edit. ________________________

c. Select the Protection tab. ________________________

d. Right-click or access the context menu. ________________________

e. Clear the Locked check box. ________________________

5. Place the following steps in the correct order to protect a worksheet.

Indicate the correct sequence by adding numbers 1-4 next to the following items.

a. Select Protect Workbook. ________________________

b. Select Encrypt with Password. ________________________

c. Select Info. ________________________

d. Select the File tab. ________________________
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Glossary 
AutoRecover A feature that helps recover unsaved work after your system 

stops responding or a power failure. 

Cell range A group of cells, either contiguous or noncontiguous, that 
have been identified for a specific process.  

Cloud storage 
service 

A service provided by a company such as Microsoft that allows 
users to store, access, sync and share files using the Internet. 

Comments A mode of discussion between users in Excel. One person 
posts an initial comment and others can respond. 

Contiguous Cells within a worksheet that are adjacent or next to each 
other. 

History Listing of saved versions of a workbook. 

Noncontiguous Cells within a worksheet that are not adjacent or next to each 
other. 

Notes A mode of adding annotations or details about the data within 
a cell to be created. 

Table 2: Glossary terms and definitions 
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Cornerstone 
Overview 
After all the work you completed in Module 3 for the Community Supported Agriculture 
(CSA) team, you need to share data with the Munson’s Marketing Team for their use in 
creating a social-media campaign for the farm's new CSA program. The data will be 
constantly updated so that the marketing team has the latest information to share on 
social media. They’ll need to have ongoing access to the workbook. To protect the data, 
you must restrict their ability to make changes and allow them only to copy data for 
their use and add comments. 

Objectives 
The following table outlines the Cornerstone objectives and their corresponding 
Microsoft Office Specialist (MOS) exam objectives. 

Manage workbooks • 1.1.4: Manage workbook versions 
Workbook protection • 1.2.1: Restrict editing 

• 1.2.2: Protect worksheet and cell 
ranges 

• 1.2.3: Protect workbook structure 
• 1.2.5: Manage comments 

Table 3: Cornerstone objectives mapped to MOS exam objectives 

Duration 
50 minutes 

Instructions 
1. Complete the tasks below for each file. 

2. When saving your file, add your name to the end of the filename, for example: 
<“You-Pick_Day_Dwayne_Espino”>. Follow your teacher’s directions for where to 
save your files.  

3. When you’re done with the Cornerstone, assess your completion and enter the 
points you think you earned within the task lists below. You can take the help of your 
teacher if required. 
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Tasks 
You’ll work with one Excel file with two worksheets in this Cornerstone. The following 
are the tasks that you must do within each sheet. 

File 1: Cornerstone_CSA_program_starter.xlsx 
Task: Manage workbook versions (4 points) 
1. Turn on version history for the workbook. (2 points) (Exam object 1.1.4) 

2. Set the workbook to AutoRecover every 10 minutes. (2 points) (Exam objective 1.1.4) 

Points scored: ________ / 4 

Task: Workbook protection and comments (16 points) 
1. Change the username to your name. (1 point) (Exam objective 1.2.5) 

2. On the 3rd Quarter worksheet, delete the comment from B6. (1 point) (Exam 
objective 1.2.5) 

3. In the July worksheet, place a comment in C17 with the text Will we be able to 
offer apples in larger quantities? We’ve had customers ask for larger quantities. 
(2 points) (Exam objective 1.2.5) 

4. In the July worksheet, place a comment in G5 with the text What profit margin are 
we hoping to receive from the sales of our product each month?. (2 points) 
(Exam objective 1.2.5) 

5. Protect the 3rd Quarter worksheet by using the password CaPsT0n3. (3 points) 
(Exam objective 1.2.1) 

6. In the July worksheet, set the cell range D6:D18 to be unlocked. (2 points) (Exam 
objective 1.2.2) 

7. Protect the July worksheet, while allowing the cell range D6:D18 to be unlocked, by 
using the password CaPsT0n3. (3 points) (Exam objective 1.2.2) 

8. Protect the workbook structure by using the password CaPsT0n3. (2 points) (Exam 
objective 1.2.3) 

Points scored: ________ / 16 

TOTAL POINTS: ________ / 20 
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